Bug 998903 - [vdsm][gluster] connectStorageServer is failing in case host is part of a combined virt-gluster cluster
[vdsm][gluster] connectStorageServer is failing in case host is part of a com...
Status: CLOSED DUPLICATE of bug 996870
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
x86_64 Unspecified
unspecified Severity high
: ovirt-3.6.3
: 3.6.0
Assigned To: Allon Mureinik
Aharon Canan
storage
:
Depends On:
Blocks: RHEV_HyperConverged_SLA
  Show dependency treegraph
 
Reported: 2013-08-20 06:22 EDT by Elad
Modified: 2016-03-10 01:25 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-09 13:25:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
scohen: needinfo+


Attachments (Terms of Use)
logs (8.40 MB, application/x-gzip)
2013-08-20 06:22 EDT, Elad
no flags Details

  None (edit)
Description Elad 2013-08-20 06:22:54 EDT
Created attachment 788407 [details]
logs

Description of problem:
We have a virt cluster that gluster service is enable on it (configured manually on DB). When trying to connect second host to storage server it fails with:
AttributeError: 'FileLikeLogger' object has no attribute 'flush'


Version-Release number of selected component (if applicable):
vdsm-gluster-4.10.2-23.0.1.el6rhs.noarch
vdsm-4.10.2-23.0.1.el6rhs.x86_64


How reproducible:
100%

Steps to Reproduce:
Have a virt cluster with connected block pool
- on vds_groups change:
psql -U postgres engine -c "UPDATE vds_groups SET gluster_service = 't' where name = 'cluster_name'";
so the cluster will support gluster service also
- make sure the hosts contains vdsm-gluster package and that gluster service is running
- create new volume from one of the host bricks (need to have a file system on the brick path on the host) (on volumes tab on UI)
- add a second host to the cluster

Actual results:
Cannot add a second host to the cluster, vdsm fails in connectStorageServer:

Thread-130::ERROR::2013-08-20 10:33:36,175::hsm::2298::Storage.HSM::(connectStorageServer) Could not connect to storageServer
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/hsm.py", line 2295, in connectStorageServer
    conObj.connect()
  File "/usr/share/vdsm/storage/storageServer.py", line 302, in connect
    return self._mountCon.connect()
  File "/usr/share/vdsm/storage/storageServer.py", line 208, in connect
    fileSD.validateDirAccess(self.getMountObj().getRecord().fs_file)
  File "/usr/share/vdsm/storage/fileSD.py", line 54, in validateDirAccess
    (os.R_OK | os.X_OK))
  File "/usr/share/vdsm/supervdsm.py", line 76, in __call__
    return callMethod()
  File "/usr/share/vdsm/supervdsm.py", line 67, in <lambda>
    **kwargs)
  File "<string>", line 2, in validateAccess
  File "/usr/lib64/python2.6/multiprocessing/managers.py", line 740, in _callmethod
    raise convert_to_error(kind, result)
AttributeError: 'FileLikeLogger' object has no attribute 'flush'


Expected results:
It should be possible to add more than one host to gluster-virt cluster

Additional info: logs
Comment 1 Allon Mureinik 2013-08-21 03:54:36 EDT
(In reply to Elad from comment #0)
> Steps to Reproduce:
> Have a virt cluster with connected block pool
> - on vds_groups change:
> psql -U postgres engine -c "UPDATE vds_groups SET gluster_service = 't'
> where name = 'cluster_name'";
> so the cluster will support gluster service also
This configuration is not currently supported for RHEVM (see RFE in bug 996870).
Until we decide to tackle this RFE, there is no point in addressing this bug (actually, this bug probably blocks this RFE)
Comment 4 Ayal Baron 2014-01-09 13:25:31 EST
Should be covered anyway in basic testing of bug 996870 so closing as dup.

*** This bug has been marked as a duplicate of bug 996870 ***

Note You need to log in before you can comment on or make changes to this bug.