Bug 999118 - Bounded thread pool creation fails due to missing required parameter queue-length
Bounded thread pool creation fails due to missing required parameter queue-le...
Status: CLOSED NEXTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
JON 3.1.2
Unspecified Unspecified
urgent Severity high
: ER01
: JON 3.1.3
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 14:54 EDT by Larry O'Leary
Modified: 2013-09-04 12:08 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 997665
: 999119 (view as bug list)
Environment:
Last Closed: 2013-09-04 12:08:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 453653 None None None Never

  None (edit)
Description Larry O'Leary 2013-08-20 14:54:45 EDT
This fix needs to be back-ported to the 3.1.x release.

+++ This bug was initially created as a clone of Bug #997665 +++

Description of problem:
Thread pools of type bounded-queue-thread-pool and blocking-bounded-queue-thread-pool fail to be created due to missing queue-length property which is required. 

Version-Release number of selected component (if applicable):
4.4.0.JON312GA

How reproducible:
Always

Steps to Reproduce:
1.  Install, configure, and start EAP 6 standalone server.
2.  Start JBoss ON system.
3.  Import EAP 6 standalone server into inventory.
4.  Configure EAP resource's connection properties.
5.  Create a new *thread pool* with the minimum set of required properties for the EAP resource:

    Navigate to *JBossAS7 Standalone Servers / EAP (127.0.0.1:9990)* and right-clicking on *thread > Create Child -> Thread Pool*:

        *New Resource Name*: `TestBoundedPool`
        *Resource Configuration Template*: `Bounded Queue Thread Pool`
        *Max Threads*: `10`
        *Keepalive Time*:
            *Time*: `10`
            *Unit*: `seconds`


Actual results:
Thread pool is not created and child history page reports failure with the following error message:

    JBAS014746: queue-length may not be null, rolled-back=true

Expected results:
Queue Length should be a property value on the create wizard and the thread pool should be created successfully 

Additional info:
I am not sure if thread pool configuration parameters have changed between versions or not so we should be careful here as I am not sure how we missed this in the original implementation.
Comment 1 Larry O'Leary 2013-09-04 12:08:32 EDT
Closing as there will be no 3.1.3 release. This is being tracked for 3.2 in 997665.

Note You need to log in before you can comment on or make changes to this bug.