Bug 997665 - Bounded thread pool creation fails due to missing required parameter queue-length
Bounded thread pool creation fails due to missing required parameter queue-le...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
JON 3.1.2
Unspecified Unspecified
urgent Severity high
: ER01
: JON 3.2.0
Assigned To: Simeon Pinder
Mike Foley
:
: 997662 (view as bug list)
Depends On:
Blocks: 999119
  Show dependency treegraph
 
Reported: 2013-08-15 19:40 EDT by Larry O'Leary
Modified: 2014-01-02 15:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 999118 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 453653 None None None Never

  None (edit)
Description Larry O'Leary 2013-08-15 19:40:58 EDT
Description of problem:
Thread pools of type bounded-queue-thread-pool and blocking-bounded-queue-thread-pool fail to be created due to missing queue-length property which is required. 

Version-Release number of selected component (if applicable):
4.4.0.JON312GA

How reproducible:
Always

Steps to Reproduce:
1.  Install, configure, and start EAP 6 standalone server.
2.  Start JBoss ON system.
3.  Import EAP 6 standalone server into inventory.
4.  Configure EAP resource's connection properties.
5.  Create a new *thread pool* with the minimum set of required properties for the EAP resource:

    Navigate to *JBossAS7 Standalone Servers / EAP (127.0.0.1:9990)* and right-clicking on *thread > Create Child -> Thread Pool*:

        *New Resource Name*: `TestBoundedPool`
        *Resource Configuration Template*: `Bounded Queue Thread Pool`
        *Max Threads*: `10`
        *Keepalive Time*:
            *Time*: `10`
            *Unit*: `seconds`


Actual results:
Thread pool is not created and child history page reports failure with the following error message:

    JBAS014746: queue-length may not be null, rolled-back=true

Expected results:
Queue Length should be a property value on the create wizard and the thread pool should be created successfully 

Additional info:
I am not sure if thread pool configuration parameters have changed between versions or not so we should be careful here as I am not sure how we missed this in the original implementation.
Comment 1 Larry O'Leary 2013-08-15 19:42:00 EDT
*** Bug 997662 has been marked as a duplicate of this bug. ***
Comment 3 Simeon Pinder 2013-08-30 15:41:12 EDT
The BZ is a mix of two different issues(also 998058), but the fix for queue-length is in this commit to release/jon3.1.x: 9fd18e80cc73c3804.

Because the configuration property mentions 'blocking-bounded-queue-thread-pool' as well I suggest applying the fix for 998058 alongside this one.
Comment 4 Simeon Pinder 2013-08-30 16:30:56 EDT
See https://bugzilla.redhat.com/show_bug.cgi?id=1003114 for minor issue around units designation when creating Thread Pool instances for EAP 6.0.0.GA.
Comment 5 Simeon Pinder 2013-08-31 11:34:34 EDT
Along with commit(e76d5a4) from BZ 998058 this should be available for testing for hotfix.

Moving this to MODIFIED for testing in ER01.
Comment 6 Sunil Kondkar 2013-10-07 09:41:22 EDT
Verified on Version: 3.2.0.ER2 Build Number: 9bf6f76:371eac0

Installed and imported EAP 6.1 standalone server. The Create New Resource of Type [ThreadPool] page has the property 'Queue Length'.

Created thread pools of type bounded-queue-thread-pool and blocking-bounded-queue-thread-pool successfully by entering value in the requied 'Queue Length' property.

Note You need to log in before you can comment on or make changes to this bug.