Bug 999127 - Unable to create or manage thread pools due to missing type definitions for blocking-bounded-queue-thread-pool and blocking-queueless-thread-pool
Unable to create or manage thread pools due to missing type definitions for b...
Status: CLOSED NEXTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
JON 3.1.2
Unspecified Unspecified
urgent Severity high
: ER01
: JON 3.1.3
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 15:07 EDT by Larry O'Leary
Modified: 2013-09-04 12:12 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 998058
: 999128 (view as bug list)
Environment:
Last Closed: 2013-09-04 12:12:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 457553 None None None Never

  None (edit)
Description Larry O'Leary 2013-08-20 15:07:27 EDT
Back-port to release 3.1.x.

+++ This bug was initially created as a clone of Bug #998058 +++

Description of problem:
You can not create or manage an EAP 6 thread pool that is of one of the following types:

    blocking-bounded-queue-thread-pool
    blocking-queueless-thread-pool

Version-Release number of selected component (if applicable):
4.4.0.JON312GA

How reproducible:
Always

Steps to Reproduce:
1.  Install, configure, and start EAP 6 standalone.
2.  Start JBoss ON system.
3.  Import EAP standalone into JON inventory.
4.  Attempt to create a thread pool under the EAP standalone server of the following types (resource template drop-down):

        blocking-bounded-queue-thread-pool
        blocking-queueless-thread-pool

Actual results:
Thread pools can not be created because the target types are not available in JBoss ON.

Expected results:
These types should be visible in the resource template drop-down and on the create chilid detail page.

Additional info:
Please note that you can create these thread pools directly in EAP's management console or using jboss-cli and although they will be discovered, their configuration is invalid due to the missing thread pool types.
Comment 1 Larry O'Leary 2013-09-04 12:12:20 EDT
Closing as there will be no 3.1.3 release. This is being tracked for the 3.2 release in 997669.

Note You need to log in before you can comment on or make changes to this bug.