Bug 998058 - Unable to create or manage thread pools due to missing type definitions for blocking-bounded-queue-thread-pool and blocking-queueless-thread-pool
Unable to create or manage thread pools due to missing type definitions for b...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
JON 3.1.2
Unspecified Unspecified
urgent Severity high
: ER01
: JON 3.2.0
Assigned To: Simeon Pinder
Mike Foley
:
Depends On:
Blocks: 999128
  Show dependency treegraph
 
Reported: 2013-08-16 18:15 EDT by Larry O'Leary
Modified: 2014-01-02 15:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 999127 (view as bug list)
Environment:
Last Closed: 2014-01-02 15:33:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 457553 None None None Never

  None (edit)
Description Larry O'Leary 2013-08-16 18:15:19 EDT
Description of problem:
You can not create or manage an EAP 6 thread pool that is of one of the following types:

    blocking-bounded-queue-thread-pool
    blocking-queueless-thread-pool

Version-Release number of selected component (if applicable):
4.4.0.JON312GA

How reproducible:
Always

Steps to Reproduce:
1.  Install, configure, and start EAP 6 standalone.
2.  Start JBoss ON system.
3.  Import EAP standalone into JON inventory.
4.  Attempt to create a thread pool under the EAP standalone server of the following types (resource template drop-down):

        blocking-bounded-queue-thread-pool
        blocking-queueless-thread-pool

Actual results:
Thread pools can not be created because the target types are not available in JBoss ON.

Expected results:
These types should be visible in the resource template drop-down and on the create chilid detail page.

Additional info:
Please note that you can create these thread pools directly in EAP's management console or using jboss-cli and although they will be discovered, their configuration is invalid due to the missing thread pool types.
Comment 2 Simeon Pinder 2013-08-31 11:25:24 EDT
This is fixed with the following commit to release/jon3.1.x: e76d5a4ca28da78

This should be ready to be applied to the hotfix branch, but also needs commit from https://bugzilla.redhat.com/show_bug.cgi?id=997665 (9fd18e8) which is another issue that would stop blocking-bounded-queue-thread-pool from being created.

Moving this to MODIFIED and to be available for test in ER01.  

Larry the fixes have also been pushed to master and release/jon3.1.x, so you can verify the behavior with a recent build as well. Can you verify this behavior? Is this ready for hotfix?
Comment 3 Larry O'Leary 2013-09-16 17:19:32 EDT
Moving back to MODIFIED as this is not yet available in a build for testing.
Comment 4 Larry O'Leary 2013-09-16 17:20:16 EDT
Reassigning to spinder as he is the developer who worked this issue. I think Libor may have been assigned in error.
Comment 5 Sunil Kondkar 2013-10-07 07:57:01 EDT
Verified on Version: 3.2.0.ER2 Build Number: 9bf6f76:371eac0

Installed and imported EAP6.1 and successfully created below threadpol types
blocking-bounded-queue-thread-pool
blocking-queueless-thread-pool

These types are visible in the resource configuration template drop-down on the Create New Resource of Type [ThreadPool] page.

Note You need to log in before you can comment on or make changes to this bug.