Bug 999554 - No Quickstarts installation path validation
No Quickstarts installation path validation
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity medium
: ER3
: EAP 6.2.0
Assigned To: Francisco Canas
Petr Kremensky
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 10:38 EDT by Petr Kremensky
Modified: 2014-09-03 00:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:12:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kremensky 2013-08-21 10:38:32 EDT
There is no validation for quickstarts installation target dir.
I would suggest take over input validation from installation target dir:
 - The target directory will be created.
 - The directory already exists. Are you sure you want to install here and possibly overwrite existing files?
 - This directory can not be written. Please choose another directory.

Reproduce:
enter "//" as quickstarts target dir during installation
 - actual: Could not crate directory Error message is shown during installation procedure
 - expected: "This directory can not be written. Please choose another directory." message is shown on Quickstarts screen.
Comment 1 Francisco Canas 2013-08-21 15:29:52 EDT
Fixed the logic error during validation of the quickstarts directory. 

The quickstarts dir panel now prompts you to create a dir if it doesn't already exist. It also checks for write permissions and emits an appropriate error msg if the directory cannot be created or written to. 

If it does not pass these validation checks, the user has to change his directory before continuing to the next installation panel.

See this commit for details:
http://git.app.eng.bos.redhat.com/?p=izpack.git;a=commit;h=1156da42f195442b9e6d875e5ec429a9e3a0248d
Comment 2 Petr Kremensky 2013-08-27 03:48:44 EDT
There will be no ER8. Changing target release to EAP 6.2.
Comment 3 Petr Kremensky 2013-09-13 06:24:24 EDT
Hi, please move BZs to ON_QA once the issue is fixed and target release is available so I can verify it. Thanks
Comment 4 Petr Kremensky 2013-09-13 09:30:35 EDT
Verified on EAP 6.2.0 ER1
Comment 5 Petr Kremensky 2013-09-24 04:07:49 EDT
I found some issues regarding this one.

- select non-existing directory as a quickstarts target:
Message window is thrown, but it uses string from path validation:
<str id="TargetPanel.createdir" txt="A fresh Red Hat JBoss Enterprise Application Platform installation will be placed here: " />. It made sense in 6.1.1 where TargetPanel.createdir text was "The target directory will be created: ", but not in 6.2. We should create new string more related to quickstarts, or make TargetPanel.createdir string more general.

Once I click on cancel of first message dialog, another message window is thrown saying "The directory you have chosen either does not exist or is not valid". Second message dialog shouldn't be there.
Comment 6 Francisco Canas 2013-09-24 14:02:25 EDT
For the issue with the incorrect string:
I have made the string for the directory creation more general:
"A new directory will be created here:"

See commit for details:
http://git.app.eng.bos.redhat.com/?p=jbossas-installer.git;a=commit;h=d3747201bf67d85a4c0ba7d740924f8f7c973a3b


For the issue with the unnecessary dialog window:
Removing this requires modifying izpack and will be done next time izpack is built. I will update this BZ when this occurs.
I have opened a new BZ for this issue, since it's separate from the incorrect string and will likely not be fixed for the upcoming milestone:
https://bugzilla.redhat.com/show_bug.cgi?id=1011654
Comment 7 Petr Kremensky 2013-09-26 09:44:13 EDT
Verified on EAP 6.2.0.ER3

Note You need to log in before you can comment on or make changes to this bug.