Bug 999573 - 2nd network card no longer accessible/usable
2nd network card no longer accessible/usable
Status: CLOSED DUPLICATE of bug 999571
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-08-21 11:12 EDT by wwaustin
Modified: 2013-09-18 10:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-09-18 10:58:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description wwaustin 2013-08-21 11:12:21 EDT
Description of problem:

This machine has 2 network cards.  pcie card: D-Link System Inc DGE-560T PCI Express Gigabit Ethernet Adapter (rev 13) [works fine] and on the MB Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 03) [it may have stopped working with the 3.10.* kernels]  Immediately after the install, both worked fine.  After the first kernel update, the realtek card stopped working altogether.  I have tried allowing NetworkManager to control the card and not doing so (both ways work under fc 17).

To check that the card is working, I put the old root (drive) file system from fedora 17 back in place, and when I booted, both cards came up and worked as expected - and did so for about 6 hours before I swapped the drives back and went back to fedora 19.

I'm not sure whether this is a NetworkManager problem, a kernel problem, a library problem or some other network-specific problem.  So the NetworkManager "component selection" above is a best-guess approximation.

manually setting the routing for the card does not help at all (or appear to work). The D-link card controls the external interfaces (ISP, other non-local systems) and the Realtek card is on the local ( network.

Version-Release number of selected component (if applicable):
Not sure it's relevent but:
kernel-3.10.7-200.fc19.x86_64 (same as with all other 3.10.* x86_64 kernels)

How reproducible:
Happens every time

Steps to Reproduce:
1.Reboot the machine (or restart network and NetworkManager)

Actual results:

D-Link (sky) card works as expected
Realtek card cannot contact anything on its network.

Expected results:

Both cards should work as expected

Additional info:\

Immediately after the initial install, both cards worked perfectly.  But after running yum update, the problem appeared.  Since there were > 400 updates in that first batch I don't have a clue which of them triggered the problem.
Comment 1 Rex Dieter 2013-09-18 10:58:48 EDT

*** This bug has been marked as a duplicate of bug 999571 ***

Note You need to log in before you can comment on or make changes to this bug.