Bug 999645 - /usr/share/gdb/auto-load/ needs filesystem symlinks
/usr/share/gdb/auto-load/ needs filesystem symlinks
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Kratochvil
Fedora Extras Quality Assurance
: Regression
: 974277 1003042 (view as bug list)
Depends On:
Blocks: 994062
  Show dependency treegraph
 
Reported: 2013-08-21 14:47 EDT by Jan Kratochvil
Modified: 2013-09-24 19:02 EDT (History)
9 users (show)

See Also:
Fixed In Version: gdb-7.6.1-41.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-24 19:00:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2013-08-21 14:47:14 EDT
Description of problem:
The usr/ symlinks bin+lib+lib64+sbin need to be present also in /usr/share/gdb/auto-load/ .

Version-Release number of selected component (if applicable):
gdb-7.6-34.fc19.x86_64
gdb-heap-0.5-12.fc19.x86_64

How reproducible:
Always.

Steps to Reproduce:
gdb true
start
heap

Actual results:
(gdb) heap
Undefined command: "heap".  Try "help".

Expected results:
(gdb) heap
Domain  Kind  Detail  Count  Allocated size
------  ----  ------  -----  --------------
               TOTAL      0               0

Additional info:
One can "fix" it by:
ln -s ../../lib64/ld-2.17.so-gdb.py /usr/share/gdb/auto-load/usr/lib64/ld-2.17.so-gdb.py
Fortunately no other packages besides gdb-heap uses non-usr/ directories.
Moreover gdb-heap uses it incorrectly but that is Bug 665799.
Comment 1 Jan Kratochvil 2013-08-21 14:48:35 EDT
*** Bug 974277 has been marked as a duplicate of this bug. ***
Comment 2 Fedora Update System 2013-08-28 16:20:53 EDT
gdb-7.6-35.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gdb-7.6-35.fc19
Comment 3 Fedora Update System 2013-08-28 16:20:56 EDT
gdb-7.5.1-40.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gdb-7.5.1-40.fc18
Comment 4 Fedora Update System 2013-08-29 18:19:39 EDT
Package gdb-7.6-35.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gdb-7.6-35.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15484/gdb-7.6-35.fc19
then log in and leave karma (feedback).
Comment 5 Jan Kratochvil 2013-08-30 10:57:46 EDT
*** Bug 1003042 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2013-08-30 13:22:51 EDT
gdb-7.5.1-41.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gdb-7.5.1-41.fc18
Comment 7 Fedora Update System 2013-08-30 13:22:53 EDT
gdb-7.6-37.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gdb-7.6-37.fc19
Comment 8 Anton Guda 2013-08-31 09:38:35 EDT
It seems, that gdb-7.6.50.20130731-9.fc20 have wrong symlinks in auto-load directory: bin -> "usr/bin". It may be better to use full path '/usr/bin' or long relative path "../../../bin".
Comment 9 Jan Kratochvil 2013-08-31 10:15:49 EDT
That is correct as it is.  You can also look it is similar in /usr/lib/debug/ .

/bin/ is the same as /usr/bin/ .
Therefore /usr/lib/debug/bin/ should be the same as /usr/lib/debug/usr/bin/ .
And also /usr/share/gdb/auto-load/bin/ should be the same as /usr/share/gdb/auto-load/usr/bin/ .

(Whether /bin should be a symlink at all is off-topic for this Bug.)
Comment 10 Fedora Update System 2013-09-09 12:33:28 EDT
gdb-7.6.1-41.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gdb-7.6.1-41.fc19
Comment 11 Fedora Update System 2013-09-09 12:33:32 EDT
gdb-7.5.1-42.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gdb-7.5.1-42.fc18
Comment 12 Fedora Update System 2013-09-24 19:00:47 EDT
gdb-7.5.1-42.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2013-09-24 19:02:40 EDT
gdb-7.6.1-41.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.