Bug 999692 - SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wineserver from 'read' accesses on the lnk_file /home/user9/.config/teamviewer8/dosdevices/c:.
SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wineserver from 'read'...
Status: CLOSED DUPLICATE of bug 999691
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:f6ee3ea683a576ab7df1286f476...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 17:27 EDT by Moez Roy
Modified: 2013-08-22 05:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-22 05:04:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-08-21 17:27:44 EDT
Description of problem:
SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wineserver from 'read' accesses on the lnk_file /home/user9/.config/teamviewer8/dosdevices/c:.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that wineserver should be allowed read access on the c: lnk_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep wineserver /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:initrc_t:s0
Target Context                unconfined_u:object_r:config_home_t:s0
Target Objects                /home/user9/.config/teamviewer8/dosdevices/c: [
                              lnk_file ]
Source                        wineserver
Source Path                   /opt/teamviewer8/tv_bin/wine/bin/wineserver
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           teamviewer-8.0.17147-1.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-100.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.10.4-100.fc18.x86_64 #1 SMP Thu
                              Aug 1 21:13:27 UTC 2013 x86_64 x86_64
Alert Count                   31
First Seen                    2013-07-15 08:14:00 PDT
Last Seen                     2013-08-21 14:26:26 PDT
Local ID                      2908a25e-3515-4bac-a193-401b5b7abd57

Raw Audit Messages
type=AVC msg=audit(1377120386.4:469): avc:  denied  { read } for  pid=1818 comm="wineserver" name="c:" dev="dm-3" ino=45876366 scontext=system_u:system_r:initrc_t:s0 tcontext=unconfined_u:object_r:config_home_t:s0 tclass=lnk_file


type=SYSCALL msg=audit(1377120386.4:469): arch=i386 syscall=fstat success=yes exit=ENONET a0=8620340 a1=8800 a2=0 a3=861f0a0 items=0 ppid=1 pid=1818 auid=4294967295 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=4294967295 tty=(none) comm=wineserver exe=/opt/teamviewer8/tv_bin/wine/bin/wineserver subj=system_u:system_r:initrc_t:s0 key=(null)

Hash: wineserver,initrc_t,config_home_t,lnk_file,read

audit2allow

#============= initrc_t ==============
allow initrc_t config_home_t:lnk_file read;

audit2allow -R
require {
	type initrc_t;
}

#============= initrc_t ==============
gnome_read_home_config(initrc_t)


Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.4-100.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-08-22 05:04:13 EDT

*** This bug has been marked as a duplicate of bug 999691 ***

Note You need to log in before you can comment on or make changes to this bug.