Bug 999691 - SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wineserver from 'write' accesses on the file client.conf.
SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wineserver from 'write...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:7803e76aaac03c4629aa3691ca7...
:
: 999692 999693 999723 999724 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 17:27 EDT by Moez Roy
Modified: 2013-08-22 05:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-22 05:09:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-08-21 17:27:33 EDT
Description of problem:
SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wineserver from 'write' accesses on the file client.conf.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that wineserver should be allowed write access on the client.conf file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep wineserver /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:initrc_t:s0
Target Context                unconfined_u:object_r:config_home_t:s0
Target Objects                client.conf [ file ]
Source                        wineserver
Source Path                   /opt/teamviewer8/tv_bin/wine/bin/wineserver
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           teamviewer-8.0.17147-1.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-100.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.10.4-100.fc18.x86_64 #1 SMP Thu
                              Aug 1 21:13:27 UTC 2013 x86_64 x86_64
Alert Count                   23
First Seen                    2013-07-15 08:13:59 PDT
Last Seen                     2013-08-21 10:48:52 PDT
Local ID                      1945f84d-9b4f-4829-a893-2032e2b98d3d

Raw Audit Messages
type=AVC msg=audit(1377107332.883:431): avc:  denied  { write } for  pid=1818 comm="wineserver" name="client.conf" dev="dm-3" ino=46007493 scontext=system_u:system_r:initrc_t:s0 tcontext=unconfined_u:object_r:config_home_t:s0 tclass=file


type=SYSCALL msg=audit(1377107332.883:431): arch=i386 syscall=fstat success=yes exit=EMULTIHOP a0=861e018 a1=8841 a2=1b6 a3=8638b38 items=0 ppid=1 pid=1818 auid=4294967295 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=4294967295 tty=(none) comm=wineserver exe=/opt/teamviewer8/tv_bin/wine/bin/wineserver subj=system_u:system_r:initrc_t:s0 key=(null)

Hash: wineserver,initrc_t,config_home_t,file,write

audit2allow

#============= initrc_t ==============
allow initrc_t config_home_t:file write;

audit2allow -R
require {
	type initrc_t;
}

#============= initrc_t ==============
gnome_manage_home_config(initrc_t)


Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.4-100.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-08-22 05:04:13 EDT
*** Bug 999692 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2013-08-22 05:04:18 EDT
*** Bug 999693 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2013-08-22 05:04:26 EDT
*** Bug 999723 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2013-08-22 05:04:30 EDT
*** Bug 999724 has been marked as a duplicate of this bug. ***
Comment 5 Miroslav Grepl 2013-08-22 05:09:31 EDT
I am pretty sure you have already reported these bugs. 

We don't ship this pkg and we told you how you can fix it using a local policy.

$ cat myinitrc.te
policy_module(myinitrc,1.0)
require{
 type initrc_t;
}
unconfined_domain_noaudit(initrc_t)



# make -f /usr/share/selinux/devel/Makefile
# semodule -i myinitrc.pp

to make this working.

Note You need to log in before you can comment on or make changes to this bug.