Bug 999881 - rhsm-icon does not pop up against SAM
rhsm-icon does not pop up against SAM
Status: CLOSED DUPLICATE of bug 994992
Product: Subscription Asset Manager
Classification: Red Hat
Component: candlepin (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Carter Kozak
SAM QE List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 06:12 EDT by qianzhan
Modified: 2014-09-14 20:09 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-22 08:28:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description qianzhan 2013-08-22 06:12:01 EDT
Description of problem:
rhsm-icon does not pop up against SAM

Version-Release number of selected component (if applicable):
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.3-7.el6sat.noarch
katello-cli-common-1.4.3-7.el6sat.noarch
katello-common-1.4.3-8.el6sam_splice.noarch
katello-configure-1.4.4-2.el6sat.noarch
katello-glue-candlepin-1.4.3-8.el6sam_splice.noarch
katello-glue-elasticsearch-1.4.3-8.el6sam_splice.noarch
katello-headpin-1.4.3-8.el6sam_splice.noarch
katello-headpin-all-1.4.3-8.el6sam_splice.noarch
katello-selinux-1.4.4-2.el6sat.noarch
signo-katello-0.0.20-1.el6sat.noarch
candlepin-0.8.20-1.el6sam.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.20-1.el6sam.noarch
candlepin-tomcat6-0.8.20-1.el6sam.noarch
thumbslug-0.0.32-1.el6sam.noarch
thumbslug-selinux-0.0.32-1.el6sam.noarch
subscription-manager-gui-1.8.20-1.el5
subscription-manager-1.8.20-1.el5
python-rhsm: 1.8.16-1.el5

How reproducible:
always

Steps to Reproduce:
1. Register to SAM and wait the rhsm-icon pops up to notice a subscription is needed:
(1)
[root@test1 ~]# subscription-manager register
Username: admin
Password: 
The system has been registered with ID: 871f46c1-eebc-41f5-87f2-9c871265fa54 

(2) The rhsm-icon does not pop up.

2. Auto-attach and unsubscribe all to wait rhsm-icon pops up:
(1)
[root@test1 ~]# subscription-manager subscribe --auto
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Unknown

[root@test1 ~]# subscription-manager unsubscribe --all
1 subscription removed at the server.
1 local certificate has been deleted.

(2) The rhsm-icon does not pop up.


Actual results:
As above.

Expected results:
The rhsm-icon should pop up with above execution.

Additional info:
The rhsm-icon pops up when needed against stage candlepin.
Comment 1 Carter Kozak 2013-08-22 08:28:57 EDT
The rhsm-icon is updated based upon your compliance status.

> Status:       Unknown

It appears that your server is still not giving any compliance info.  This looks like the same bug as before, 403 when you run /compliance.

Closing as duplicate, let me know if that's not the case.

*** This bug has been marked as a duplicate of bug 994992 ***
Comment 2 qianzhan 2013-08-23 01:26:11 EDT
(In reply to Carter Kozak from comment #1)
> The rhsm-icon is updated based upon your compliance status.
> 
> > Status:       Unknown
> 
> It appears that your server is still not giving any compliance info.  This
> looks like the same bug as before, 403 when you run /compliance.
> 
> Closing as duplicate, let me know if that's not the case.
> 
> *** This bug has been marked as a duplicate of bug 994992 ***

The bug does not appear against SAM-1.3.0-snapshot-3:

katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.3-8.el6sat.noarch
katello-cli-common-1.4.3-8.el6sat.noarch
katello-common-1.4.3-9.el6sam_splice.noarch
katello-configure-1.4.4-3.el6sat.noarch
katello-glue-candlepin-1.4.3-9.el6sam_splice.noarch
katello-glue-elasticsearch-1.4.3-9.el6sam_splice.noarch
katello-headpin-1.4.3-9.el6sam_splice.noarch
katello-headpin-all-1.4.3-9.el6sam_splice.noarch
katello-selinux-1.4.4-2.el6sat.noarch
signo-katello-0.0.20-1.el6sat.noarch
candlepin-0.8.21-1.el6sam.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.21-1.el6sam.noarch
candlepin-tomcat6-0.8.21-1.el6sam.noarch
thumbslug-0.0.32-1.el6sam.noarch
thumbslug-selinux-0.0.32-1.el6sam.noarch
subscription-manager: 1.8.20-1.el5
python-rhsm: 1.8.16-1.el5

Note You need to log in before you can comment on or make changes to this bug.