Bug 999921 - Hook scripts for samba don't add default log file and log level in smb.conf
Hook scripts for samba don't add default log file and log level in smb.conf
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Raghavendra Talur
surabhi
:
Depends On: 999910
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 07:24 EDT by Raghavendra Talur
Modified: 2013-09-23 18:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.23rhs-1.el6rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 999910
Environment:
Last Closed: 2013-09-23 18:32:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra Talur 2013-08-22 07:24:45 EDT
+++ This bug was initially created as a clone of Bug #999910 +++

Description of problem:
Hook scripts for samba add entry in smb.conf for each volume.
However, they don't add default log file for the plugin.
In case of errors, this will lead to having no record of what went wrong
in the client process stack.


How reproducible:
Always

--- Additional comment from Anand Avati on 2013-08-22 07:17:43 EDT ---

REVIEW: http://review.gluster.org/5685 (extras/hookscripts: Add default logfile for glusterfs vfs plugin.) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 2 Raghavendra Talur 2013-08-22 07:52:42 EDT
posted patch for review at https://code.engineering.redhat.com/gerrit/#/c/11779/
Comment 3 surabhi 2013-09-04 09:53:51 EDT
Verified the bug with latest version:
samba-glusterfs-3.6.9-160.3.el6rhs.x86_64
glusterfs-3.4.0.30rhs-2.el6rhs.x86_64

Now the new shares have default log file and log level set.
Comment 4 Scott Haines 2013-09-23 18:32:16 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.