Bug 999950 - Business-central is single-user application
Business-central is single-user application
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
urgent Severity urgent
: CR1
: 6.0.0
Assigned To: Pedro Zapata
Zuzana Krejčová
:
Depends On: 983634 1001561 1048265 1049361 1049368 1049396
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 08:24 EDT by Zuzana Krejčová
Modified: 2014-08-06 16:18 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:18:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zuzana Krejčová 2013-08-22 08:24:56 EDT
Description of problem:
Similarly to bug 983634 that has been ignored, the whole business-central is single-user only. Collaboration does not work. The last user saving an asset of any type wins.

If two users edit an asset at the same time, the last commit/save overwrites changes made by the first commit/save. Users are in no way warned that someone else is making changes, there are no conflicts in git.

This is not the type of behaviour one would expect of production ready application using git.

I'd expect at least a warning. Warning before editing the asset, in the worst case upon saving the changes (optimistic locking). In that case, user shouldn't be allowed to save the changes, because that would overwrite the previous commit. This would still mean the loss of work, but at least the user would notice.
If both commits/saves are allowed, then there should be some way to merge them. This would be ideal.



Version-Release number of selected component (if applicable):
6.0 ER1
Comment 3 manstis 2013-09-12 09:38:33 EDT
More changes (to drools-wb):

(master) https://github.com/droolsjbpm/drools-wb/commit/4983117df

(6.0.x) https://github.com/droolsjbpm/drools-wb/commit/9208509e4

Other editors to follow.
Comment 6 Lukáš Petrovický 2013-10-23 07:40:47 EDT
Why is this "POST"? What does that even mean?

Is this issue resolved or not?
Comment 7 Edson Tirelli 2013-10-23 09:36:10 EDT
Porcelli, can you please clarify the status of this issue and if it is done, set it to MODIFIED?
Comment 10 Edson Tirelli 2013-11-18 14:59:06 EST
Raising the priority to get it fixed for the product release.
Comment 13 Zuzana Krejčová 2014-01-03 09:56:22 EST
I will definitely be looking into this more, but as of now this issue is not fixed. Consider this blocked by at least bug 1048265. If I find more issues, I will, of course, inform you.
As for bug 983634 which is supposedly blocked by this - shouldn't it be the other way? This being blocked by bug 983634?
Comment 14 Pedro Zapata 2014-01-10 10:21:03 EST
The global issue has been implemented and solved. As agreed during the release status call, it's marked as modified.

There are a few dependent tickets still open should be targeted for 6.0.1 and will be tracked separately.
Comment 16 Zuzana Krejčová 2014-01-27 04:48:31 EST
(In reply to Pedro Zapata from comment #14)
> The global issue has been implemented and solved. 

Issues with the solution were mostly fixed as well - see bugs that block this. 

Verified with CR2.

Note You need to log in before you can comment on or make changes to this bug.