Bug 1626953 (CVE-2018-14620) - CVE-2018-14620 openstack-rabbitmq-container: Insecure download of rabbitmq_clusterer during docker build
Summary: CVE-2018-14620 openstack-rabbitmq-container: Insecure download of rabbitmq_cl...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2018-14620
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20180910:1500,...
Depends On: 1627119 1627120 1627121
Blocks: 1626024
TreeView+ depends on / blocked
 
Reported: 2018-09-10 07:45 UTC by Sam Fowler
Modified: 2019-06-08 23:36 UTC (History)
17 users (show)

Fixed In Version: openstack-rabbitmq-container-13.0-57, openstack-rabbitmq-container-12.0-20180910.1
Doc Type: If docs needed, set a value
Doc Text:
The OpenStack RabbitMQ container image insecurely retrieves the rabbitmq_clusterer component over HTTP, without validation, during the build stage. This could potentially allow an attacker to serve malicious code to the image builder and install in the resultant container image.
Clone Of:
Environment:
Last Closed: 2018-12-20 04:15:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2018:2721 None None None 2018-09-18 12:15:34 UTC
OpenStack gerrit 600426 None None None 2018-09-10 14:11:19 UTC
Launchpad 1791077 None None None 2018-09-10 14:26:07 UTC
Launchpad 1791674 None None None 2018-09-10 14:20:19 UTC
Red Hat Product Errata RHSA-2018:2729 None None None 2018-09-20 11:07:58 UTC

Description Sam Fowler 2018-09-10 07:45:16 UTC
The openstack-rabbitmq-container image insecurely retrieves the rabbitmq_clusterer component over HTTP during the build stage. This could potentially allow an attacker to serve malicious code to the image builder and install in the resultant container image.

Comment 9 errata-xmlrpc 2018-09-18 12:15:25 UTC
This issue has been addressed in the following products:

  Red Hat OpenStack Platform 13.0 (Queens)

Via RHSA-2018:2721 https://access.redhat.com/errata/RHSA-2018:2721

Comment 10 errata-xmlrpc 2018-09-20 11:07:50 UTC
This issue has been addressed in the following products:

  Red Hat OpenStack Platform 12.0 (Pike)

Via RHSA-2018:2729 https://access.redhat.com/errata/RHSA-2018:2729


Note You need to log in before you can comment on or make changes to this bug.