Bug 1845867 (CVE-2020-10767) - CVE-2020-10767 kernel: Indirect Branch Prediction Barrier is force-disabled when STIBP is unavailable or enhanced IBRS is available.
Summary: CVE-2020-10767 kernel: Indirect Branch Prediction Barrier is force-disabled w...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2020-10767
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1846029 1847379 1847383 1847375 1847376 1847377 1847378 1847380 1847381 1847382 1847403 1847404
Blocks: 1845835
TreeView+ depends on / blocked
 
Reported: 2020-06-10 09:50 UTC by Wade Mealing
Modified: 2020-09-14 11:41 UTC (History)
56 users (show)

Fixed In Version: Linux kernel 5.8-rc1
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in the Linux kernel’s implementation of the Enhanced IBPB (Indirect Branch Prediction Barrier). The IBPB mitigation will be disabled when STIBP is not available or when the Enhanced Indirect Branch Restricted Speculation (IBRS) is available. This flaw allows a local attacker to perform a Spectre V2 style attack when this configuration is active. The highest threat from this vulnerability is to confidentiality.
Clone Of:
Environment:
Last Closed: 2020-07-21 13:28:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:3086 None None None 2020-07-22 01:04:39 UTC
Red Hat Product Errata RHSA-2020:3010 None None None 2020-07-21 11:05:47 UTC
Red Hat Product Errata RHSA-2020:3016 None None None 2020-07-21 11:23:55 UTC
Red Hat Product Errata RHSA-2020:3041 None None None 2020-07-21 14:32:40 UTC
Red Hat Product Errata RHSA-2020:3073 None None None 2020-07-21 16:24:20 UTC
Red Hat Product Errata RHSA-2020:3222 None None None 2020-07-29 19:37:38 UTC
Red Hat Product Errata RHSA-2020:3297 None None None 2020-08-04 07:38:08 UTC

Description Wade Mealing 2020-06-10 09:50:58 UTC
A flaw was found in the Linux kernels implementation of IBPB ( Indirect Branch Prediction Barrier  ).  The  IBPB mitigation will be disabled when STIBP is not available or when Enhanced Indirect Branch Restricted Speculation (IBRS) is available.  

This is not expected behaviour and leave the system open to a spectre v2 style attack.  This can allow a local attacker to perform a spectre V2 style attack when this configuration is active.

Comment 1 Wade Mealing 2020-06-10 10:55:31 UTC
This makes the CPU vulnerable to Spectre v2.

Comment 5 Wade Mealing 2020-06-11 08:15:32 UTC
Mitigation:

Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.

Comment 10 Wade Mealing 2020-06-16 09:57:42 UTC
Created kernel tracking bugs for this issue:

Affects: fedora-all [bug 1847375]

Comment 13 Fedora Update System 2020-06-19 01:04:42 UTC
FEDORA-2020-125ccdc871 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Fedora Update System 2020-06-23 01:13:42 UTC
FEDORA-2020-1b2dae6219 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 15 Petr Matousek 2020-06-23 15:29:39 UTC
Statement:

This flaw is rated as having Important impact, because it enables exploitation of the previous Spectre v2 attack, which has a rating of Important.

Comment 19 errata-xmlrpc 2020-07-21 11:05:37 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2020:3010 https://access.redhat.com/errata/RHSA-2020:3010

Comment 20 errata-xmlrpc 2020-07-21 11:23:49 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2020:3016 https://access.redhat.com/errata/RHSA-2020:3016

Comment 21 Product Security DevOps Team 2020-07-21 13:28:21 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2020-10767

Comment 22 errata-xmlrpc 2020-07-21 14:32:37 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.0 Update Services for SAP Solutions

Via RHSA-2020:3041 https://access.redhat.com/errata/RHSA-2020:3041

Comment 23 errata-xmlrpc 2020-07-21 16:24:16 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2020:3073 https://access.redhat.com/errata/RHSA-2020:3073

Comment 24 errata-xmlrpc 2020-07-29 19:37:34 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.1 Extended Update Support

Via RHSA-2020:3222 https://access.redhat.com/errata/RHSA-2020:3222

Comment 25 errata-xmlrpc 2020-08-04 07:38:04 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.1 Extended Update Support

Via RHSA-2020:3297 https://access.redhat.com/errata/RHSA-2020:3297


Note You need to log in before you can comment on or make changes to this bug.