Bug 1788164

Summary: Console operator degraded in IPv6 cluster [openshift-4.3.z]
Product: OpenShift Container Platform Reporter: chris alfonso <calfonso>
Component: Management ConsoleAssignee: bpeterse
Status: CLOSED DUPLICATE QA Contact: Yadan Pei <yapei>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 4.3.zCC: aos-bugs, cvogt, jokerman, nmukherj, pkrupa, rgarg
Target Milestone: ---   
Target Release: 4.3.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1788136 Environment:
Last Closed: 2020-01-30 02:00:07 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1788136, 1794546    
Bug Blocks:    

Description chris alfonso 2020-01-06 15:16:52 UTC
+++ This bug was initially created as a clone of Bug #1788136 +++

Description of problem:
Console operator is degraded causing the installation to fail

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-12-18-145749-ipv6.1

How reproducible:
Always

Steps to Reproduce:
1. Start an IPv6 cluster


Actual results:
Installation fails with the following message:

```
DEBUG Still waiting for the cluster to initialize: Some cluster operators are still updating: authentication, console 
DEBUG Still waiting for the cluster to initialize: Some cluster operators are still updating: authentication, console 
DEBUG Still waiting for the cluster to initialize: Working towards 4.3.0-0.nightly-2019-12-18-145749-ipv6.1: 100% complete 
DEBUG Still waiting for the cluster to initialize: Some cluster operators are still updating: authentication, console 
ERROR Cluster operator authentication Degraded is True with RouteHealthDegradedFailedGet: RouteHealthDegraded: failed to GET route: net/http: TLS handshake timeout 
INFO Cluster operator authentication Progressing is Unknown with NoData:  
INFO Cluster operator authentication Available is Unknown with NoData:  
INFO Cluster operator console Progressing is True with SyncLoopRefreshProgressingInProgress: SyncLoopRefreshProgressing: Working toward version 4.3.0-0.nightly-2019-12-18-145749-ipv6.1 
INFO Cluster operator console Available is False with DeploymentAvailableInsufficientReplicas: DeploymentAvailable: 0 pods available for console deployment 
INFO Cluster operator insights Disabled is False with :  
FATAL failed to initialize the cluster: Some cluster operators are still updating: authentication, console
```


Expected results:
Installation succeeds and operator is not degraded


Additional info:

Comment 1 bpeterse 2020-01-08 15:51:31 UTC
I was not able to open the attached must-gather file, corrupted?
Is there any further information that can be provided, such as the architecture/platform?

Comment 2 bpeterse 2020-01-30 02:00:07 UTC
Also an accidental duplication of a clone:

https://bugzilla.redhat.com/show_bug.cgi?id=1794548

*** This bug has been marked as a duplicate of bug 1794548 ***