Bug 1796618

Summary: Allow IPv6 CIDRs to be used in install-config
Product: OpenShift Container Platform Reporter: Russell Bryant <rbryant>
Component: InstallerAssignee: Russell Bryant <rbryant>
Installer sub component: openshift-installer QA Contact: Gaoyun Pei <gpei>
Status: CLOSED ERRATA Docs Contact:
Severity: unspecified    
Priority: unspecified    
Version: 4.3.z   
Target Milestone: ---   
Target Release: 4.3.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1796624 (view as bug list) Environment:
Last Closed: 2020-03-10 23:53:17 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1796624    
Bug Blocks: 1785718, 1794699, 1788526, 1789124, 1789421, 1790434, 1790442, 1792309, 1794548, 1794765    

Description Russell Bryant 2020-01-30 19:20:26 UTC
Currently, IPv6 CIDRs are rejected during install-config validation.  This was changed in master/4.4 via https://github.com/openshift/installer/pull/2829

Comment 1 Russell Bryant 2020-01-30 19:20:43 UTC
See https://github.com/openshift/installer/pull/3029

Comment 4 Gaoyun Pei 2020-02-21 07:21:48 UTC
Verify this bug with registry.svc.ci.openshift.org/ocp/release:4.3.0-0.nightly-2020-02-21-003712

Set the following parameters in install-config.yaml
networking:
  clusterNetwork:
  - cidr: fd01::/48
    hostPrefix: 64
  machineNetwork:
  - cidr: 10.0.0.0/16
  - cidr: fd00::/48
  networkType: OVNKubernetes
  serviceNetwork:
  - fd02::/112

With OPENSHIFT_INSTALL_AZURE_EMULATE_SINGLESTACK_IPV6=true, start the installation. Installer could create the expected subnets with ipv6 address CIDR. Move this bug to verified.

Comment 6 errata-xmlrpc 2020-03-10 23:53:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0676