Bug 186378

Summary: FC5 clean install fails on Transmeta Crusoe processor system
Product: [Fedora] Fedora Reporter: TC <tcwan>
Component: anacondaAssignee: Peter Jones <pjones>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5CC: jmknoble, maarten_l, p.mayers, rigsb007, roy.dragseth, tibbs
Target Milestone: ---Keywords: Regression
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Fedora 7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-03-10 22:38:40 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description TC 2006-03-23 04:16:57 EST
Description of problem:

I have FC4 installed on my Fujitsu P2120 notebook with Transmeta Crusoe
processor. However, upgrading to FC5 was not possible due to insufficient disk
space. Subsequently I performed a clean install of FC5.

Version-Release number of selected component (if applicable):

FC5 i386 installer CD

How reproducible:

Always

Steps to Reproduce:
1. Clean install of FC5 i386 architecture
2. Go through installation dialogs, start installation process
3. Anaconda will crash with "Error running transaction: package *** is intended
for a i686 architecture" error
  
Actual results:

Anaconda will crash with "Error running transaction: package *** is intended for
a i686 architecture" error (3 packages are listed in the error: kernel is one) 

Expected results:

Able to clean install FC5 (with i686 kernel package) on Transmeta Crusoe
processor system

Additional info:

FC4 installer works fine, will clean install FC4 and kernel*i686.rpm correctly.

Finally I ended up doing a clean reinstall of FC4, and performed an upgrade
using FC5 install disc and it proceeded without crashing.
Comment 1 Paul Nasrat 2006-03-23 11:29:00 EST
If you switch to tty3 can you cat /etc/rpm/platform  please
Comment 2 TC 2006-03-23 20:33:40 EST
It shows:
i686-redhat-linux
Comment 3 Paul Nasrat 2006-04-25 09:57:46 EDT
*** Bug 189865 has been marked as a duplicate of this bug. ***
Comment 4 Paul Nasrat 2006-04-25 10:09:35 EDT
I've replicated here and can see what is going on.
Comment 5 Maarten van Leunen 2006-05-05 04:58:01 EDT
*** Bug 188417 has been marked as a duplicate of this bug. ***
Comment 6 Phil Mayers 2006-05-05 06:21:40 EDT
Sorry to nag, but is there any progress on this issue? I understand shipping an
actual boot errata will take time, but if there's a rawhide/testing boot kernel,
anaconda package or patch I can apply to just get this one laptop installed it
would be helpful. Thanks in advance
Comment 7 Jason Tibbitts 2006-05-05 09:40:34 EDT
This is in one of the duplicate bugs, but I wanted to make sure it was noticed:
on my machines, the i586 kernel installs when the i686 or i686-smp kernel should
be installed.  Five installs so far, all with this issue.  I am capable of
patching anaconda and rebuilding the boot media if it would help in testing; I
just don't know where to look.
Comment 8 Chris Rigsby 2006-05-05 12:08:15 EDT
*** Bug 190829 has been marked as a duplicate of this bug. ***
Comment 9 Jim Knoble 2006-05-09 21:07:08 EDT
> Comment #4 From Paul Nasrat (pnasrat@redhat.com)  	 on 2006-04-25 10:09 EST
>
> I've replicated here and can see what is going on.

Any progress on this?  I've encountered this bug as well (Fujitsu Lifebook
P2120, Transmeta Crusoe TM5800 CPU), and it's keeping me from installing Fedora
Core 5.  I'd be happy to make a new installation CD if necessary.  Even a dirty
workaround for Transmeta users would be useful in the interim....
Comment 10 Paul Nasrat 2006-05-09 21:16:14 EDT
I'm hoping to fix this for FC6 - however I'm working on larger anaconda changes
first (eg multiple repository support).

An upntested work around may be when the installer boots up and is on the
welcome screen switch to tty2 and mkdir -p /mnt/sysimage/etc/rpm and then echo
i686-redhat-linux > /mnt/sysimage/etc/rpm/platform.  If you have time to try
that out, and let me know if it works for you.  I can probably provide an
updates.img to do the same.
Comment 11 TC 2006-05-09 22:02:28 EDT
I'm reluctant to reformat my FC5 install to test this. Perhaps one of the other
interested parties who haven't installed FC5 yet can try this.
Comment 12 Jim Knoble 2006-05-10 00:26:12 EDT
I'd be happy to test; probably won't get to it until early morning on 2006-05-11
UTC.
Comment 13 Chris Rigsby 2006-05-11 08:47:50 EDT
I also have a Fujitsu P2120.  I tried switching to tty2 from the welcome screen,
then:
# mkdir -p /mnt/sysimage/etc/rpm
# echo i686-redhat-linux > /mnt/sysimage/etc/rpm/platform

I then did:

# cat /mnt/sysimage/etc/rpm/platform

to make sure everything looked okay.  It did.  However, when I tried to switch
back to tty7 where the installer was running, everything locked solid with a
blank screen.  I was unable to switch back to any other tty (1-5), nor did the
three-finger salute reboot the system.  I retried several times, including
switching from tty7 to tty1 and tty2 a few times before making the platform
file.  After making the file, I can freely switch between any of the text ttys,
but as soon as I return to the graphical installer, it freezes with a black screen.

Perhaps tonight I'll trying doing a text-based install.  
Comment 14 Roy Dragseth 2006-05-16 04:15:08 EDT
I see this same problem on my Sony Picturebook with the Crusoe processor.

the file /mnt/sysimage/etc/rpm/platform already contains the string 
i686-redhat-linux so the cpu seems to be detected correctly.

Comment 15 Roy Dragseth 2006-05-16 05:44:17 EDT
To get FC5 going I had to install a clean FC4 minimal setup and do a yum 
upgrade.
Comment 16 Roy Dragseth 2006-05-16 06:58:05 EDT
FYI:
I see the same freezing behavior and reported this as bug  191887.

r.



Comment 17 Paul Raines 2006-05-16 11:58:09 EDT
The proposed workaround does not work.  First of all /mnt/sysimage is
not even mounted till just before the packages start installing.  So
doing what you propose above will be "overmounted" anyway.  Also, once
I get the 'incorrect arch' error, I can go to tty2 and look at the
/mnt/sysimage/etc/rpm/platform file and it has i686-redhat-linux
in it anyway.

However, I found a workaround.  At the welcome screen, to to tty2
and change /etc/rpm/platform to read 'i586-redhat-linux'.

Then later, when it is transferring the install image to your / partition
quickly go to tty2 and change /mnt/sysimage/etc/rpm/platform to
be 'i568-redhat-linux'

Then it seems to install okay (thought it is still going now and
has not rebooted yet)
Comment 18 Paul Nasrat 2006-05-16 12:38:51 EDT
Can you attach /proc/cpuinfo from the machine.
Comment 19 Paul Nasrat 2006-05-16 12:41:07 EDT
You should also be able to install with passing rpmarch=i586 to the syslinux
boot line:

linux rpmarch=i586
Comment 20 Roy Dragseth 2006-05-23 07:21:14 EDT
> linux rpmarch=i586

great! this solved my problems.

Here's the cpuinfo on my box:


processor       : 0
vendor_id       : GenuineTMx86
cpu family      : 6
model           : 4
model name      : Transmeta(tm) Crusoe(tm) Processor TM5800
stepping        : 3
cpu MHz         : 867.000
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr cx8 cmov mmx longrun lrti
bogomips        : 1724.49


r.
Comment 21 Phil Mayers 2006-11-20 13:05:12 EST
This bug is STILL PRESENT in FC6

Somewhat disappointing.

I am testing if the rpmarch=i586 workaround works now, but since it has already
vapourised my machine it'll be a little while before I can update. In addition,
it is not exactly easy to test that workaround on PXE installs.
Comment 22 Phil Mayers 2006-11-20 13:58:47 EST
rpmarch=i586 still works as a workaround for FC6
Comment 23 TC 2007-06-06 03:34:39 EDT
F7 anaconda appears to work correctly on P2120. However, there are other issues
with respect to actually getting the installed F7 distribution booted, which is
tracked under https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=242472
Comment 24 TC 2007-06-20 00:08:49 EDT
This issue should be closed since it has a workaround in F6 and solved in F7.
The pata_ali IDE kernel panic Bug #242472 has been solved with post-F7 updated
kernel.
Comment 25 Red Hat Bugzilla 2007-08-21 01:22:41 EDT
User pnasrat@redhat.com's account has been closed