Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.

Bug 202403 (tb-myspell)

Summary: Make spellchecking in Thunderbird work (myspell)
Product: [Fedora] Fedora Reporter: Kim Bisgaard <kim-rh>
Component: thunderbirdAssignee: Christopher Aillon <caillon>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 7CC: antonio.montagnani, david.monniaux, mcepl, mcepl
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: TB12ReproductionRequest
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-03-10 07:28:56 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Kim Bisgaard 2006-08-14 03:05:33 EDT
Description of problem:
There are no dictionaries installed for thunderbird - please add a trigger
script to either openoffice.org-langpack-??_?? or thunderbird with the
equivalent of this script:
ver=1.5.0.5
cd /usr/lib/openoffice.org2.0/share/dict/ooo/
for d in ??_??.aff ??_??.dic; do 
	n=`echo $d |tr _ -`; 
	ln -s `pwd`/$d /usr/lib/thunderbird-$ver/components/myspell/$n ; 
done

thanks!
Comment 1 Matěj Cepl 2007-07-18 13:31:42 EDT
Fedora Core 5 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora Core 6, or
Fedora 7, or Rawhide)? If this issue turns out to still be reproducible, please
let us know in this bug report.  If after a month's time we have not heard back
from you, we will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.
Comment 3 Kim Bisgaard 2007-07-21 10:14:09 EDT
A current (Fedora 7) script  could be:

#!/bin/bash

ver=`rpm -q --qf "%{version}" thunderbird`
cd /usr/share/myspell/
for d in ??_??.aff ??_??.dic; do
        n=`echo $d |tr _ -`;
        ln -s `pwd`/$d /usr/lib/thunderbird-$ver/dictionaries/$n ;
done
Comment 4 Matěj Cepl 2007-07-23 05:59:10 EDT
I don't think making thunderbird dependent on OpenOffice.org would make anybody
happy.
Comment 5 Matěj Cepl 2007-07-23 06:04:57 EDT
Scrap comment 4, that's nonsense. 
Comment 6 Matěj Cepl 2007-07-23 06:53:17 EDT
*** Bug 217187 has been marked as a duplicate of this bug. ***
Comment 7 Matěj Cepl 2007-07-23 06:53:40 EDT
*** Bug 244972 has been marked as a duplicate of this bug. ***
Comment 8 Matěj Cepl 2007-07-23 06:53:45 EDT
*** Bug 217188 has been marked as a duplicate of this bug. ***
Comment 9 Christopher Aillon 2007-08-07 12:28:39 EDT
We're moving to hunspell in the nearish future which should fix this issue, so
this is probably wontfix.
Comment 10 Matěj Cepl 2008-02-08 15:42:45 EST
Since this bugzilla report was filed, we have seriously upgraded Gecko-related
packages, which may have resolved this issue. Users who have experienced this
problem are encouraged to upgrade their system to the latest version of their
distribution available.

Please, confirm to us that this bug is reproducible on the latest upgrade of the
supported distribution (that's RHEL, or Fedora 7, 8, and Rawhide).

Setting the bug to NEEDINFO. If I won't get confirmation of reproducability in
30 days, the bug will be closed as INSUFFICIENT_DATA.

[This is mass-changing of bugs which seem to be too old and irrelevant anymore;
we are sorry, if this bug should not be incldued.]
Comment 11 Kim Bisgaard 2008-03-05 06:14:31 EST
I can confirm that it does still NOT work with 2.0.0.12-1.fc8
Comment 12 antonio montagnani 2008-03-05 06:24:18 EST
and also in rawhide
Comment 13 Kim Bisgaard 2008-03-05 06:46:19 EST
I can confirm that it does still NOT work with 2.0.0.12-1.fc8
Comment 14 Matěj Cepl 2008-03-07 17:42:41 EST
At this point, we're going to only be taking security fixes and major stability
fixes into this release of Fedora.  However, we still want to ensure the bug is
fixed in the next version.  We'd appreciate if you could test with the latest
version of Thunderbird (2.0.0.12) now available for your distribution and
provide feedback as to whether the problem still exists so we can file a ticket
upstream as soon as possible.
Comment 15 Kim Bisgaard 2008-03-08 06:10:48 EST
I can confirm that it does still NOT work with 2.0.0.12-1.fc8
Comment 16 Matěj Cepl 2008-03-10 07:28:56 EDT
Should be fixed in F9 (http://fedoraproject.org/wiki/Releases/FeatureDictionary)
and fixing this for Gecko apps is bug 218762.

Closing as DUPLICATE.

*** This bug has been marked as a duplicate of 218762 ***