Bug 2060450

Summary: Overview page does not load from openshift console for some set of users after upgrading to 4.7.19
Product: OpenShift Container Platform Reporter: Christoph Jerolimov <cjerolim>
Component: Dev ConsoleAssignee: Christoph Jerolimov <cjerolim>
Status: CLOSED ERRATA QA Contact: spathak <spathak>
Severity: high Docs Contact:
Priority: high    
Version: 4.7CC: abhbaner, aos-bugs, nmukherj
Target Milestone: ---   
Target Release: 4.8.z   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-04-11 20:04:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 2060449    
Bug Blocks: 2060451    

Description Christoph Jerolimov 2022-03-03 14:38:57 UTC
This bug was initially created as a copy of Bug #2009345

I am copying this bug because: Backporting

Description of problem:

For some sets of users not able to load the Overview page and it displays a white screen after entering their credentials. 

Version-Release number of selected component (if applicable):

- This issue is only for some sets of users.
- They tried in an incognito window, and a different browser, even tried remotely where other users are able to connect with their account.
- The account is having the same set of roles as other users.
- But when they try by going to a different URL(appending like this https://console-openshift-console.apps.sharedocp4upi46.lab.rdu2.cee.redhat.com/k8s/cluster/projects) for the cluster and then coming back to the Overview page it works. 
- They deleted the account and the identity and after they logged in again it started working without any issue.

How reproducible:

Steps to Reproduce:

Actual results:
The overview page displays a white screen. 

Expected results:
The overview page from the console should be loaded as soon as entering credentials. 

Additional info:

Comment 5 spathak@redhat.com 2022-04-04 12:56:24 UTC
Verified on build version: 4.8.0-0.nightly-2022-04-01-224429
Browser version: Chrome 99
Tried creating a namespace with numbers and accessing routes

Comment 7 errata-xmlrpc 2022-04-11 20:04:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Important: OpenShift Container Platform 4.8.36 security update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.