This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 237757

Summary: Wrong init script
Product: Red Hat Enterprise Linux 5 Reporter: Michal Marciniszyn <mmarcini>
Component: am-utilsAssignee: Karel Zak <kzak>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.0CC: tvujec
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-05-31 02:02:00 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 237789, 237758, 237759    

Description Michal Marciniszyn 2007-04-25 05:21:16 EDT
Description of problem:
Init script does not return correct error codes and has wrong status implementation.

Version-Release number of selected component (if applicable):
All

How reproducible:
Always

Steps to Reproduce:
1. rename conf file (/etc/amd.conf)
2. service amd start / service amd status
3. echo $?
  
Actual results:
1

Expected results:
6 / status of the amd

Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is implemented correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html
Comment 1 Karel Zak 2007-05-31 02:02:00 EDT

*** This bug has been marked as a duplicate of 237756 ***