Bug 239646

Summary: GPL Ghostscript 8.57 released
Product: [Fedora] Fedora Reporter: acount closed by user <a1459440>
Component: ghostscriptAssignee: Tim Waugh <twaugh>
Status: CLOSED RAWHIDE QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: rawhideCC: mgarski, ndeb, rmj, umar, whiteg
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: All   
URL: http://www.ghostscript.com/awki/GPL_Ghostscript_8.60
Whiteboard:
Fixed In Version: 8.60-0.svn8117.1.fc8 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-07-16 07:59:19 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235704    

Description acount closed by user 2007-05-10 05:26:35 EDT
As the head branch of Ghostscript is now under GPL (and not only the
previous major version as formerly) the ESP Ghostscript project was
closed and the extra functionality of ESP Ghostscript is merged into
the head development of Ghostscript, GPL Ghostscript.
Comment 1 acount closed by user 2007-05-10 05:28:11 EDT
source code: http://www.openprinting.org/download/printing/esp-gpl-ghostscript-
merge/
Comment 2 Tim Waugh 2007-05-10 05:35:18 EDT
That's a test version.  Yes, we'll hopefully pick this up when it's ready,
perhaps in time for F8.
Comment 3 acount closed by user 2007-06-05 05:52:25 EDT
8.57 was released days ago: http://www.ghostscript.com/awki/GPL_Ghostscript_8.57

--cut--
In addition to the usual bug fixes, there are specific performance and quality 
improvements in the areas of patterns, shading and image filtering. Also new in 
this release is an implementation of the Well Tempered Screening algorithm in 
an output device, using Graeme Gill's IMDI library for efficient color mapping.
--end--
Comment 4 acount closed by user 2007-06-23 08:58:41 EDT
I did not see any news about GS on
http://fedoraproject.org/wiki/Releases/8/FeatureList.

what's about GS-8.57 on F-8 ?


-thanks-
Comment 5 Tim Waugh 2007-06-25 11:08:17 EDT
*** Bug 244910 has been marked as a duplicate of this bug. ***
Comment 6 Sammy 2007-06-26 14:12:27 EDT
I have cooked up a source rpm for 8.60 that is working for me. Found patches
etc at various places and based it on FC6 source rpm. It uses revision 8077 from
26 June, 2007.

http://compsci.cas.vanderbilt.edu/Fedora/local/SRPMS/ghostscript-8.60-3.fc6.src.rpm
Comment 7 Tim Waugh 2007-06-28 13:03:33 EDT
Thanks for posting a link to that.

The CJK bits we add in might complicate things.  I'll try to find out the state
of that.
Comment 8 acount closed by user 2007-06-30 06:29:28 EDT
it looks like the integration of ESP in GPL GS is _not_ ready yet !
maybe for 8.58 release.
Comment 9 Sammy 2007-06-30 07:25:07 EDT
I believe the integration is ready. It may be other patches that need adopting
to the new GS. By the way they skipped to version 8.60 because this represents
a relatively major change due to integration of cups driver.
Comment 10 George N. White III 2007-06-30 12:29:55 EDT
Some valid pdf files give errors:

   **** Embedded font uses undefined procedure RD

with ESP Ghostscript 815.04.(see ghostscript bug 689314) but work with 8.60. 
I have attached the test file created with TL2007 etex+dvipdfm:

$ cat t2.tex
\nopagenumbers
\font\f=bchb8y\f
A
\bye
$ etex t2
This is pdfTeXk, Version 3.141592-1.40.3 (Web2C 7.5.6)
 %&-line parsing enabled.
entering extended mode
(./t2.tex [1] )
Output written on t2.dvi (1 page, 204 bytes).
Transcript written on t2.log.
$ dvipdfm t2

t2.dvi -> t2.pdf
[1]
16224 bytes written
$ pdffonts t2.pdfname                                 type         emb sub uni 
object ID
------------------------------------ ------------ --- --- --- ---------
HZFXHS+CharterBT-Bold                Type 1       yes yes no      10  0
$ pdfinfo t2.pdf
Creator:         TeX output 2007.06.30:1205
Producer:       dvipdfm 0.13.2c, Copyright © 1998, by Mark A. Wicks
CreationDate:   Sat Jun 30 12:06:27 2007
Tagged:         no
Pages:          1
Encrypted:      no
Page size:      612 x 792 pts (letter)
File size:      16224 bytes
Optimized:      no
PDF version:    1.2

$ /usr/bin/gsx t2.pdf
ESP Ghostscript 815.04 (2007-03-14)
Copyright (C) 2004 artofcode LLC, Benicia, CA.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Processing pages 1 through 1.
Page 1
   **** Embedded font uses undefined procedure RD
   [..]


This file works with gs8.60 and other recent versions.
Comment 11 Tim Waugh 2007-07-16 07:59:19 EDT
A snapshot of 8.60 from SVN is in rawhide now.
Comment 12 Tim Waugh 2007-07-30 05:18:41 EDT
*** Bug 249933 has been marked as a duplicate of this bug. ***
Comment 13 acount closed by user 2007-07-31 05:36:42 EDT
[gs-devel] GNU Ghostscript 8.60 release candidate
Ralph Giles giles at ghostscript.com 
Mon Jul 30 20:54:40 PDT 2007 

--------------------------------------------------------------------------------

All,

I've put up a release candidate for the upcoming 8.60 release. If you 
haven't tested the current code out of the repository, hopefully this 
will encourage you. If we don't find any showstoppers, we'll release on 
Wednesday, August 1st.

  http://ghostscript.com/~giles/ghostscript-8.60rc1.tar.gz

Cheers,
 -r
Comment 14 acount closed by user 2007-08-02 05:03:58 EDT
8.60 released: http://www.ghostscript.com/awki/GPL_Ghostscript_8.60
Comment 15 Roderick Johnstone 2007-08-22 04:41:31 EDT
I see the ghostscript 8.60 packages in rawhide. Any chance of having these as a
fedora 7 update?
Comment 16 Tim Waugh 2007-08-24 04:12:47 EDT
Unlikely.  Currently the rawhide package completely breaks CJK support.