This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 444868

Summary: man-pages-fr-2.79.0-3.fc9 conflicts with shadow-utils-4.1.1-1.fc9
Product: [Fedora] Fedora Reporter: Pierre-Yves <pingoufc4>
Component: man-pages-frAssignee: Alain Portal <alain.portal>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: alain.portal, bruno, guillaume, pvrabec, tmraz
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 2.79.0-4.fc7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-05-10 09:52:12 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235706    

Description Pierre-Yves 2008-05-01 08:10:53 EDT
Description of problem:
There is a conflict file between the packages:
 man-pages-fr-2.79.0-3.fc9.noarch
and
 shadow-utils-4.1.1-1.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1.yum update
2.enjoy !

Actual results:
=============================================================================
Updating:
 man-pages-fr            noarch     2.79.0-3.fc9     fedora            5.2 M

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total size: 5.2 M
Is this ok [y/N]: y
Downloading Packages:
Downloading DeltaRPMs:
Rebuilding rpms from deltarpms
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /usr/share/man/fr/man8/vipw.8.gz from install of
man-pages-fr-2.79.0-3.fc9.noarch conflicts with file from package
shadow-utils-4.1.1-1.fc9.x86_64

Error Summary
-------------


Expected results:
yum update :D
Comment 1 Rex Dieter 2008-05-01 09:05:32 EDT
*** Bug 444866 has been marked as a duplicate of this bug. ***
Comment 2 Alain Portal 2008-05-01 09:33:40 EDT
Thank for report.
I can't fix this bug today as I'm not in front of the machine on which I'm 
working on the package. It will be fix tomorrow.
Comment 3 Alain Portal 2008-05-01 11:27:40 EDT
Sorry for no french speaking people, but as this is a french specific problem 
and as I have to solve several problem that I'm not really able to explain in 
english, I need to be sure I'm understood and understanding the answers.

Je vais causer français pour la bonne cause !
J'ai besoin d'en savoir plus pour être certain que seule cette page pose 
problème.
En effet, la mise à jour du paquet a été acceptée après le gel (Ndt : freeze) 
de la F9. <voice mode="Lapalisse">Aujourd'hui, toute mise à jour pour la F9 
est une mise à jour pour la F9</voice> et ne peut donc être intégrée dans la 
F9 qui sortira.
Sauf à convaincre, ce que je ferais, les personnes qui gèrent tout ça, que le 
paquet actuel peut faire foirer l'installation de la F9.

Première chose : me donner la liste des pages de manuel en français de 
shadow-utils.

rpm -ql shadow-utils | grep "/usr/share/man/fr"

Histoire d'être certain que c'est la seule page du paquet qui soit en conflit.

La seconde sera sans doute plus délicate, mais l'idéal serait de désinstaller 
shadow-utils et retenter une mise à jour de man-pages-fr pour voir s'il n'y 
aurait pas d'autres conflits avec d'autres paquets.

En fait, je ne sais pas si yum s'arrête aux premières erreurs ou bien s'il 
signale toutes les erreurs qu'il rencontre.
Comment 4 Jeremy Katz 2008-05-01 11:44:34 EDT
This breaks installs for French users, hence is a blocker for the release. 
Comment 5 Pierre-Yves 2008-05-01 11:55:57 EDT
First thing comes first

$ rpm -ql shadow-utils | grep "/usr/share/man/fr"
/usr/share/man/fr/man1/chage.1.gz
/usr/share/man/fr/man1/gpasswd.1.gz
/usr/share/man/fr/man1/newgrp.1.gz
/usr/share/man/fr/man1/sg.1.gz
/usr/share/man/fr/man3/getspnam.3.gz
/usr/share/man/fr/man3/shadow.3.gz
/usr/share/man/fr/man5/faillog.5.gz
/usr/share/man/fr/man5/gshadow.5.gz
/usr/share/man/fr/man5/login.defs.5.gz
/usr/share/man/fr/man5/shadow.5.gz
/usr/share/man/fr/man8/adduser.8.gz
/usr/share/man/fr/man8/chpasswd.8.gz
/usr/share/man/fr/man8/faillog.8.gz
/usr/share/man/fr/man8/groupadd.8.gz
/usr/share/man/fr/man8/groupdel.8.gz
/usr/share/man/fr/man8/groupmod.8.gz
/usr/share/man/fr/man8/grpck.8.gz
/usr/share/man/fr/man8/grpconv.8.gz
/usr/share/man/fr/man8/grpunconv.8.gz
/usr/share/man/fr/man8/lastlog.8.gz
/usr/share/man/fr/man8/newusers.8.gz
/usr/share/man/fr/man8/pwck.8.gz
/usr/share/man/fr/man8/pwconv.8.gz
/usr/share/man/fr/man8/pwunconv.8.gz
/usr/share/man/fr/man8/useradd.8.gz
/usr/share/man/fr/man8/userdel.8.gz
/usr/share/man/fr/man8/usermod.8.gz
/usr/share/man/fr/man8/vigr.8.gz
/usr/share/man/fr/man8/vipw.8.gz


For the second since I do not have virtual machine over here I can not try...

What about trying via mock (you add shadow-utils as BR and see how far you can go) ?
Just an idea I am not sure that would do the trick...
Comment 6 Jeremy Katz 2008-05-01 21:09:39 EDT
*** Bug 444767 has been marked as a duplicate of this bug. ***
Comment 7 Kevin Kofler 2008-05-01 22:00:09 EDT
Normally, RPM reports all conflicts, not just the first one, so fixing the 
conflict which was reported should really fix the blocker bug.

Of course, the only way to check that there are no conflicts with some package 
somewhere in the repository is to install them all or write a script to check 
all their filelists.
Comment 8 Alain Portal 2008-05-02 07:26:27 EDT
(In reply to comment #7)
> Normally, RPM reports all conflicts, not just the first one, so fixing the 
> conflict which was reported should really fix the blocker bug.

Hope you right ;-)

> Of course, the only way to check that there are no conflicts with some 
package 
> somewhere in the repository is to install them all or write a script to 
check 
> all their filelists.

Of course, I can't install all the packages.
But how can I do to get the filelist of an uninstalled package without 
downloading the package?
Getting a list of all (english/french) man pages would be a good thing to me 
because this could help me to offer new translations.
Comment 9 Fedora Update System 2008-05-02 07:31:32 EDT
man-pages-fr-2.79.0-4.fc7 has been submitted as an update for Fedora 7
Comment 10 Fedora Update System 2008-05-02 07:32:48 EDT
man-pages-fr-2.79.0-4.fc8 has been submitted as an update for Fedora 8
Comment 11 Bill Nottingham 2008-05-02 10:45:53 EDT
Should be fixed in man-pages-fr-2.79.0-4.fc9
Comment 12 Bruno Wolff III 2008-05-02 13:22:39 EDT
I installed man-pages-fr-2.79.0-4.fc9rpm on a couple of systems and it installed
without any problems.
Comment 13 Alain Portal 2008-05-02 14:39:42 EDT
(In reply to comment #12)
> I installed man-pages-fr-2.79.0-4.fc9rpm on a couple of systems and it 
installed
> without any problems.

Of course, I fixed it ;-)

Don't you have system under F7 or F8?
If yes, could you increase karma?
https://admin.fedoraproject.org/updates/
Comment 14 Fedora Update System 2008-05-10 09:52:10 EDT
man-pages-fr-2.79.0-4.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.