Bug 488800

Summary: [StorageRewrite] DeviceException: Could not find device for path /dev/sdb
Product: [Fedora] Fedora Reporter: James Laska <jlaska>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 11CC: anaconda-maint-list, asayama, jturner, matzilla, mr_hankeys8rd, pjones, rmaximo, twoerner, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: StorageRewrite anaconda_trace_hash:e78e3924b6f7c14b57e0804999a584ade9df3c8e69f6c9d1e02b16975e66bace
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-06-25 11:40:49 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
Attached traceback automatically from anaconda.
Another duplicate
AttributeError: 'PartitionDevice' object has no attribute 'migrate' none

Description James Laska 2009-03-05 14:19:54 EST
The following was filed automatically by anaconda:
anaconda exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/device.py", line 48, in __init__
    self.__device = _ped.device_get(path)
  File "/tmp/updates/storage/devices.py", line 602, in __init__
    self.partedDevice = parted.Device(path=self.path)
  File "/tmp/updates/storage/devicetree.py", line 752, in addUdevDevice
  File "/tmp/updates/storage/devicetree.py", line 1013, in _populate
  File "/tmp/updates/storage/devicetree.py", line 155, in __init__
  File "/tmp/updates/storage/__init__.py", line 220, in reset
  File "/tmp/updates/storage/__init__.py", line 65, in storageInitialize
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
DeviceException: Could not find device for path /dev/sdb
Comment 1 James Laska 2009-03-05 14:19:59 EST
Created attachment 334184 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-03-10 11:31:19 EDT
*** Bug 489465 has been marked as a duplicate of this bug. ***
Comment 3 Owen Taylor 2009-03-12 07:59:51 EDT
Created attachment 334918 [details]
Another duplicate

Here's another duplicate traceback. The observation that might be useful (either for debugging or for people working around) is that it was caused by having my monitor's USB hub, which has an (empty) cf/sd card reader. Unplugging that got me past this issue.
Comment 4 Chris Lumens 2009-03-12 11:19:06 EDT
*** Bug 489918 has been marked as a duplicate of this bug. ***
Comment 5 James Laska 2009-03-12 13:35:29 EDT
I can consistently hit this failure on brutus.test.redhat.com.  This system is connected to a USB attached hub.  Off of the hub is a set of 6 IDE->USB converters which connect to 6 CDROM drives.

The CDROM drives do not have power, but it appears that the USB has enough power to see the devices.

With the USB hub not connected, my system sees:

sh-4.0# ls /sys/class/block/
dm-0   loop1  loop4  loop7  ram10  ram13  ram2  ram5  ram8  sda1
dm-1   loop2  loop5  ram0   ram11  ram14  ram3  ram6  ram9  sda2
loop0  loop3  loop6  ram1   ram12  ram15  ram4  ram7  sda   sr0

With the USB hub connected, but the CDROM drives powered off, my system sees:

sh-4.0# ls /sys/class/block/
dm-0   loop1  loop4  loop7  ram10  ram13  ram2  ram5  ram8  sda1  sdc  sdf
dm-1   loop2  loop5  ram0   ram11  ram14  ram3  ram6  ram9  sda2  sdd  sr0
loop0  loop3  loop6  ram1   ram12  ram15  ram4  ram7  sda   sdb   sde

sh-4.0# PYTHONPATH=/usr/lib/anaconda python -c 'import isys; print isys.mediaPresent("/dev/sdb");'
Comment 6 Chris Lumens 2009-03-13 09:54:07 EDT
*** Bug 490110 has been marked as a duplicate of this bug. ***
Comment 7 Thomas Woerner 2009-03-13 10:41:35 EDT
After deactivating all card readers (in monitor and in PC) the installer was also working for me.
Comment 8 Kyle 2009-03-14 17:23:51 EDT
Created attachment 335229 [details]
AttributeError: 'PartitionDevice' object has no attribute 'migrate'

My laptop has an internal SD card reader that I cannot disable from the BIOS and I hit this bug. After finding this report, I tried inserting an SD card, which got me further to the point that I got a graphical popup saying there was a bug and options to debug, save, or exit installer. The attachment is from /tmp/anacdump.txt at that time and has a different error from the other two attachments.

I've tried three different SD's. I wanted to format one locally to see if that got me by, but they are all loaded with stuff. Is there a way I can disable card reader support from grub?
Comment 9 Kyle 2009-03-14 20:13:55 EDT
I added the nousb boot option and received the error in my prior attachment (the equivalent of having an SD device plugged in.) This is a small indication to me that the second bug is not related to the first. Would anyone agree that I should create a separate bug report?
Comment 10 Chris Lumens 2009-03-16 14:29:37 EDT
I've committed a potential fix for this problem, though it needs some more thorough testing.  Please try the next build of anaconda and let me know the status.

Kyle - please try the next build as well, and if you are still seeing the problem you reported, open a new bug about it.  Your traceback does not appear to be related to the one being tracked in this bug report.  Thanks.
Comment 11 James Laska 2009-03-18 12:04:31 EDT
Retested with (anaconda build) and no longer seeing this issue
Comment 12 Kyle 2009-03-20 21:09:53 EDT
Agreed, bug is gone. I tried and hit another bug much earlier in the boot process. Then I tried and got back to comment #9 without the nousb option or an SD card plugged in.
Comment 13 Matthieu Araman 2009-03-30 07:09:03 EDT
looks fixed for me too, with anaconda from 20090326 boot.iso.
I can go completely through the installation without unplugging my usb card reader.
Comment 14 Bug Zapper 2009-06-09 07:55:37 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here: