Bug 488980

Summary: [KMS, 845] Invisible mouse cursor in X
Product: [Fedora] Fedora Reporter: Michael Young <m.a.young>
Component: xorg-x11-drv-intelAssignee: Kristian Høgsberg <krh>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: high    
Version: rawhideCC: ackistler, ajax, ariszlo, awilliam, dwlegg, idht4n, jason, jbarnes, jbastian, jfrieben, jlayton, kicsia, lkundrak, mark, notting, rda, rnichols42, tristanheaven, xgl-maint, yates
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-05-21 10:10:03 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 487202, 497399    
Attachments:
Description Flags
Xorg log file
none
Xorg.0.log with Fedora11 Beta LiveCD on i845 video
none
Xorg.0.log with Fedora11 Beta LiveCD on i845 video with "nomodeset" boot parameter
none
Xorg.0.log with Fedora11 Beta on i845 video
none
Xorg.0.log with Fedora11 Beta with "nomodeset" boot parameter on i845 video
none
Xorg.0.log for f11 Preview Live CD with default boot parameters
none
support 8xx desktop cursors none

Description Michael Young 2009-03-06 11:18:53 EST
Created attachment 334313 [details]
Xorg log file

When I start X there is no mouse cursor visible. If I move the mouse around I can see from how the screen reacts that it is there, and with some guesswork I can even click on objects, but I can't directly see where the mouse is.
Comment 1 Michael Young 2009-03-06 11:34:53 EST
Incidentally this is without an /etc/X11/xorg.conf file.
Comment 2 Michael Young 2009-03-12 08:03:00 EDT
Note that if I boot the kernel with the nomodeset option then I do get a mouse pointer.
Comment 3 Lubomir Rintel 2009-03-15 12:49:13 EDT
According to certain reports [1], this works with kernel 2.6.29-0.73.rc3.git2.fc11.i686 and is broken in 2.6.29-0.131.rc5.git2.fc11.i686.

[1] https://www.redhat.com/archives/fedora-test-list/2009-February/msg00816.html
Comment 4 Jason Long 2009-03-16 08:48:11 EDT
I don't know about 2.6.29-0.73.rc3.git2, but I've tested 2.6.29-0.78.rc3.git2. That version of the kernel doesn't have the mouse pointer problem, but neither does it have kernel mode setting (as far as I can tell).

I.e.

2.6.29-0.78.rc3.git5 - pointer is visible, but no kms
2.6.29-0.197.rc7      - kms works, but no mouse pointer
2.6.29-0.218.rc7.git2 - kms works, but no mouse pointer
2.6.29-0.237.rc7.git4 - kms works, but no mouse pointer
Comment 5 Joachim Frieben 2009-04-12 14:45:53 EDT
Same issue for Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device rev 3. Installed packages include:
- kernel-2.6.29.1-68.fc11.i586
- xorg-x11-drv-intel-2.6.99.902-2.fc11.i586
- xorg-x11-server-Xorg-1.6.0-19.fc11.i586
Comment 6 Joachim Frieben 2009-04-15 03:02:08 EDT
No improvement for latest packages:
- kernel-2.6.29.1-70.fc11.i586
- xorg-x11-drv-intel-2.6.99.902-3.fc11.i586
- xorg-x11-server-Xorg-1.6.1-1.fc11.i586
Comment 7 Antal KICSI 2009-04-19 10:22:00 EDT
Created attachment 340235 [details]
Xorg.0.log with Fedora11 Beta LiveCD on i845 video

The Fedora11 Beta Live CD does not work as expected on my computer
(Fujitsu-Siemens ScenicS2 with i845 integrated video ): boots, almost
everything works exept no mouse cursor.  It detects motion, but the 
cursor is invisible.I can guess where the cursor is and click in the
right place.This is the same behaviour as with the 2009-03-12 Intel
Test Days Live CD. I attached the Xorg.0.log for this case.

Adding "nomodeset" to the boot command line resulted in a running
Xserver with mouse cursor. The system works slower as my currently
installed Fedora 8, but it works.

I reported the same problem at BZ469292 before, but at Adam Williamson's sugestion I report it on this thread also.
Comment 8 Antal KICSI 2009-04-19 10:24:27 EDT
Created attachment 340236 [details]
Xorg.0.log with Fedora11 Beta LiveCD on i845 video with "nomodeset" boot parameter

Attached the Xorg.0.log when I started the Fedora11 Beta LiveCD with
"nomodeset" boot parameter - running Xserver with mouse cursor.
Comment 9 Antal KICSI 2009-04-19 12:14:54 EDT
Created attachment 340240 [details]
Xorg.0.log with Fedora11 Beta on i845 video

I tried with:

kernel-2.6.29.1-68.fc11.i586
xorg-x11-drv-intel-2.6.99.902-3.fc11.i586
xorg-x11-server-Xorg-1.6.0-17.fc11.i586

with the following results:

without the "nomodeset" kernel parameter I have no mouse cursor
at the login screen but I can gess where it is. After login still 
no mouse cursor

glxgears corrupted 	: ~ 375 FPS
x11perf -putimage100 	: ~ 320/sec

Attached Xorg.0.log for this case.
Comment 10 Antal KICSI 2009-04-19 12:17:11 EDT
Created attachment 340241 [details]
Xorg.0.log with Fedora11 Beta with "nomodeset" boot parameter on i845 video 

With "nomodeset" kernel parameter - I have mouse cursor, everything
looks OK

glxgears (OK) 		: ~ 300 FPS
x11perf -putimage100	: ~ 5160/sec (!!)

kernel-2.6.29.1-68.fc11.i586
xorg-x11-drv-intel-2.6.99.902-3.fc11.i586
xorg-x11-server-Xorg-1.6.0-17.fc11.i586
Comment 11 Mark Chesterfield 2009-04-23 13:31:27 EDT
I have the identical problem on the latest Fedora-11 Beta, no visible mouse cursor.

kernel-PAE-2.6.29.1-102.fc11.i686
xorg-x11-drv-intel-2.7.0-1.fc11.i586
xorg-x11-server-Xorg-1.6.1-6.fc11.i586
Comment 12 Bob Arendt 2009-04-26 21:57:32 EDT
This problem persists with today's rawhide:
   Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset (rev 03)

kernel-2.6.29.1-102.fc11.i586
xorg-x11-server-Xorg-1.6.1-6.fc11.i586
package xorg-x11-drv-i810 is not installed
xorg-x11-drv-synaptics-1.1.0-3.fc11.i586
libdrm-2.4.6-6.fc11.i586
mesa-libGL-7.5-0.9.fc11.i586
mesa-libGLU-7.5-0.9.fc11.i586
mesa-dri-drivers-7.5-0.9.fc11.i586
Comment 13 Antal KICSI 2009-04-28 17:12:39 EDT
The problem persists with today's F11 Preview - Intel Corporation 82845G video chipset

I cannot attach Xorg.0.log because my USB drive does not mount!!!!!
Comment 14 Antal KICSI 2009-04-28 17:27:24 EDT
In addition to previous post - I tried with F11-Preview Live CD on Fujitsu-Siemen Scenic S2 with integrated I845 video on board.
If I use "nomodeset" boot parameter everything looks OK.

I do not specified all the details before because I get frustrated by this stupid error that keeping me to use Fedora8. Really, I am sick and tired about this I845 problem from nearly a year ago!

Please find some solution! Thanks!
Comment 15 Antal KICSI 2009-04-28 17:59:38 EDT
Created attachment 341657 [details]
Xorg.0.log for f11 Preview Live CD with default boot parameters

This is the Xorg.0.conf for Fedora11 Preview Live CD with Gnome - on I845 integrated video chipset without any kernel parameter but the defaults ( KMS enabled, no xorg.conf ).

I managed to mount my USB drive via terminal. The graphical automount still does not work.
Comment 16 Adam Williamson 2009-04-28 19:36:35 EDT
I don't think we really need any further logs on this one. I think we have all the information for the bug to be fixed, we just need to find the developer time. At least, further Xorg.0.logs are unlikely to be any help. Thanks, guys.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 17 Adam Jackson 2009-05-07 17:21:30 EDT
*** Bug 498708 has been marked as a duplicate of this bug. ***
Comment 18 Bob Arendt 2009-05-08 23:10:39 EDT
Issue persists with todays rawhide:

kernel-2.6.29.2-126.fc11.i586
xorg-x11-server-Xorg-1.6.1-11.fc11.i586
xorg-x11-drv-intel-2.7.0-4.fc11.i586
xorg-x11-drv-synaptics-1.1.0-5.fc11.i586
libdrm-2.4.6-6.fc11.i586
mesa-libGL-7.5-0.9.fc11.i586
mesa-libGLU-7.5-0.9.fc11.i586
mesa-dri-drivers-7.5-0.9.fc11.i586
Comment 19 Ariszló 2009-05-09 14:26:56 EDT
With kernel-PAE-2.6.29.2-126.fc11, I need to add nomodeset to the kernel line in /boot/grub/grub.conf to see the mouse pointer.

No mouse pointer issue at all with the plain, non-PAE kernel:
kernel-2.6.29.2-126.fc11

00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE
Chipset Integrated Graphics Device (rev 01)

Upstream bug report:
http://bugs.freedesktop.org/show_bug.cgi?id=21373
Comment 20 Ariszló 2009-05-09 14:45:26 EDT
(In reply to comment #19)
> No mouse pointer issue at all with the plain, non-PAE kernel:
> kernel-2.6.29.2-126.fc11

Sorry, I was wrong about the non-PAE kernel. I have just installed it letting yum adding it to grub.conf. Assuming that yum did not add the nomodeset option, rebooted the machine, saw the mouse pointer and thought what I did. Now I can see that yum did add the nomodeset option to the non-PAE kernel, perhaps copying it from the manually edited kernel line of the PAE kernel.
Comment 21 Will Woods 2009-05-13 11:05:08 EDT
*** Bug 500650 has been marked as a duplicate of this bug. ***
Comment 22 Bill Nottingham 2009-05-15 16:17:25 EDT
Does this persist with the current rawhide .140 kernel?
Comment 23 Jason Long 2009-05-15 17:11:47 EDT
Yes, the issue persists with current rawhide:

kernel-2.6.29.3-140.fc11.i586
xorg-x11-server-Xorg-1.6.1-11.fc11.i586
xorg-x11-drv-intel-2.7.0-4.fc11.i586
libdrm-2.4.6-6.fc11.i586

Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 03)
Comment 24 Antal KICSI 2009-05-16 11:36:09 EDT
Yes, the issue is present with

kernel-2.6.29.3-140.fc11.i586
xorg-x11-server-Xorg-1.6.1-11.fc11.i586
xorg-x11-drv-intel-2.7.0-4.fc11.i586
Comment 25 Michael Young 2009-05-18 06:06:01 EDT
The problem persists with
kernel-PAE-2.6.29.3-140.fc11.i686
xorg-x11-server-Xorg-1.6.1-11.fc11.i586
xorg-x11-drv-intel-2.7.0-4.fc11.i586

and with
kernel-PAE-2.6.29.3-142.i686
xorg-x11-server-Xorg-1.6.1-14.fc11.i586
xorg-x11-drv-intel-2.7.0-4.fc11.i586
Comment 26 Lubomir Rintel 2009-05-18 06:11:24 EDT
I don't think posting more broken revision numbers helps anyhow.
Comment 27 Jesse Barnes 2009-05-20 14:24:56 EDT
Created attachment 344857 [details]
support 8xx desktop cursors

Can someone give this patch a try?  The kernel was lacking support for 8xx desktop cursors entirely (they have a different register layout than later chips).
Comment 28 Michael Young 2009-05-20 17:07:15 EDT
I have built a PAE kernel with this patch at
http://fedorapeople.org/~myoung/kernel-PAE-2.6.29.3-154.bz488980.fc11.i686.rpm
though I can't test it myself until tomorrow morning.
Comment 29 Kristian Høgsberg 2009-05-20 17:19:21 EDT
kernel-2.6.29.3-155 should have a fix for this, building here:

  http://koji.fedoraproject.org/koji/taskinfo?taskID=1367177

and should be in F-11 tomorrow.
Comment 30 Adam Williamson 2009-05-20 17:24:13 EDT
Please, reporters, test the updated kernel as fast as you can: we're on a tight schedule for F11 final release here. thanks!
Comment 31 Adam Williamson 2009-05-20 18:29:44 EDT
This issue is listed in the Fedora 11 Common Bugs page (pre-release):

https://fedoraproject.org/wiki/Common_F11_bugs#845-no-cursor
Comment 32 Jeff Bastian 2009-05-20 18:48:41 EDT
The packages from comment 29 fixed the problem for me!
Comment 33 Joachim Frieben 2009-05-21 02:54:51 EDT
Issue fixed by kernel-PAE-2.6.29.3-155.fc11 for "Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device rev 3". Thank you guys!
Comment 34 Ariszló 2009-05-21 04:40:48 EDT
(In reply to comment #27)
> Created an attachment (id=344857) [details]
> support 8xx desktop cursors

Thanks a lot! Have you sent the patch upstream?
Comment 35 Michael Young 2009-05-21 05:13:35 EDT
kernel-PAE-2.6.29.3-155.fc11 works for me as well (though not the kernel I built yesterday, which causes the screen to jump, so don't use it).
Comment 36 Jeff Layton 2009-05-21 07:11:46 EDT
This kernel fixed the problem of the mouse cursor being invisible with KMS enabled:

    kernel-PAE-2.6.29.3-155.fc11.i686

...however, my machine is hanging frequently when I enable KMS. It may actually be oopsing -- hard to tell with X on the screen. Disabling KMS seems to prevent the hangs.

This is probably a separate issue though. It's quite possible that earlier kernels had this problem as well, and I just couldn't tell since KMS wasn't usable for me with no mouse cursor.
Comment 37 Jason Long 2009-05-21 08:55:45 EDT
I confirm the issue is fixed for me with the

kernel-2.6.29.3-155.fc11.i586

linked to on comment 29.
Comment 38 Jeff Bastian 2009-05-21 09:24:40 EDT
(In reply to comment #36)
> ...however, my machine is hanging frequently when I enable KMS.


Yes, mine too.  I didn't run it long enough yesterday after verifying the mouse cursor is visible, but today I'm seeing it hang after a few minutes.  It's not a complete hang, however, as the mouse cursor still moves (but mouse clicks don't do anything), and I can still log in remotely and it works fine.

I also noticed that the kernel puts the monitor (an old CRT) into 1280x1024 while booting, but when X starts it drops to 1024x768, which defeats the flicker-free experience.
Comment 39 Kristian Høgsberg 2009-05-21 10:10:03 EDT
Ok, great, thanks for confirming.  The hangs are unfortunate but they can't be a side-effect of this fix.  I'm closing this bug now; if you can get the dmesg output, Xorg.0.log by remote logging in to a hung system, please open a new bug and attach these files.  For extra bug-hunting credits, try logging in with ssh -Y (X forwarding), then running sysprof on the hung system and attaching the results.  If you don't know what this mean, don't worry about it ;) Thanks.
Comment 40 Antal KICSI 2009-05-21 14:14:26 EDT
The packages from comment 29 fixed the problem for me!
Thanks a lot!
Comment 41 Lubomir Rintel 2009-05-21 14:40:47 EDT
(In reply to comment #39)
> For extra bug-hunting credits, try logging in with ssh
> -Y (X forwarding), then running sysprof on the hung system and attaching the
> results.

I've opened a separate ticket, bug #502077. No extra credits for sysprof (did not reveal anything useful); I can provide an access to the machine that this can be reproduced on & serial console if needed though.
Comment 42 Adam Williamson 2009-05-21 15:19:28 EDT
can other reporters confirm whether or not they are seeing hangs with normal use with modesetting enabled, as Lubomir does?
Comment 43 Jason Long 2009-05-21 15:39:55 EDT
I have not noticed any hangs on my box since enabling modesetting.
Comment 44 Mark Chesterfield 2009-05-22 07:11:52 EDT
Confirming that kernel-2.6.29.3-155.fc11.i686.PAE appears to have fixed the invisible mouse cursor issue.

Thank-you
Comment 45 David 2009-05-22 15:58:35 EDT
(In reply to comment #42)
> can other reporters confirm whether or not they are seeing hangs with normal
> use with modesetting enabled, as Lubomir does?  

My system sorta hung with modesetting enabled ... the keyboard was unresponsive and I couldn't click on anything with the mouse.  Ironically the mouse pointer was there and moving, so it was the only thing working under X.  This happened about 30 seconds after I started up.  I tried to unhide my panel and it moved half way down and froze.  I had to push the power button to shut down.
Comment 46 Adam Williamson 2009-05-22 16:12:08 EDT
david: do you have an 845, 855 or 865 chipset? if 865, please follow up on 502077.
Comment 47 Michael Young 2009-05-22 16:22:00 EDT
I had my computer on for 7 or 8 hours without a hang (with an 845 as shown by the first attachment). I did see some stray pixels in short lines when scrolling.
Comment 48 Adam Williamson 2009-05-22 16:27:25 EDT
michael: that's 502096.
Comment 49 David W. Legg 2009-05-25 14:57:30 EDT
Fixed for me and my Intel 845 chipset. Thanks.
Comment 50 Allen Kistler 2009-06-08 14:43:03 EDT
*** Bug 495032 has been marked as a duplicate of this bug. ***