Bug 495479

Summary: RFE: Support graceful reboot with KVM guests
Product: Red Hat Enterprise Linux 5 Reporter: Nan Zhang <nzhang>
Component: libvirtAssignee: Daniel Veillard <veillard>
Status: CLOSED WONTFIX QA Contact: Virtualization Bugs <virt-bugs>
Severity: medium Docs Contact:
Priority: low    
Version: 5.4CC: berrange, dallan, gozen, hbrock, jdenemar, jialiu, llim, virt-maint, xen-maint
Target Milestone: rcKeywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 524779 (view as bug list) Environment:
Last Closed: 2011-01-31 16:43:12 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 496537, 506929    
Bug Blocks: 524779    

Description Nan Zhang 2009-04-13 07:41:44 EDT
Description of problem:
The following error messages occurs when rebooting guest domain.
--------------------
error: Failed to reboot domain kvmtest
error: this function is not supported by the hypervisor: virDomainReboot
--------------------

Version-Release number of selected component (if applicable):
rhel5u3: 2.6.18-128.el5
kvm-83-27.el5ovirt
libvirt-0.6.2-1.el5

How reproducible:
Always

Steps to Reproduce:
1. define a guest domain from xml
2. # virsh start kvmtest
3. # virsh reboot kvmtest
  
Actual results:
Failed to reboot the guest domain.

Expected results:
The guest domain can be rebooted successfully.

Additional info:
shutdown and destroy operation are normally.
Comment 1 Daniel Veillard 2009-04-22 08:30:46 EDT
Yes, as far as I can tell this won't be supported in 0.6.3, QEmu has no support
for a 'reboot' operation, only shutdown. This could be worked around in libvirt
but that would be made with "shutdown and start", not exactly equivalent to
a reboot at the QEmu level though.

So not for 5.4, maybe in 5.5, either though QEmu or via a libvirt workaround.

Daniel
Comment 2 Daniel Berrange 2009-06-19 07:13:02 EDT
Yep, this is a current limitation of QEMU, so fixing this is blocked on getting the RFE in QEMU.
Comment 3 Daniel Berrange 2009-10-29 13:16:49 EDT
The upstream QEMU discussion basically ended with them rejecting the idea of a 'system_reboot' monitor command. We'll probably have to fake this in libvirt instead, by issuing a 'system_shutdown' and waiting for it to shut down, and then start it up again.
Comment 6 Daniel Veillard 2009-12-25 08:42:43 EST
*** Bug 550157 has been marked as a duplicate of this bug. ***
Comment 11 RHEL Product and Program Management 2011-01-11 14:59:28 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 12 RHEL Product and Program Management 2011-01-11 17:58:53 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.