Bug 495665

Summary: Crash during custom layout
Product: [Fedora] Fedora Reporter: MartinG <martin>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: anaconda-maint-list, andreas, cje, pjones, rmaximo, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: anaconda_trace_hash:83b7cdf2e30e0c6ae2641dce6c28b8a1b910d1b52af975cf6d9f6389f433c343
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-04-14 13:31:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Attached traceback automatically from anaconda. none

Description MartinG 2009-04-14 10:04:05 UTC
The following was filed automatically by anaconda:
anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_ui_helpers_gui.py", line 401, in createPreExistFSOptionSection
    formatcb.connect("toggled", formatOptionResizeCB, (resizesb, origfs))
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 498, in <lambda>
    luksdev=templuks)
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 550, in editLogicalVolume
    (row, self.fsoptionsDict) = cpefsos(maintable, row)
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 775, in editCurrentLogicalVolume
    self.editLogicalVolume(lv)
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 831, in logvolActivateCb
    self.editCurrentLogicalVolume()
AttributeError: 'NoneType' object has no attribute 'connect'

Comment 1 MartinG 2009-04-14 10:04:11 UTC
Created attachment 339454 [details]
Attached traceback automatically from anaconda.

Comment 2 MartinG 2009-04-14 10:09:21 UTC
This was from Fedora-11-Snap1-x86_64-Live-KDE, with upgraded anaconda-11.5.0.44-1 from koji.

The exception happened when I ran custom layout, and edited the (now empty/uninitialized) swap volume.

Comment 3 Chris Lumens 2009-04-14 13:31:29 UTC
This will be fixed in the next build of anaconda.  Thanks for the bug report.

Comment 4 Chris Lumens 2009-04-14 15:59:48 UTC
*** Bug 495744 has been marked as a duplicate of this bug. ***

Comment 5 Chris Lumens 2009-04-15 13:59:15 UTC
*** Bug 495810 has been marked as a duplicate of this bug. ***

Comment 6 MartinG 2009-04-17 13:20:15 UTC
Thank you! This worked for me:
Boot the snap1 live image, get packages from koji and install:
# yum --nogpgcheck localinstall \
anaconda-11.5.0.45-2* 
NetworkManager-0.7.1-3.git20090414.fc11* \
NetworkManager-glib-0.7.1-3.git20090414.fc11* \
NetworkManager-gnome-0.7.1-3.git20090414.fc11*

Then install to disk - create custom layout -> works!