Bug 495665 - Crash during custom layout
Crash during custom layout
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:83b7cdf2e30e0c6ae...
:
: 495744 495810 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-14 06:04 EDT by MartinG
Modified: 2009-04-17 09:20 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 09:31:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (84.75 KB, text/plain)
2009-04-14 06:04 EDT, MartinG
no flags Details

  None (edit)
Description MartinG 2009-04-14 06:04:05 EDT
The following was filed automatically by anaconda:
anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_ui_helpers_gui.py", line 401, in createPreExistFSOptionSection
    formatcb.connect("toggled", formatOptionResizeCB, (resizesb, origfs))
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 498, in <lambda>
    luksdev=templuks)
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 550, in editLogicalVolume
    (row, self.fsoptionsDict) = cpefsos(maintable, row)
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 775, in editCurrentLogicalVolume
    self.editLogicalVolume(lv)
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 831, in logvolActivateCb
    self.editCurrentLogicalVolume()
AttributeError: 'NoneType' object has no attribute 'connect'
Comment 1 MartinG 2009-04-14 06:04:11 EDT
Created attachment 339454 [details]
Attached traceback automatically from anaconda.
Comment 2 MartinG 2009-04-14 06:09:21 EDT
This was from Fedora-11-Snap1-x86_64-Live-KDE, with upgraded anaconda-11.5.0.44-1 from koji.

The exception happened when I ran custom layout, and edited the (now empty/uninitialized) swap volume.
Comment 3 Chris Lumens 2009-04-14 09:31:29 EDT
This will be fixed in the next build of anaconda.  Thanks for the bug report.
Comment 4 Chris Lumens 2009-04-14 11:59:48 EDT
*** Bug 495744 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2009-04-15 09:59:15 EDT
*** Bug 495810 has been marked as a duplicate of this bug. ***
Comment 6 MartinG 2009-04-17 09:20:15 EDT
Thank you! This worked for me:
Boot the snap1 live image, get packages from koji and install:
# yum --nogpgcheck localinstall \
anaconda-11.5.0.45-2* 
NetworkManager-0.7.1-3.git20090414.fc11* \
NetworkManager-glib-0.7.1-3.git20090414.fc11* \
NetworkManager-gnome-0.7.1-3.git20090414.fc11*

Then install to disk - create custom layout -> works!

Note You need to log in before you can comment on or make changes to this bug.