This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 519350

Summary: Installing F12 rawhide using F12 Alpha anaconda results in no initrd in bootloader conf - should we disallow enabling other repos in the UI?
Product: [Fedora] Fedora Reporter: Niels Haase <arxs>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: low    
Version: rawhideCC: atodorov, awilliam, bjrosen, bugzilla.redhat, dcantrell, dgregor, fche, gczarcinski, itamar, jstodola, kernel-maint, markmc, mat.booth, mbanas, mgleahy, notting, pedrofsilva, rbiba, rjones, robxu9, rwilliam, scottt.tw, spacewar, vanmeeuwen+fedora, xx3nvyxx
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 523751 (view as bug list) Environment:
Last Closed: 2009-10-07 11:34:52 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 473303, 523751    
Attachments:
Description Flags
anaconda.log file grabs when "reboot now" screen in anaconda are shown
none
grub.conf file grabs when "reboot now" screen in anaconda are shown
none
yaboot.conf from PPC machine with RHEL6.0-20090904.5 none

Description Niels Haase 2009-08-26 05:40:14 EDT
Description of problem:
Installation of Fedora 12 Alpha x86_64 DVD into VirtualBox 3.0.4 won't boot.

VFS: Cannot open root device "mapper/vg_fedora12vb-lv_root" or unknown-block(0,0)
Please append a correct "root=" boot option; here are the available partitions:
0800 62914560 sda driver: sd
0801 204800 sda1
0802 62705708 sda2
0b00 1048575 sr0 driver: sr
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

Version-Release number of selected component (if applicable):
Fedora 12 Alpha x86_64 Install DVD with Install and Rawhide repo enabled during the install.

How reproducible:
100%  

Steps to Reproduce:
1. Install from x86_64 install DVD
2. Choose the Install and Rawhide repo
3. After the selection of software, and the successfully install of them, the next screen is the "Please reboot now". Maybe I miss something, but the setup of grub, is it missing here?
  
Actual results:
non working F12 install

Expected results:
working F12 install

Additional info:
Comment 1 Niels Haase 2009-08-26 07:44:06 EDT
Created attachment 358705 [details]
anaconda.log 
file grabs when "reboot now" screen in anaconda are shown
Comment 2 Niels Haase 2009-08-26 07:45:37 EDT
Created attachment 358706 [details]
grub.conf file grabs when "reboot now" screen in anaconda are shown 

/mnt/sysimage/boot/grub/grub.conf
Comment 3 Andrew Parker 2009-08-26 09:02:24 EDT
I get a "VFS: Unable to mount root fs on unknown-block(0,0)" on an i686 install too.  (0,0) is not part of the current install.
Comment 4 William Washco 2009-08-26 13:52:52 EDT
When booting normally:
Kernel panic - not syncing: VFS: unable to mount root fs on unknown-block(0,0)

When booting to grub command line:
grub> root (hd0,0)
grub> kernel /boot/vmlinux-2.6.31-0.174.rc7.git2.fc12.i686
grub> initrd /boot/initrd-generic-2.6.31-0.174.rc7.git.fc12.i686.img
grub> boot

A wall of text that I can't scroll through flies by. The last screen shown has
this:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
|Freeing unused kernel memory: 1764k freed
|Write protecting the kernel text: 5260k
|Write protecting the kernel read-only data: 1772k
|mknod used greatest stack depth: 6760 bytes left
|mknod used greatest stack depth: 6760 bytes left
|mknod used greatest stack depth: 6760 bytes left
|dracut: dracut-0.9-2.fc12
|dracut: dracut-0.9-2.fc12
|dracut: FATAL: No or empty root= argument
|dracut: Refusing to continue
|dracut: FATAL: No or empty root= argument
|dracut: Refusing to continue
|
|
|Signal caught!
|
|Boot has failed, sleeping forever.
|Synaptics Touchpad, model: 1, fw:5.9, id: 02c6ab1, caps 0x884793/0x0
|serio: Synaptics pass-through port at isa0060/serio1/input0
|input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input5
|async/1 used greatest stack depth: 5872 bytes left
|IBM TrackPoint firmware: 0x0e, buttons: 3/3
|input: TPPS/2 IBM TrackPoint as /devices/platform/i8042/serio1/serio2/input/inpu
|t6
|_
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Tried my best to copy it as exactly as possible, and I would have more info if
I could scroll up. Hope it helps.
Comment 5 Gene Czarcinski 2009-08-26 15:27:23 EDT
The kernel on rawhide is bad. Work around (at least for me) ...

bootup the DVD/CD in rescue mode.  

mount the DVD/CD

Install the kernel from the DVD/CD
   rpm -ivh --oldpackage <kernel from DVD/CD>

This worked for me ... of course then graphics hung.
Comment 6 Mat Booth 2009-08-26 17:04:16 EDT
Hi all,

I get the error described in the bug summary when trying to install the F12 Alpha i386 into a KVM virtual machine using the netinst image. I've tried twice now.

The installation appears to complete successfully. Then I click the "Reboot" button at the end of the installation process and then some stack traces appear in the console before it reboots. Here are some screenshots of the crash in action:

http://mbooth.fedorapeople.org/F12AlphaCrash/00003208.jpg
http://mbooth.fedorapeople.org/F12AlphaCrash/00003252.jpg
http://mbooth.fedorapeople.org/F12AlphaCrash/00003253.jpg
http://mbooth.fedorapeople.org/F12AlphaCrash/00003254.jpg
http://mbooth.fedorapeople.org/F12AlphaCrash/00003255.jpg
http://mbooth.fedorapeople.org/F12AlphaCrash/00003312.jpg

Then after the reboot:

http://mbooth.fedorapeople.org/F12AlphaCrash/00003407.jpg

Bang! And the machine is dead!
Comment 7 Mat Booth 2009-08-26 17:08:35 EDT
I can't really tell if I missed anything in the recording. If you think I did, let me know and I will see if I can capture more by recording the crash at a higher frame rate and post more screenshots.
Comment 8 Mat Booth 2009-08-26 17:18:59 EDT
Oh I forgot to mention, this is with kernel 2.6.31-0.125.4.2.rc5.git2.fc12.i686
Comment 9 Mat Booth 2009-08-26 17:21:42 EDT
(In reply to comment #8)
> Oh I forgot to mention, this is with kernel 2.6.31-0.125.4.2.rc5.git2.fc12.i686  

No wait, that's the one on the CD, the one it installed was kernel-PAE-2.6.31-0.174.rc7.git2.fc12.i686
Comment 10 William Washco 2009-08-26 17:48:50 EDT
(In reply to comment #4)
This:

grub> root (hd0,0)
grub> kernel /boot/vmlinux-2.6.31-0.174.rc7.git2.fc12.i686 root=/dev/sda1
grub> initrd /boot/initrd-generic-2.6.31-0.174.rc7.git.fc12.i686.img
grub> boot

Seems to work for me.
Comment 11 William Washco 2009-08-26 17:50:48 EDT
(In reply to comment #10)
Although, I can't seem to use my laptop's touchpad or keyboard now that firstboot is up...
Comment 12 William Washco 2009-08-26 19:09:34 EDT
(In reply to comment #11)
firstboot output:

Window manager warning: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf for information. (Details -  1: Failed to get connection session: An SELinux policy prevents this sender from sending this message to this recipient (rejected message had sender "(unset)" interface "org.freedesktop.DBus" member "Hello" error name "(unset)" destination "org.freedesktop.DBus"))

<that one fills up the top half of the screen, repeated over and over again>

firstboot ERROR: Module language does not contain a class named moduleClass; skipping.
Loading /lib/kbd/keymaps/i386/qwerty/us.map.gz
/usr/share/system-config-date/scdMainWindow.py:245: GtkWarning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
  self.xml = gtk.glade.XML ("/usr/share/system-config-date/system-config-date.glade", domain="system-config-date")
/usr/share/system-config-date/timezone_map_gui.py:339: DeprecationWarning: Use the new widget gtk.Tooltip
  self.tooltips = gtk.Tooltips ()
/usr/share/system-config-date/timezone_map_gui.py:340: DeprecationWarning: Use the new widget gtk.Tooltip
  self.tooltips.set_tip (self.canvas, _('Use button 2 or 3 for panning and the scrollwheel to zoom in or out.'))
/usr/share/smolt/client/smolt.py:388: DeprecationWarning BaseException.message has been depricated as of Python 2.6
  self.message = message
/usr/share/smolt/client/smolt.py:1093: DeprecationWarning BaseException.message has been depricated as of Python 2.6
  error(_('Error:') + ' ' + e.message)
Error: Could not bind to dbus. Is dbus running?
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x4000ab (firstboot)
Window manager warning: meta_window_activate called by pager with a 0 timestamp; the pager needs to be fixed.


<next I will try setting selinux to permissive (see first error mentioning selinux)>
Comment 13 William Washco 2009-08-26 19:22:32 EDT
Posting from F12 alpha now. To sum up, the steps I took to boot into F12 are as follows:

1. make sure grub is booting to the correct root (edit the config line to be a /dev/ path instead of it's default)
2. add initrd /path/to/initrd_file to the boot options
3. boot into single user mode and set selinux to permissive /etc/sysconfig/selinux

YMMV, but that's what worked for me. Hope this helps!
Comment 14 Alexander Todorov 2009-08-27 03:22:14 EDT
William,
comment #12 seems to be firstboot issue and not related to the original problem reported here. Can you report the firstboot failure separately. 

Thanks!
Comment 15 Pedro Silva 2009-08-28 16:37:33 EDT
I'm also seeing this problem.

Installing with F12 Alpha Netinstall CD.

Install works fine until reboot, it stops with the bug's title error message.

Following comment #10, I booted the machine in rescue mode, edited grub.conf and inserted the line:

initrd /initrd-generic-2.6.30-0.180.rc7.git4.fc12.i686.PAE.img

and rebooted.

After this, boot started and firstboot came up, great!

It seems anaconda or something during the install process "forgets" to add that line in /boot/grub.conf. Or am I missing something here?
Comment 16 Pedro Silva 2009-08-28 17:05:46 EDT
Err... didn't read that title well, my issue is with a real machine/box, not with VirtualBox product. :S
Comment 17 William Washco 2009-08-28 18:20:34 EDT
(In reply to comment #16)
> Err... didn't read that title well, my issue is with a real machine/box, not
> with VirtualBox product. :S  

It's the same bug afaik. Also, that is consistent with my tests, and may very well be the underlying cause.
Comment 18 mgl 2009-09-07 11:28:15 EDT
I can confirm that the missing initrd line in the grub.conf is the problem.  I just did this on my own VirtualBox install where I was getting the same error.  I booted with a live linux CD, mounted the boot partition, edited grub.conf and added initrd /initrd-generic-[whatever_the_current_version_is].rc9.fc12.i686.img, then rebooted and it worked.

Thanks for posting that solution.
Comment 19 Gene Czarcinski 2009-09-07 12:37:19 EDT
I have run various test installs both as qemu-kvm guests and on real hardware.

In all cases, the following occurs:

1. If I install only from a DVD only then everything works as expected and the kernel on the DVD is installed together with the initrd statement in grub.conf.  Once installed, I can boot and install the current kernel from development/rawhide -- everything works OK with the proper initrd statement.

2. On the other hand, if I install from DVD (same DVD as above) plus get updates from development/rawhide to be used during install, then there is the missing initrd statement and the system is not bootable.

It is not clear to me why this is happening.
Comment 20 Martin Banas 2009-09-09 10:09:02 EDT
The same issue found on RHEL6.0-20090904.5 on PPC. There is missing line with "initrd" in yaboot.conf and the system cannot boot.

Components:

RHEL6.0-20090904.5
anaconda 12.15
Comment 21 Martin Banas 2009-09-09 10:09:46 EDT
Created attachment 360220 [details]
yaboot.conf from PPC machine with RHEL6.0-20090904.5
Comment 22 Martin Banas 2009-09-16 03:11:45 EDT
Still occurs in RHEL6.0-20090915.0 with anaconda 12.24. initrd entry is not in /boot/etc/yaboot.conf
Comment 23 Eric Smith 2009-09-17 00:22:39 EDT
I had the same problem (missing "initrd" line in grub.conf) on a fresh network install of F12 Alpha x86_64 on real hardware.  Manually adding the appropriate initrd line to /boot/grub/grub.conf fixed it.
Comment 24 Eric Smith 2009-09-17 00:23:57 EDT
Removing VirtualBox from title, same thing happens on real hardware or on other virtual machines.
Comment 25 Richard W.M. Jones 2009-09-17 08:53:33 EDT
Same again here.

I did an install just now (in a VM) of
http://www.mirrorservice.org/sites/download.fedora.redhat.com/pub/fedora/linux/releases/test/12-Alpha/Fedora/x86_64/iso/Fedora-12-Alpha-x86_64-netinst.iso
and grub.conf doesn't have an initrd line:

# guestfish -i /dev/vg_trick/F12Alphax64 

Welcome to guestfish, the libguestfs filesystem interactive shell for
editing virtual machine filesystems.

Type: 'help' for help with commands
      'quit' to quit the shell

><fs> cat /boot/grub/grub.conf 
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/mapper/vg_f12alphax64-lv_root
#          initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=0
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.31-14.fc12.x86_64)
	root (hd0,0)
	kernel /vmlinuz-2.6.31-14.fc12.x86_64 ro root=/dev/mapper/vg_f12alphax64-lv_root rhgb quiet LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us

><fs> tail /boot/grub/grub.conf 
#          kernel /vmlinuz-version ro root=/dev/mapper/vg_f12alphax64-lv_root
#          initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=0
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.31-14.fc12.x86_64)
	root (hd0,0)
	kernel /vmlinuz-2.6.31-14.fc12.x86_64 ro root=/dev/mapper/vg_f12alphax64-lv_root rhgb quiet LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us

Luckily guestfish makes it very easy to edit that file!  Change
'cat' command above to 'edit' or 'vi' to edit grub.conf.

Adding the initrd line fixed the boot problem for me.
Comment 26 Hans de Goede 2009-09-21 07:07:43 EDT
Niels Haase,

Judging from your attachment made in comment #1, you are using an F-12 *alpha* netinst.iso, but you did not point the installer to an F-12 *alpha* repository, but instead to a rawhide repository (the alpha has kernel-2.6.31-0.125.rc5.git2.fc12, where as you have 2.6.31-0.174.rc7.git2.fc12.x86_64)

William Washco,

Exactly the same for you (based on your grub.conf included in your comments)

Mat Booth,

The same for you too (as you said yuorself, your installed system has kernel-PAE-2.6.31-0.174.rc7.git2.fc12.i686)

Pedora Silva,

The same for you, you have 2.6.30-0.180.rc7.git4.fc12.i686.PAE which is
not the kernel from the Alpha

mgl,

The same for you, the alpha does not have an rc9 kernel like you have

Gene Czarcinski,

As you indicate yourself, this only happens when using rawhide as updates source during the install.

Richard W.M. Jones,

The same for you (kernel 2.6.31-14.fc12.x86_64 is not the kernel from the Alpha



All:

Using an installer image with another version of the packages tree then from
which that installer image is build is not supported, nor is enabling an updates repository during install. This is not supported for regular releases, and esp. not for rawhide.

What is happening here, is that by an F12-alpha netinst.iso with a rawhide tree, you get no initrd line in grub.conf because f12-alpha had a regular mkinitrd, where as rawhide has dracut, and mixing the 2 as described above will result in no initrd line in grub.conf.

This is caused by the initrd filename being different between mkinitrd and dracut (in purpose so that one can see with what sort of initrd one is dealing with). Anaconda checks that /boot/initrd-<version.img> exists and if not will not write the initrd line to grub.conf.

Anacnoda in rawhide has long been fixed to know about the new initrd name, but the old anaconda you are using with a new rawhide tree does not yet know about this change. There has been a very short window where a full rawhide installation had this issue to, this is bug 519185, which has long been fixed.

When installing from rawhide, please always use a boot.iso from the rawhide images directory!


p.s.

As for the issues with RHEL6 on ppc, that is not a Fedora bug, please file a new bug for this against the appropriate product.
Comment 27 Richard W.M. Jones 2009-09-21 08:11:56 EDT
Hmmmmmm

I would say this behaviour is unhelpful / unexpected.  At no point
during the install did I explicitly "point" anything at anything else.
I just downloaded the netinst.iso and ran with it.

It sounds like the netinst.iso should know how to get the right
packages from the right place :-)
Comment 28 Mat Booth 2009-09-21 08:46:58 EDT
(In reply to comment #27)
> Hmmmmmm
> 
> I would say this behaviour is unhelpful / unexpected.  At no point
> during the install did I explicitly "point" anything at anything else.
> I just downloaded the netinst.iso and ran with it.
> 

Same for me, I never changed the repo from the default.


> It sounds like the netinst.iso should know how to get the right
> packages from the right place :-)
Comment 29 Hans de Goede 2009-09-21 08:53:06 EDT
(In reply to comment #28)
> (In reply to comment #27)
> > Hmmmmmm
> > 
> > I would say this behaviour is unhelpful / unexpected.  At no point
> > during the install did I explicitly "point" anything at anything else.
> > I just downloaded the netinst.iso and ran with it.
> > 
> 
> Same for me, I never changed the repo from the default.
> 
> 

Hmm,

This seems like a bug in the compose process to me, Jesse (Keating) what
is your input on this ?
Comment 30 Hans de Goede 2009-09-21 08:54:41 EDT
Adding Jesse Keating to the CC, Jesse see comment #29
Comment 31 William Washco 2009-09-21 12:23:35 EDT
(In reply to comment #26)
As far as I have seen from experience (I have installed numerous Alpha, Beta, and Pre-release versions of Fedora), until the next version is ACTUALLY released, there is no repository for them. They work off of the rawhide repository. If this is not the case, please tell me how to access this mysterious "F-12 *alpha* repository."
Comment 32 Jesse Keating 2009-09-21 12:35:00 EDT
There was a tree for Alpha, http://download.fedoraproject.org/pub/fedora/linux/releases/test/12-Alpha/Fedora/<arch>/os

This would be the repo to use with the alpha boot image.
Comment 33 Niels Haase 2009-09-22 19:32:25 EDT
(In reply to comment #26)
Hans, 

first, many thanks for your very detailed replay.
But I wonder a little bit about this

> 
> All:
> 
> Using an installer image with another version of the packages tree then from
> which that installer image is build is not supported, nor is enabling an
> updates repository during install. This is not supported for regular releases,
> and esp. not for rawhide.
> 

This is from the official F11 installation guide [1]:

[...] You can define additional repositories to increase the software available to your system _during_ _installation_ [...]

The Fedora 11 - i386 - Updates repository contains the complete collection of software that was released as Fedora 11, with the various pieces of software in their most current stable versions. This option not only installs the software that you select, but makes sure that it is fully updated as well. Note that the computer must have access to the internet to use this option.


[1] http://docs.fedoraproject.org/install-guide/f11/en-US/html/s1-pkgselection-x86.html#sn-additional-repos

I can't find anything about "not supported" since this chapter explains the repository who are displayed and also available for activation during the install.

To summary my confusion, every Fedora installation so far, I activate the updates repo because it's selectable during install without any warnings.

To be honest, if this is not support why is it so easy to use it?

Hope you can bring light into the darkness.
Thank you (again) for your time!


-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 34 Hans de Goede 2009-09-29 09:01:58 EDT
*** Bug 522965 has been marked as a duplicate of this bug. ***
Comment 35 Hans de Goede 2009-10-06 09:05:16 EDT
*** Bug 523792 has been marked as a duplicate of this bug. ***
Comment 36 Mark McLoughlin 2009-10-06 09:20:51 EDT
Hmm, I don't think this should be closed

I'm removing from F12Beta since it's unlikely to cause major problems for the beta. Adding to F12Blocker because it sounds like something we should make a call on before releasing.

(In reply to comment #26)
> Using an installer image with another version of the packages tree then from
> which that installer image is build is not supported, nor is enabling an
> updates repository during install. This is not supported for regular releases,
> and esp. not for rawhide.

Why do we offer the ability in the UI to enable the rawhide and updates repos if it's not supported?
Comment 37 Hans de Goede 2009-10-07 03:25:21 EDT
Re-assigning this back to anaconda-team, as the repo-editing stuff is not
my area of expertise (actually I've never touched it).
Comment 38 Chris Lumens 2009-10-07 11:34:52 EDT

*** This bug has been marked as a duplicate of bug 516366 ***
Comment 39 Eric Smith 2009-10-07 13:54:38 EDT
I disagree that this is a dup of bug 516366.  I experienced this failure by doing a net install *without* enabling the updates repo.