Bug 522137

Summary: Test_Day:2009-09-09_Radeon: Multiple tests crash X.org
Product: [Fedora] Fedora Reporter: Martin Decky <martin>
Component: xorg-x11-drv-atiAssignee: Dave Airlie <airlied>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: rawhideCC: awilliam, chemobejk, cra, david.dubrovic, linux, pfpschneider, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-10-21 18:51:58 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 473303    
Attachments:
Description Flags
dmesg output for QA:Testcase_radeon_rotate
none
X.org log for QA:Testcase_radeon_rotate
none
dmesg output for QA:Testcase_radeon_fastuserswitch
none
X.org log (1st instance) for QA:Testcase_radeon_fastuserswitch
none
X.org log (2nd instance) for QA:Testcase_radeon_fastuserswitch
none
dmesg output for QA:Testcase_radeon_multihead
none
X.org log for QA:Testcase_radeon_multihead none

Description Martin Decky 2009-09-09 10:59:29 EDT
Description of problem:
Running the following tests of the Test_Day:2009-09-09_Radeon suite crash X.org:
QA:Testcase_radeon_rotate
QA:Testcase_radeon_fastuserswitch
QA:Testcase_radeon_vt
QA:Testcase_radeon_multihead

Rotate and multihead tests caused a crash when I wanted to change some options of the primary or secondary display (change resolution, change rotation). The fastuserswitch and vt tests caused a crash on random occasions (sometimes switching to the other VT or X.org instance worked, sometimes it crashed).

Version-Release number of selected component (if applicable):
Test Day:2009-09-09 Radeon LiveCD for i686

How reproducible:
For rotate and multihead: Always when performing a change of the display configuration.
For fastuserswitch and vt: The first operation is usually OK, after repeating the operation a crash usually occurs.

Additional info:
VGA compatible controller: ATI Technologies Inc Radeon Mobility X1400
[1002:7145]
Lenovo ThinkPad T60
dual-screen configuration (internal LVDS and external LCD connected via DVI in
a docking station)

In Fedora 11 with xorg-x11-drv-ati-6.12.2-16.fc11.i586 running all these tests goes OK.
Comment 1 Martin Decky 2009-09-09 11:00:28 EDT
Created attachment 360246 [details]
dmesg output for QA:Testcase_radeon_rotate
Comment 2 Martin Decky 2009-09-09 11:00:49 EDT
Created attachment 360247 [details]
X.org log for QA:Testcase_radeon_rotate
Comment 3 Martin Decky 2009-09-09 11:01:25 EDT
Created attachment 360248 [details]
dmesg output for QA:Testcase_radeon_fastuserswitch
Comment 4 Martin Decky 2009-09-09 11:01:47 EDT
Created attachment 360249 [details]
X.org log (1st instance) for QA:Testcase_radeon_fastuserswitch
Comment 5 Martin Decky 2009-09-09 11:02:09 EDT
Created attachment 360250 [details]
X.org log (2nd instance) for QA:Testcase_radeon_fastuserswitch
Comment 6 Martin Decky 2009-09-09 11:02:37 EDT
Created attachment 360251 [details]
dmesg output for QA:Testcase_radeon_multihead
Comment 7 Martin Decky 2009-09-09 11:02:54 EDT
Created attachment 360252 [details]
X.org log for QA:Testcase_radeon_multihead
Comment 8 Peter F. Patel-Schneider 2009-09-09 12:53:29 EDT
Also seen on a T60p with ATI Technologies Inc M56GL [Mobility FireGL V5200]
Comment 9 Martin Decky 2009-09-09 16:42:28 EDT
Also seen on ATI Technologies Inc RV280 [Radeon 9200 PRO] (rev 01) [1002:5960]
Comment 10 Adam Williamson 2009-09-16 14:11:58 EDT
when you say 'also seen', you mean all the same symptoms in all the same cases? also, does Xorg.0.log show the same segfault at the end? same question to both Peter and Martin, thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Adam Williamson 2009-09-16 14:20:03 EDT
*** Bug 522181 has been marked as a duplicate of this bug. ***
Comment 12 Peter F. Patel-Schneider 2009-09-16 14:59:36 EDT
For me, just the rotate and multihead crashes were seen.
Comment 13 Adam Williamson 2009-09-16 15:04:54 EDT
*** Bug 522286 has been marked as a duplicate of this bug. ***
Comment 14 Adam Williamson 2009-09-16 15:30:08 EDT
peter: do you see the same segfault in the X log?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Peter F. Patel-Schneider 2009-09-16 16:11:04 EDT
I can't tell, as I was working from a CD.  Putting everything back together would take some doing.
Comment 16 Adam Williamson 2009-09-16 20:54:33 EDT
*** Bug 522779 has been marked as a duplicate of this bug. ***
Comment 17 Adam Williamson 2009-09-17 15:25:54 EDT
OK. Well, it probably was the same thing. At least, quite a few people seem to be seeing this problem (see all the dupes).

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 18 Charles R. Anderson 2009-09-27 16:10:37 EDT
Confirmed same segfault when attempting to turn DVI monitor off or enable clone mode on Radeon 9800 Pro.  I can't get the DVI port on this card to work at all, not even during bootup/BIOS, but I'm not sure if the hardware is bad.  Xorg configures side-by-side mode automatically, which makes it difficult to use when the DVI output stays blank.

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R350 [Radeon 9800 Pro]
01:00.1 Display Controller: ATI Technologies Inc Radeon R350 [Radeon 9800 Pro] (Secondary)
Comment 19 Martin Decky 2009-10-03 08:56:50 EDT
(In reply to comment #10)

Yes, there were the same symptoms and the same segfaults in all the cases (this was the reason why I grouped them in a single bug report).
Comment 21 Martin Decky 2009-10-05 18:52:02 EDT
After retesting with desktop-i386-20091002.15.iso snapshot everything seems to work fine again on RV280. I'll retest X1400 tomorrow.
Comment 22 Martin Decky 2009-10-05 19:26:53 EDT
(In reply to comment #21)

I am sorry for a hasty comment, actually only changing the mode works flawlessly. Rotating the screen, restarting the X server and switching VTs crashes X.org occasionally even with the updated snapshot. One of the stack traces from X.org log:

0: /usr/bin/Xorg (xorg_backtrace+0x3c) [0x80e561c]
1: /usr/bin/Xorg (0x8048000+0x5eb26) [0x80a6b26]
2: (vdso) (__kernel_rt_sigreturn+0x0) [0x71940c]
3: /usr/lib/xorg/modules/drivers/radeon_drv.so (0xd4d000+0xa2301) [0xdef301]
4: /usr/lib/xorg/modules/drivers/radeon_drv.so (0xd4d000+0xd040b) [0xe1d40b]
5: /usr/lib/xorg/modules/drivers/radeon_drv.so (0xd4d000+0xd050b) [0xe1d50b]
6: /usr/lib/xorg/modules/drivers/radeon_drv.so (0xd4d000+0xcc499) [0xe19499]
7: /usr/bin/Xorg (0x8048000+0x1333b2) [0x817b3b2]
8: /usr/bin/Xorg (0x8048000+0x88fb3) [0x80d0fb3]
9: /usr/lib/xorg/modules/extensions/libglx.so (0x2d3000+0x424b5) [0x3154b5]
10: /usr/bin/Xorg (xf86Wakeup+0x513) [0x80b2923]
11: /usr/bin/Xorg (WakeupHandler+0x52) [0x8073792]
12: /usr/bin/Xorg (WaitForSomething+0x1a2) [0x80a0e72]
13: /usr/bin/Xorg (0x8048000+0x25ea0) [0x806dea0]
14: /usr/bin/Xorg (0x8048000+0x1a855) [0x8062855]
15: /lib/libc.so.6 (__libc_start_main+0xe6) [0x889b36]
16: /usr/bin/Xorg (0x8048000+0x1a441) [0x8062441]
Segmentation fault at address (nil)
Comment 23 Martin Decky 2009-10-21 08:39:09 EDT
OK, this time for real:

Everything seems to work fine (no segfaults related to this bug) with xorg-x11-drv-ati-6.13.0-0.10.20091006git457646d73.fc12 and kernel-PAE-2.6.31.4-88.fc12 on Radeon Mobility X1400 [1002:7145].
Comment 24 Adam Williamson 2009-10-21 18:51:58 EDT
excellent!

closing this. If I closed your report as a duplicate of this bug, please check that it works for you with the versions mentioned by Martin above, if not, re-open your 'duplicate' bug. thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers