Bug 522508

Summary: Macintosh G5 ppc64 system - kernel BUG at drivers/rtc/rtc-ps3.c:36!
Product: [Fedora] Fedora Reporter: Brad Lucier <lucier>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: carsten, itamar, jreiser, kernel-maint
Target Milestone: ---   
Target Release: ---   
Hardware: ppc64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 516218 Environment:
Last Closed: 2009-09-30 02:16:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Brad Lucier 2009-09-10 14:58:25 UTC
+++ This bug was initially created as a clone of Bug #516218 +++

The original bug (and all the bugs marked as duplicates) was reported against Fedora 12 Rawhide, but it also happens with Fedora 11 after install of

Sep  8 15:39:43 localhost yum: Updated: kernel-firmware-2.6.30.5-43.fc11.noarch
Sep  8 15:40:25 localhost yum: Installed: kernel-2.6.30.5-43.fc11.ppc64
Sep  8 15:41:09 localhost yum: Installed: kernel-devel-2.6.30.5-43.fc11.ppc64
Sep  8 15:41:11 localhost yum: Updated: kernel-bootwrapper-2.6.30.5-43.fc11.ppc
Sep  8 15:41:17 localhost yum: Updated: kernel-headers-2.6.30.5-43.fc11.ppc

on a Power Mac G5.

As reported in /var/log/messages, the oops is:

Sep 10 00:49:13 localhost kernel: ------------[ cut here ]------------
Sep 10 00:49:13 localhost kernel: kernel BUG at drivers/rtc/rtc-ps3.c:36!
Sep 10 00:49:13 localhost kernel: Oops: Exception in kernel mode, sig: 5 [#1]
Sep 10 00:49:13 localhost kernel: SMP NR_CPUS=128 NUMA PowerMac
Sep 10 00:49:13 localhost kernel: Modules linked in: shpchp ata_generic sata_svw [last unloaded: scsi_wait_scan]
Sep 10 00:49:13 localhost kernel: NIP: c00000000054c420 LR: c00000000054c418 CTR: c00000000054c3e4
Sep 10 00:49:13 localhost kernel: REGS: c000000273313570 TRAP: 0700   Not tainted  (2.6.30.5-43.fc11.ppc64)
Sep 10 00:49:13 localhost kernel: MSR: 9000000000029032 <EE,ME,CE,IR,DR>  CR: 34222424  XER: 200fffff
Sep 10 00:49:13 localhost kernel: TASK = c000000274bd9ad0[202] 'hwclock' THREAD: c000000273310000 CPU: 0
Sep 10 00:49:13 localhost kernel: GPR00: c00000000054c418 c0000002733137f0 c000000000f8fed8 0000000000000026 
Sep 10 00:49:13 localhost kernel: GPR04: c00000000054c418 0000000034222424 0000000000000000 c000000000085394 
Sep 10 00:49:13 localhost kernel: GPR08: 9000000000009032 0000000000008010 9000000000001032 c000000273313868 
Sep 10 00:49:13 localhost kernel: GPR12: 0000000000000002 c000000000fd7380 00000000100193d8 0000000010006bd0 
Sep 10 00:49:13 localhost kernel: GPR16: 0000000000000000 00000000ffe1145b 00000000ffe1125c 0000000010020000 
Sep 10 00:49:13 localhost kernel: GPR20: 0000000000000001 0000000000000000 00000000ffe11218 000000000002cbec 
Sep 10 00:49:13 localhost kernel: GPR24: c000000000722e50 0000000000000000 ffffffffffffffea c0000002733139b0 
Sep 10 00:49:13 localhost kernel: GPR28: c000000273457400 c0000002733139b0 c000000000f35488 c0000002733137f0 
Sep 10 00:49:13 localhost kernel: NIP [c00000000054c420] .ps3_get_time+0x3c/0x84
Sep 10 00:49:13 localhost kernel: LR [c00000000054c418] .ps3_get_time+0x34/0x84
Sep 10 00:49:13 localhost kernel: Call Trace:
Sep 10 00:49:13 localhost kernel: [c0000002733137f0] [c00000000054c418] .ps3_get_time+0x34/0x84 (unreliable)
Sep 10 00:49:13 localhost kernel: [c000000273313890] [c000000000545b34] .rtc_read_time+0xa8/0xe4
Sep 10 00:49:13 localhost kernel: [c000000273313930] [c000000000546744] .rtc_dev_ioctl+0x358/0x5a8
Sep 10 00:49:13 localhost kernel: [c000000273313a40] [c0000000001b6630] .vfs_ioctl+0x70/0x10c
Sep 10 00:49:13 localhost kernel: [c000000273313af0] [c0000000001b6d74] .do_vfs_ioctl+0x6a8/0x720
Sep 10 00:49:13 localhost kernel: [c000000273313be0] [c0000000001b6e74] .SyS_ioctl+0x88/0xd0
Sep 10 00:49:13 localhost kernel: [c000000273313ca0] [c0000000001f6614] .do_ioctl32_pointer+0x3c/0x5c
Sep 10 00:49:13 localhost kernel: [c000000273313d40] [c0000000001fb6f0] .compat_sys_ioctl+0x400/0x488
Sep 10 00:49:13 localhost kernel: [c000000273313e30] [c0000000000085f0] syscall_exit+0x0/0x40
Sep 10 00:49:13 localhost kernel: Instruction dump:
Sep 10 00:49:13 localhost kernel: fba1ffe8 fbe1fff8 f821ff61 7c3f0b78 7c9d2378 60000000 60000000 387f0070 
Sep 10 00:49:13 localhost kernel: 389f0078 4bb38f69 60000000 7c6307b4 <0b030000> eb9f0070 4bb3d931 60000000 
Sep 10 00:49:13 localhost kernel: ---[ end trace 710b37ba5cdb3229 ]---

So it may be OK for Rawhide to wait for the upstream fix to appear in the 2.6.31 kernel, but it seems it should be fixed for 2.6.30 kernel in Fedora 11, too.

ORIGINAL DESCRIPTION:

Description of problem:

Install F-12-Alpha on IBM power5 ppc64 system and it fails to boot with kernel trace.

Version-Release number of selected component (if applicable):
 * 2.6.31-0.125.rc5.git2.fc12.ppc64 


How reproducible:


Steps to Reproduce:
1. Install F-12-Alpha on IBM ppc64 system
  
Actual results:

Elapsed time since release of system processors: 4287 mins 0 secs

Config file read, 1024 bytes

Welcome to Fedora!
Hit <TAB> for boot options
Welcome to yaboot version 1.3.14 (Red Hat 1.3.14-14.fc12)
Enter "help" to get some basic usage information
boot: linux
Please wait, loading kernel...
   Elf64 kernel loaded...
Loading ramdisk...
ramdisk loaded at 03900000, size: 3791 Kbytes
OF stdout device is: /vdevice/vty@30000000
Preparing to boot Linux version 2.6.31-0.125.rc5.git2.fc12.ppc64 (mockbuild@ppc4.fedora.phx.redhat.com) (gcc version 4.4.1 20090725 (Red Hat 4.4.1-3) (GCC) ) #1 SMP Tue Aug 4 03:04:27 EDT 2009
Calling ibm,client-architecture...command line: root=/dev/mapper/vg_ibm505lp1-lv_root ro console=hvc0 rhgb quiet 
memory layout at init:
  alloc_bottom : 0000000003cb4000
  alloc_top    : 0000000008000000
  alloc_top_hi : 00000000f5000000
  rmo_top      : 0000000008000000
  ram_top      : 00000000f5000000
instantiating rtas at 0x00000000076a1000... done
boot cpu hw idx 0000000000000000
starting cpu hw idx 0000000000000002... done
starting cpu hw idx 0000000000000004... done
starting cpu hw idx 0000000000000006... done
copying OF device tree...
Building dt strings...
Building dt structure...
Device tree strings 0x0000000003db5000 -> 0x0000000003db634d
Device tree struct  0x0000000003db7000 -> 0x0000000003dca000
Calling quiesce...
returning from prom_init
Phyp-dump not supported on this hardware
		Welcome to Fedora 
		Press 'I' to enter interactive startup.
Starting udev: ------------[ cut here ]------------
kernel BUG at drivers/rtc/rtc-ps3.c:36!
Oops: Exception in kernel mode, sig: 5 [#1]
SMP NR_CPUS=128 NUMA pSeries
Modules linked in: ipr [last unloaded: scsi_wait_scan]
NIP: c00000000059e460 LR: c00000000059e458 CTR: c00000000059e424
REGS: c0000000edcc3570 TRAP: 0700   Not tainted  (2.6.31-0.125.rc5.git2.fc12.ppc64)
MSR: 8000000000029032 <EE,ME,CE,IR,DR>  CR: 44222424  XER: 00000000
TASK = c0000000edcb8000[233] 'hwclock' THREAD: c0000000edcc0000 CPU: 0
GPR00: c00000000059e458 c0000000edcc37f0 c00000000127e930 fffffffffffffffe 
GPR04: c0000000edcc3868 0000000000000004 c0000000edcc39d4 0000000000000000 
GPR08: 08b8000000000000 c000000001267318 c0000000ec5964e8 c0000000edcc3868 
GPR12: 0000000000004000 c0000000012d8300 0000000010019d40 00000000ffaccdbb 
GPR16: 0000000000000000 00000000ffaccc90 0000000000000000 0000000010020000 
GPR20: 0000000000000000 000000000009ecc4 000000004a7c35bc 0000000000000001 
GPR24: 0000000040247009 c000000000787358 ffffffffffffffea c0000000edcc39b0 
GPR28: c0000000ec596278 c0000000edcc39b0 c00000000121c870 c0000000edcc37f0 
NIP [c00000000059e460] .ps3_get_time+0x3c/0x84
LR [c00000000059e458] .ps3_get_time+0x34/0x84
Call Trace:
[c0000000edcc37f0] [c00000000059e458] .ps3_get_time+0x34/0x84 (unreliable)
[c0000000edcc3890] [c000000000597d58] .rtc_read_time+0xac/0xe8
[c0000000edcc3930] [c000000000598948] .rtc_dev_ioctl+0x358/0x5a4
[c0000000edcc3a40] [c0000000001e3c60] .vfs_ioctl+0x70/0x10c
[c0000000edcc3af0] [c0000000001e4498] .do_vfs_ioctl+0x6d8/0x748
[c0000000edcc3be0] [c0000000001e4590] .SyS_ioctl+0x88/0xd0
[c0000000edcc3ca0] [c0000000002262fc] .do_ioctl32_pointer+0x3c/0x5c
[c0000000edcc3d40] [c00000000022b224] .compat_sys_ioctl+0x43c/0x4c4
[c0000000edcc3e30] [c0000000000085f0] syscall_exit+0x0/0x40
Instruction dump:
fba1ffe8 fbe1fff8 f821ff61 7c3f0b78 7c9d2378 60000000 60000000 387f0070 
389f0078 4baece3d 60000000 7c6307b4 <0b030000> eb9f0070 4baf1805 60000000 
---[ end trace ed3854884192069a ]---


Expected results:

 * No call trace

Additional info:

 * System: ibm-505-lp1.test.redhat.com

--- Additional comment from harald@redhat.com on 2009-08-11 07:07:49 EDT ---

*** Bug 516219 has been marked as a duplicate of this bug. ***

--- Additional comment from cebbert@redhat.com on 2009-08-25 16:45:14 EDT ---

*** Bug 519240 has been marked as a duplicate of this bug. ***

--- Additional comment from cebbert@redhat.com on 2009-08-25 16:48:16 EDT ---

Fix is here:
http://www.mail-archive.com/linuxppc-dev@lists.ozlabs.org/msg36409.html

Hopefully this will make 2.6.31-final...

--- Additional comment from cebbert@redhat.com on 2009-08-27 14:17:37 EDT ---

Fix is merged upstream.

Comment 1 Carsten Jacobi 2009-09-13 13:21:01 UTC
Why is priority low and severity medium on this ticket?!? G5 is currently broken without this fix!!!
I have just applied the patch from ozlabs and my G5 is bootable again all of a sudden! Please include this fix in one of the next kernel RPMs ASAP!! This should be high priority and severity.

Comment 2 John Reiser 2009-09-15 18:32:39 UTC
Fedora 12 has decided to expend no more effort on 64-bit PowerPC (although major pieces still do[will] work), and in the next release Fedora 13 even 32-bit PowerPC no longer will be a primary architecture.  There just aren't enough Fedora users on such boxes.  [S390 and its variants are treated distinct from PowerPC, and of course Red Hat and it products are distinct from Fedora Project.]

Comment 3 Brad Lucier 2009-09-15 19:37:39 UTC
Re:

Fedora 12 has decided to expend no more effort on 64-bit PowerPC

Be that as it may, this bug was introduced to Fedora 11 within the past two weeks with

Sep  8 15:40:25 localhost yum: Installed: kernel-2.6.30.5-43.fc11.ppc64

and it's a three line fix (including a blank line), so if Fedora 11 is not abandoning 64-bit PowerPC I think the fix should be applied and pushed out.

Comment 4 Chuck Ebbert 2009-09-25 04:09:54 UTC
This was fixed upstream in 2.6.30.6

Comment 5 Brad Lucier 2009-09-30 02:16:23 UTC
Fixed with kernel-2.6.30.8-64.fc11.ppc64.

Thanks!