Bug 523635

Summary: WARNING: at kernel/trace/ftrace.c:1003 ftrace_bug+0x198/0x27e()
Product: [Fedora] Fedora Reporter: Zdenek Kabelac <zkabelac>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: georg.wild, itamar, johannbg, kernel-maint, orion, selinux, tpelka, yaneti
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 525070 (view as bug list) Environment:
Last Closed: 2009-09-27 11:04:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 525070    

Description Zdenek Kabelac 2009-09-16 09:21:54 UTC
Description of problem:

kernel warnings during boot:

WARNING: at kernel/trace/ftrace.c:1003 ftrace_bug+0x198/0x27e() (Not tainted)
Hardware name: 6464CTO
Modules linked in: output(+)
Pid: 106, comm: modprobe Not tainted 2.6.31-12.fc12.x86_64 #1
Call Trace:
[<ffffffff81064244>] warn_slowpath_common+0x95/0xc3
[<ffffffffa0000193>] ? video_output_register+0x11/0x10a [output]
[<ffffffff81064299>] warn_slowpath_null+0x27/0x3d
[<ffffffff810d4a0e>] ftrace_bug+0x198/0x27e
[<ffffffffa0000193>] ? video_output_register+0x11/0x10a [output]
[<ffffffff810d5c66>] ftrace_convert_nops+0x201/0x2b9
[<ffffffffa0000193>] ? video_output_register+0x11/0x10a [output]
[<ffffffff810d5d6a>] ftrace_module_notify+0x4c/0x7f
[<ffffffff815099a5>] notifier_call_chain+0x72/0xba
[<ffffffff81086db1>] ? __blocking_notifier_call_chain+0x4c/0x8e
[<ffffffff81086dc8>] __blocking_notifier_call_chain+0x63/0x8e
[<ffffffff81086e1a>] blocking_notifier_call_chain+0x27/0x3d
[<ffffffff810a466a>] sys_init_module+0xb7/0x249
[<ffffffff81011f42>] system_call_fastpath+0x16/0x1b

ftrace faulted on writing [<ffffffffa0000193>] video_output_register+0x11/0x10a [output]

Version-Release number of selected component (if applicable):
kernel-2.6.31-12.fc12.x86_64
x86_64, Lenovo T61, 4GB, C2D, up-to-date fedora rawhide 2009-09-16

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tom London 2009-09-21 13:38:20 UTC
I'm seeing this too on Lenove X200 with -12.fc2.x86_64:

usb 4-1: configuration #1 chosen from 1 choice
udev: starting version 145
usb 1-5.2: new full speed USB device using ehci_hcd and address 4
------------[ cut here ]------------
WARNING: at kernel/trace/ftrace.c:1003 ftrace_bug+0x198/0x27e() (Not tainted)
Hardware name: 74585FU
Modules linked in: output(+)
Pid: 112, comm: modprobe Not tainted 2.6.31-33.fc12.x86_64 #1
Call Trace:
 [<ffffffff810642ec>] warn_slowpath_common+0x95/0xc3
 [<ffffffffa0000193>] ? video_output_register+0x11/0x10a [output]
 [<ffffffff81064341>] warn_slowpath_null+0x27/0x3d
 [<ffffffff810d4ace>] ftrace_bug+0x198/0x27e
 [<ffffffffa0000193>] ? video_output_register+0x11/0x10a [output]
 [<ffffffff810d5d26>] ftrace_convert_nops+0x201/0x2b9
 [<ffffffffa0000193>] ? video_output_register+0x11/0x10a [output]
 [<ffffffff810d5e2a>] ftrace_module_notify+0x4c/0x7f
 [<ffffffff81509c65>] notifier_call_chain+0x72/0xba
 [<ffffffff81086e71>] ? __blocking_notifier_call_chain+0x4c/0x8e
 [<ffffffff81086e88>] __blocking_notifier_call_chain+0x63/0x8e
 [<ffffffff81086eda>] blocking_notifier_call_chain+0x27/0x3d
 [<ffffffff810a472a>] sys_init_module+0xb7/0x249
 [<ffffffff81011f42>] system_call_fastpath+0x16/0x1b
---[ end trace e7e7dc056f6936b1 ]---
ftrace faulted on writing [<ffffffffa0000193>] video_output_register+0x11/0x10a [output]
[drm] Initialized drm 1.1.0 20060810
usb 1-5.2: New USB device found, idVendor=067b, idProduct=2305
usb 1-5.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-5.2: Product: IEEE-1284 Controller

Comment 2 Yanko Kaneti 2009-09-21 14:29:32 UTC
Now that I've noticed mine isn't in video_output_register, but in i2c_new_dummy

WARNING: at kernel/trace/ftrace.c:1003 ftrace_bug+0x198/0x27e() (Not tainted)
Hardware name: GA-MA78GM-S2H
Modules linked in: i2c_core(+)
Pid: 130, comm: modprobe Not tainted 2.6.31-33.fc12.x86_64 #1
Call Trace:
 [<ffffffff810642ec>] warn_slowpath_common+0x95/0xc3
 [<ffffffffa0003072>] ? i2c_new_dummy+0x8/0x5e [i2c_core]
 [<ffffffff81064341>] warn_slowpath_null+0x27/0x3d
 [<ffffffff810d4ace>] ftrace_bug+0x198/0x27e
 [<ffffffffa0003072>] ? i2c_new_dummy+0x8/0x5e [i2c_core]
 [<ffffffff810d5d26>] ftrace_convert_nops+0x201/0x2b9
 [<ffffffffa0003072>] ? i2c_new_dummy+0x8/0x5e [i2c_core]
 [<ffffffff810d5e2a>] ftrace_module_notify+0x4c/0x7f
 [<ffffffff81509c65>] notifier_call_chain+0x72/0xba
 [<ffffffff81086e71>] ? __blocking_notifier_call_chain+0x4c/0x8e
 [<ffffffff81086e88>] __blocking_notifier_call_chain+0x63/0x8e
 [<ffffffff81086eda>] blocking_notifier_call_chain+0x27/0x3d
 [<ffffffff810a472a>] sys_init_module+0xb7/0x249
 [<ffffffff81011f42>] system_call_fastpath+0x16/0x1b
---[ end trace 62bfd67a45008312 ]---
ftrace faulted on writing [<ffffffffa0003072>] i2c_new_dummy+0x8/0x5e [i2c_core]

Comment 3 Orion Poplawski 2009-09-22 16:33:03 UTC
Another:

Dell Inspiron 6400
 
WARNING: at kernel/trace/ftrace.c:1003 ftrace_bug+0x198/0x27e() (Not tainted)
Hardware name: MM061
Modules linked in: output(+)
Pid: 94, comm: modprobe Not tainted 2.6.31-33.fc12.x86_64 #1
Call Trace:
 [<ffffffff810642ec>] warn_slowpath_common+0x95/0xc3
 [<ffffffffa0000193>] ? video_output_register+0x11/0x10a [output]
 [<ffffffff81064341>] warn_slowpath_null+0x27/0x3d
 [<ffffffff810d4ace>] ftrace_bug+0x198/0x27e
 [<ffffffffa0000193>] ? video_output_register+0x11/0x10a [output]
 [<ffffffff810d5d26>] ftrace_convert_nops+0x201/0x2b9
 [<ffffffffa0000193>] ? video_output_register+0x11/0x10a [output]
 [<ffffffff810d5e2a>] ftrace_module_notify+0x4c/0x7f
 [<ffffffff81509c65>] notifier_call_chain+0x72/0xba
 [<ffffffff81086e71>] ? __blocking_notifier_call_chain+0x4c/0x8e
 [<ffffffff81086e88>] __blocking_notifier_call_chain+0x63/0x8e
 [<ffffffff81086eda>] blocking_notifier_call_chain+0x27/0x3d
 [<ffffffff810a472a>] sys_init_module+0xb7/0x249
 [<ffffffff81011f42>] system_call_fastpath+0x16/0x1b
---[ end trace c78f3c300c17b940 ]---
ftrace faulted on writing [<ffffffffa0000193>] video_output_register+0x11/0x10a [output]

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

Comment 4 Orion Poplawski 2009-09-22 16:33:57 UTC
*** Bug 524890 has been marked as a duplicate of this bug. ***

Comment 5 Chuck Ebbert 2009-09-24 14:34:10 UTC
*** Bug 525466 has been marked as a duplicate of this bug. ***

Comment 6 Georg Wild 2009-09-27 09:01:01 UTC
This seems fixed with the upgrade to kernel
Linux version 2.6.31.1-48.fc12.x86_64 (mockbuild@x86-6.fedora.phx.redhat.com) (gcc version 4.4.1 20090923 (Red Hat 4.4.1-16) (GCC) ) #1 SMP Fri Sep 25 16:57:40 EDT 2009

Comment 7 Chuck Ebbert 2009-09-27 11:04:18 UTC
*** Bug 524042 has been marked as a duplicate of this bug. ***