This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 548520

Summary: NetworkManager pppd plugin does not work with latest pppd
Product: [Fedora] Fedora Reporter: Andreas Bierfert <andreas.bierfert>
Component: NetworkManagerAssignee: Dan Williams <dcbw>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: bookreviewer, conradsand.fb, dcbw, fabio.canepa, fschwarz, honza, johannbg, jvsmith, maurizio.antillon, rebelinux, rproffit, vengmd, xjakub
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: NetworkManager-0.7.998-2.git20100106.fc12 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-02-26 22:39:38 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Andreas Bierfert 2009-12-17 12:17:31 EST
pppd has been updated to version 2.4.5 in F12 effectively breaking network connectivity for connections which use the pppd plugin of nm.

ppp-2.4.5-2.fc12.x86_64
NetworkManager-0.7.997-2.git20091214.fc12.x86_64

Error Message:
Dec 17 18:01:26 spica pppd[2560]: Plugin /usr/lib64/pppd/2.4.4/nm-pppd-plugin.so is for pppd version 2.4.4, this is 2.4.5
Dec 17 18:01:26 spica NetworkManager: <WARN>  ppp_exit_code(): ppp pid 2560 exited with error: pppd options error
Comment 1 Jonathan Colon 2009-12-18 13:12:44 EST
i already back-ported to ppp 2.4.4-13.fc12  and now NM works!!!

https://bugzilla.redhat.com/show_bug.cgi?id=548760
Comment 2 Andreas Bierfert 2009-12-31 09:52:06 EST
F12 updates-testing still has ppp 2.4.5 and no updated/fixed NM packages
Comment 3 Dan Williams 2010-01-04 18:03:03 EST
*** Bug 548760 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2010-01-12 18:41:30 EST
NetworkManager-0.7.998-1.git20100106.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0440
Comment 5 Jóhann B. Guðmundsson 2010-01-12 19:26:16 EST
Uhum.

Dan dont you need to rebuild this for 2.4.5 instead of 2.4.4

# rpm -q NetworkManager
NetworkManager-0.7.998-1.git20100106.fc12.x86_64

# rpm -qil NetworkManager | grep ppp
/usr/lib64/pppd/2.4.4/nm-pppd-plugin.so
Comment 6 Julian Sikorski 2010-01-13 13:42:19 EST
Also, something strange is going on. When I tried to rebuild NetworkManager 1:0.7.997-2.git20091214.fc12 against ppp 2.4.5, the ppp plugin was still installed to /usr/lib64/pppd/2.4.4. It worked fine, just the installation path was weird.
Comment 7 Fedora Update System 2010-01-13 20:06:00 EST
NetworkManager-0.7.998-2.git20100106.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.998-2.git20100106.fc12
Comment 8 Jóhann B. Guðmundsson 2010-01-14 06:27:19 EST
After update-ing to NetworkManager-0.7.998-2.git20100106.fc12.x86_64.rpm and   ppp-2.4.5-2.fc12.x86_64.rpm NetworkManager is still unable to establish pptp vpn connection.. 

Jan 14 09:50:32 localhost pppd[7468]: Warning: can't open options file /root/.ppprc: Permission denied
Jan 14 09:50:32 localhost pppd[7468]: Plugin /usr/lib64/pppd/2.4.4/nm-pptp-pppd-plugin.so is for pppd version 2.4.4, this is 2.4.5
Comment 9 Julian Sikorski 2010-01-14 14:28:25 EST
Works fine for me, the path is correct as well. Jóhann, make sure you restart the NetworkManager service after the update (sudo service NetworkManager restart).
Comment 10 Jóhann B. Guðmundsson 2010-01-15 02:44:18 EST
I did shutdown and restart NetworkManager does not work for me on a x86_64 bit platform.. 

Make sure you are using the same bits as I... 

[root@localhost ~]# rpm -q NetworkManager ppp
NetworkManager-0.7.998-2.git20100106.fc12.x86_64
ppp-2.4.5-2.fc12.x86_64

[root@localhost pppd]# ls /usr/lib64/pppd/
2.4.4
2.4.5

As you can see both 2.4.4 and 2.4.5 exist under /usr/lib64/pppd/

I removed 2.4.4 from that directory results in this. ( I did stop and start NetworkManager encase you are wondering in between )  

Jan 15 06:57:31 localhost pppd[22727]: Warning: can't open options file /root/.ppprc: Permission denied
Jan 15 06:57:31 localhost pppd[22727]: /usr/lib64/pppd/2.4.4/nm-pptp-pppd-plugin.so: cannot open shared object file: No such file or directory
Jan 15 06:57:31 localhost pppd[22727]: Couldn't load plugin /usr/lib64/pppd/2.4.4/nm-pptp-pppd-plugin.so

As you can clearly see pppd is still looking into the 2.4.4 directory while it should be looking into the 2.4.5 directory.

It errors out if the directory does not exist and it errors out if the directory exist on version mismatch...
Comment 11 Jóhann B. Guðmundsson 2010-01-15 05:17:47 EST
<homer> Doh </homer>  

/usr/lib64/pppd/2.4.4/nm-pptp-pppd-plugin.so <---- 

Ofcourse we need to rebuild NetworkManager-pptp against 2.4.5...
Comment 12 Fedora Update System 2010-01-15 17:17:39 EST
NetworkManager-0.7.998-2.git20100106.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0660
Comment 13 Milos Jakubicek 2010-01-20 14:21:25 EST
Dan, you forgot to rebuild NM-pptp package, this is not going to work. If you need to request buildroot override, go ahead. If you don't have time, let me know and I will do that.
Comment 14 Dan Williams 2010-01-20 15:38:22 EST
(In reply to comment #13)
> Dan, you forgot to rebuild NM-pptp package, this is not going to work. If you
> need to request buildroot override, go ahead. If you don't have time, let me
> know and I will do that.    

This bug is assigned to NetworkManager, not to NM-pptp.  NM-pptp will require an additional update but that's not the scope of this specific bug.
Comment 15 Milos Jakubicek 2010-01-20 16:06:32 EST
What do you mean by "not in the scope of this bug"? This bug is a user report about the fact that pptp support in NM is not working. It concerns two BZ components, yes -- but your update which you have assigned to this bug does *not* solve the issue.

But anyway, my main point: is there any single reason why NM and NM-pptp shouldn't be kept in sync? Why in the hell don't you release NM and NM-pptp in a single update?

Btw, NM-pptp just needs a rebuild, nothing else...a work for 10 mins including editing the update (provided you don't need buildroot override, otherwise it is 5 mins filing a rel-eng ticket, then about ~5 hours free time and then 10 mins building and updating).
Comment 16 Dan Williams 2010-01-20 16:50:23 EST
This bug (#548520) is assigned to NetworkManager.  It is *not* assigned to NetworkManager-pptp, which is a separate component.  Both NM itself and NM-pptp have the version problem, and yes NM-pptp needs to be updated as well.

But since this bug is about NetworkManager itself, and that problem has been fixed, this bug is resolved.  The issue with NM-pptp is completely separate.

NM and NM-pptp do not generally need to be kept in sync with each other, as long as the major version (0.8) is the same since NetworkManager doesn't break backwards compatibility in a major release.  Since there is nothing in NM-pptp that explicitly or implicitly depends on this updated version of NetworkManager, there is no reason to tie the NM-pptp release to this updated version of NM.

NM-pptp doesn't need a rebuild, it needs a bit more specfile logic like I added to NM itself.

And let me remind you, this problem is only in F12-updates-testing.  It has *not* hit Fedora 12 yet, and that's the exact reason we have F12-updates-testing.  I expect that before ppp-2.4.5 hits Fedora 12 that we'll have a corresponding version of NM-pptp available.
Comment 17 Jan Bušta 2010-01-20 17:34:09 EST
(In reply to comment #16)
> This bug (#548520) is assigned to NetworkManager.  It is *not* assigned to
> NetworkManager-pptp, which is a separate component.  Both NM itself and NM-pptp
> have the version problem, and yes NM-pptp needs to be updated as well.
> 

Should I create another bug with the same content which will be assigned to NetworkManager-pptp for you?

> And let me remind you, this problem is only in F12-updates-testing.  It has
> *not* hit Fedora 12 yet, and that's the exact reason we have
> F12-updates-testing.  I expect that before ppp-2.4.5 hits Fedora 12 that we'll
> have a corresponding version of NM-pptp available.   

OK, F12-updates-testing is a place where the problems can (should) be solved, waiting for the pushing to F12-updates is bullshit. There is no real problem, I do not know WHERE it is.
Comment 18 Milos Jakubicek 2010-01-20 17:56:42 EST
(In reply to comment #16)
> NM-pptp doesn't need a rebuild, it needs a bit more specfile logic like I added
> to NM itself.

Well -- I've just rebuilt the current NetworkManager-pptp in F12 (NetworkManager-pptp-0.7.996-4.git20090921.fc12.x86_64) and it immediately works.

So, only what it currently needs to resolve the problem, *is rebuilding*.

> And let me remind you, this problem is only in F12-updates-testing.  It has
> *not* hit Fedora 12 yet, and that's the exact reason we have
> F12-updates-testing.  I expect that before ppp-2.4.5 hits Fedora 12 that we'll
> have a corresponding version of NM-pptp available.    

This is not an argument. Let me remind you, that the updates-testing repository is no place for broken packages or packages causing other packages to be broken. It is the last resort to catch the omnipresent human errors. It's not F12's rawhide. Broken or broking packages have either to be immediately fixed or unpushed. Otherwise we just cause people not using this repository and we loose valuable QA.

Please try to rebuild NM-pptp asap and release an update, it won't take much time (buildroot override might be necessary -- didn't check). *Thank you in advance*.

P. S.
If new ppp has been pushed in to the updates-testing repository without previous announcement to maintainers of dependent packages by jskala (i.e. without your knowledge) it is of course a serious mistake. Therefore we have the possibility of easy buildroot override to be able to solve such things smoothly. Otherwise ppp is asking for unpush from updates-testing...
Comment 19 Dan Williams 2010-01-20 18:10:10 EST
(In reply to comment #17)
> (In reply to comment #16)
> > This bug (#548520) is assigned to NetworkManager.  It is *not* assigned to
> > NetworkManager-pptp, which is a separate component.  Both NM itself and NM-pptp
> > have the version problem, and yes NM-pptp needs to be updated as well.
> > 
> 
> Should I create another bug with the same content which will be assigned to
> NetworkManager-pptp for you?

That would be great, if there isnt' already one.
Comment 20 Dan Williams 2010-01-20 18:12:03 EST
(In reply to comment #18)
> (In reply to comment #16)
> > NM-pptp doesn't need a rebuild, it needs a bit more specfile logic like I added
> > to NM itself.
> 
> Well -- I've just rebuilt the current NetworkManager-pptp in F12
> (NetworkManager-pptp-0.7.996-4.git20090921.fc12.x86_64) and it immediately
> works.
> 
> So, only what it currently needs to resolve the problem, *is rebuilding*.

Hardly.  If ppp updates to 2.4.6 tomorrow, then you'll be right back in the same problem.  To prevent that, we need a few fixes to the specfile as well.  It is not simply a rebuild.  I'd also like to prevent this in the future.

> If new ppp has been pushed in to the updates-testing repository without
> previous announcement to maintainers of dependent packages by jskala (i.e.
> without your knowledge) it is of course a serious mistake. Therefore we have
> the possibility of easy buildroot override to be able to solve such things
> smoothly. Otherwise ppp is asking for unpush from updates-testing...    

As far as I know, no announcement was made.  But the problem was that NM and NM-pptp was using "Requires: ppp >= 2.4.4" which allowed this to happen.  So it's not really his fault.
Comment 21 Milos Jakubicek 2010-01-20 18:32:05 EST
(In reply to comment #20)
> (In reply to comment #18)
> > (In reply to comment #16)
> > > NM-pptp doesn't need a rebuild, it needs a bit more specfile logic like I added
> > > to NM itself.
> > 
> > Well -- I've just rebuilt the current NetworkManager-pptp in F12
> > (NetworkManager-pptp-0.7.996-4.git20090921.fc12.x86_64) and it immediately
> > works.
> > 
> > So, only what it currently needs to resolve the problem, *is rebuilding*.
> 
> Hardly.  If ppp updates to 2.4.6 tomorrow, then you'll be right back in the
> same problem.  To prevent that, we need a few fixes to the specfile as well. 
> It is not simply a rebuild.  I'd also like to prevent this in the future.
"
I see your point -- but you can solve it for the users very fastly right now and then later solve it in general for the future. For the case "if ppp updates to 2.4.6 tomorrow" see below...
 
> > If new ppp has been pushed in to the updates-testing repository without
> > previous announcement to maintainers of dependent packages by jskala (i.e.
> > without your knowledge) it is of course a serious mistake. Therefore we have
> > the possibility of easy buildroot override to be able to solve such things
> > smoothly. Otherwise ppp is asking for unpush from updates-testing...    
> 
> As far as I know, no announcement was made.  But the problem was that NM and
> NM-pptp was using "Requires: ppp >= 2.4.4" which allowed this to happen.  So
> it's not really his fault.    

Eeeeeh...it is, really. Having "Requires: xxx >= a.b.c" for some dependency package is completely ok, it doesn't mean "this package will work for xxx >= a.b.c" but "this package *won't* work for xxx < a.b.c". Pushing an update into existing Fedora release which breaks API/ABI and causes dependent packages not to work without rebuilding them and coordinating the update is just plain wrong and forbidden.

:((((
Comment 23 Milos Jakubicek 2010-01-21 08:31:45 EST
Dan, thank you.
Comment 24 Dan Williams 2010-02-24 22:05:36 EST
*** Bug 568213 has been marked as a duplicate of this bug. ***
Comment 25 C Sand 2010-02-24 22:25:58 EST
(In reply to comment #24)
> *** Bug 568213 has been marked as a duplicate of this bug. ***    

By reading through all the comments above it's not clear to me whether the mobile broadband issue has been fixed. Should I reassign Bug 568213 to some other component ?

(btw, and I'm not trying to be nasty here, what happens to all the mobile broadband users who no longer have network connectivity due to the recent ppp update?)
Comment 26 Fabio Canepa 2010-02-25 02:17:08 EST
(In reply to comment #25)
> (btw, and I'm not trying to be nasty here, what happens to all the mobile
> broadband users who no longer have network connectivity due to the recent ppp
> update?)    

Same here... At home I've only mobile broadband connectivity ad now my fedora cannot connect to Internet... How can I fix it ? Should I download NetworkManager-pptp.src.rpm and rebuild ?

Thanx!
Comment 27 Dan Williams 2010-02-25 13:09:41 EST
(In reply to comment #25)
> (In reply to comment #24)
> > *** Bug 568213 has been marked as a duplicate of this bug. ***    
> 
> By reading through all the comments above it's not clear to me whether the
> mobile broadband issue has been fixed. Should I reassign Bug 568213 to some
> other component ?
> 
> (btw, and I'm not trying to be nasty here, what happens to all the mobile
> broadband users who no longer have network connectivity due to the recent ppp
> update?)    

yum --enablerepo=updates-testing upgrade NetworkManager*

will install the NetworkManager version from updates-testing that is compatible with ppp-2.4.5.  It's scheduled for the next stable updates push.
Comment 28 Dan Williams 2010-02-25 13:10:59 EST
(In reply to comment #26)
> (In reply to comment #25)
> > (btw, and I'm not trying to be nasty here, what happens to all the mobile
> > broadband users who no longer have network connectivity due to the recent ppp
> > update?)    
> 
> Same here... At home I've only mobile broadband connectivity ad now my fedora
> cannot connect to Internet... How can I fix it ? Should I download
> NetworkManager-pptp.src.rpm and rebuild ?

This update is available in updates-testing as well, and has been since 2010-01-22.  Please see bug 543002 for more details as well as how to update.  Otherwise, the direct link to the updated PPTP package advisory is:

https://admin.fedoraproject.org/updates/F12/FEDORA-2010-0932
Comment 29 Fabio Canepa 2010-02-25 15:47:26 EST
(In reply to comment #27)
> yum --enablerepo=updates-testing upgrade NetworkManager*
> 
> will install the NetworkManager version from updates-testing that is compatible
> with ppp-2.4.5.  It's scheduled for the next stable updates push.    

Updating to the NetworkManager available in testing fix my problem.
I think ppp-2.4.5 should bye pushed only after NM updates.

Thanx!
Comment 30 Matthew Hall 2010-02-26 01:06:09 EST
> Updating to the NetworkManager available in testing fix my problem.
> I think ppp-2.4.5 should bye pushed only after NM updates.*

It doesn't look this happened.

The version of ppp currently in updates is 2.4.5-2.fc12, with no update to NetworkManager available (so 3g connections fail with 'Plugin /usr/lib/pppd/2.4.4/nm-pppd-plugin.so is for pppd version 2.4.4, this is 2.4.5').

NM 1:0.7.998-2.git20100106.fc12 and ppp 2.4.5-5.fc12 are available in updates-testing - so someone needs to push either just NM or both updates from testing.
Comment 31 C Sand 2010-02-26 01:49:04 EST
Once the new NM and PPP packages are available, all will be ok for now, but this is just a bandaid solution.  Is there a procedure in place to prevent this snafu from happening again ?
Comment 32 Fabio Canepa 2010-02-26 04:20:43 EST
(In reply to comment #30)
> It doesn't look this happened.
> 
> The version of ppp currently in updates is 2.4.5-2.fc12, with no update to
> NetworkManager available (so 3g connections fail with 'Plugin
> /usr/lib/pppd/2.4.4/nm-pppd-plugin.so is for pppd version 2.4.4, this is
> 2.4.5').
> 
> NM 1:0.7.998-2.git20100106.fc12 and ppp 2.4.5-5.fc12 are available in
> updates-testing - so someone needs to push either just NM or both updates from
> testing.    

As I write I fixed the problem by updating networkmanager from repository "update-testing" using sudo yum --enablerepo=updates-testing update NetworkManager*

[fabio@f12fabio ~]$ rpm -qa | grep -i networkmanager
NetworkManager-vpnc-0.7.996-4.git20090921.fc12.x86_64
NetworkManager-gnome-0.7.998-2.git20100106.fc12.x86_64
NetworkManager-openvpn-0.7.996-4.git20090923.fc12.x86_64
NetworkManager-openconnect-0.7.996-4.git20090921.fc12.x86_64
NetworkManager-0.7.998-2.git20100106.fc12.x86_64
NetworkManager-glib-0.7.998-2.git20100106.fc12.x86_64
[fabio@f12fabio ~]$ rpm -qa | grep ppp
ppp-2.4.5-5.fc12.x86_64
Comment 33 Matthew Hall 2010-02-26 06:18:26 EST
Fabio: That would be fine assuming F12 users have more than one method to connect to the Internet and are compelled enough to search bugzilla for this answer. As for myself I was stuck without 3G access to resolve this problem until I found an open wireless AP. 

Conrad: I would suggest the NM packager sets and explicit requires on a specific ppp version such that a ppp update with new sover could not take place without NM being updated aswell.
Comment 34 Julian Sikorski 2010-02-26 06:24:03 EST
The thing is that you can add more than one build to an update request. This is how it should have been handled.
Comment 35 Fedora Update System 2010-02-26 22:39:20 EST
NetworkManager-0.7.998-2.git20100106.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 36 Dan Williams 2010-03-02 02:48:06 EST
*** Bug 568930 has been marked as a duplicate of this bug. ***