This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 573366

Summary: Damage Processing issues when using compiz
Product: [Fedora] Fedora Reporter: drago01
Component: mesaAssignee: Adam Jackson <ajax>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: adel.gadllah, ajax, anssi, aronparsons, bnocera, dcantrell, fabsh, gdghare, gleidson, pankaj86, sassmann, xgl-maint
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-04-20 08:53:46 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 507684    
Attachments:
Description Flags
Xorg log none

Description drago01 2010-03-14 08:47:08 EDT
Description of problem:

When using compiz on F13 on a GM45 there are lots of weird redrawing issues.

One reproducer is the mouse configuration capplet, change to another tab seems to not have any effect, forcing a full screen redraw by switching workspaces lets it display the selected tab.

Reverting compiz to the F12 version does not fix it, so it is not a compiz issue, but a xserver / driver one.

Enabling the workarounds plugin which has an option to basically always call glxWaitX does not fix it.

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.7.99.901-8.20100223.fc13.x86_64
xorg-x11-drv-intel-2.10.0-4.fc13.x86_64
mesa-libGLU-7.8-0.18.fc13.x86_64
mesa-libGL-7.8-0.18.fc13.x86_64
mesa-dri-drivers-7.8-0.18.fc13.x86_64

How reproducible:

Always

Steps to Reproduce:
1. See above
  
Actual results:

No partial redrawing

Expected results:

No redrawing issues.
Comment 1 drago01 2010-03-14 08:47:48 EDT
Created attachment 399975 [details]
Xorg log
Comment 2 Matěj Cepl 2010-03-19 08:32:52 EDT
Could you elaborate please on this statement?

> Reverting compiz to the F12 version does not fix it, so it is not a compiz
> issue, but a xserver / driver one.

I don't get the same conclusion as you do apparently.

Just contrary, I see a lot of compiz issues on various drivers, so it seems to me that there could be something going on in the compiz itself.

Reassigning to compiz without a prejudice ... if compiz maintainers think this is driver issue, please, reassign to xorg-x11-drv-intel.

Thank you
Comment 3 drago01 2010-03-19 09:48:35 EDT
(In reply to comment #2)
> Could you elaborate please on this statement?
> 
> > Reverting compiz to the F12 version does not fix it, so it is not a compiz
> > issue, but a xserver / driver one.
> 
> I don't get the same conclusion as you do apparently.
> 
> Just contrary, I see a lot of compiz issues on various drivers, so it seems to
> me that there could be something going on in the compiz itself.

Well that does not make sense at all ... 

I said reverting to a _known working_ compiz version (the one shipped in F12) does NOT fix the issue.

So how is this a bug triggered by a compiz change?

Also which issues are you referring too?

> Reassigning to compiz without a prejudice ... if compiz maintainers think this
> is driver issue, please, reassign to xorg-x11-drv-intel.

Well I doubt that the intel driver is to blame either ... because the same version is working fine on F12 (2.10.0) ... so it is either a mesa or xserver bug.
Comment 4 drago01 2010-03-19 10:29:32 EDT
(In reply to comment #3)
> (In reply to comment #2)
> > Could you elaborate please on this statement?
> > 
> > > Reverting compiz to the F12 version does not fix it, so it is not a compiz
> > > issue, but a xserver / driver one.
> > 
> > I don't get the same conclusion as you do apparently.
> > 
> > Just contrary, I see a lot of compiz issues on various drivers, so it seems to
> > me that there could be something going on in the compiz itself.
> 
> Well that does not make sense at all ... 
> 
> I said reverting to a _known working_ compiz version (the one shipped in F12)
> does NOT fix the issue.
> 
> So how is this a bug triggered by a compiz change?
> 
> Also which issues are you referring too?
> 
> > Reassigning to compiz without a prejudice ... if compiz maintainers think this
> > is driver issue, please, reassign to xorg-x11-drv-intel.
> 
> Well I doubt that the intel driver is to blame either ... because the same
> version is working fine on F12 (2.10.0) ... so it is either a mesa or xserver
> bug.    

Reverting to F12's mesa fixes it.
Comment 5 Adel Gadllah 2010-03-26 07:30:41 EDT
*** Bug 577112 has been marked as a duplicate of this bug. ***
Comment 6 Adel Gadllah 2010-03-27 08:04:45 EDT
*** Bug 577473 has been marked as a duplicate of this bug. ***
Comment 7 Adel Gadllah 2010-04-17 09:24:59 EDT
This is still present with mesa-7.8.1-1 and xorg-x11-drv-intel-2.11.0-1
Comment 8 Adel Gadllah 2010-04-20 07:17:49 EDT
*** Bug 583904 has been marked as a duplicate of this bug. ***
Comment 9 pankaj pandey 2010-04-20 08:43:47 EDT
This issue seems to be same as bug #577142 so probably can be marked as duplicate of that.
Comment 10 Adel Gadllah 2010-04-20 08:53:46 EDT
(In reply to comment #9)
> This issue seems to be same as bug #577142 so probably can be marked as
> duplicate of that.    

Thanks for pointing this out, the bug you linked to also seems to have link to an upstream bug report with a proposed fix.

*** This bug has been marked as a duplicate of bug 577142 ***