Bug 590661

Summary: GRUB bootloader should have a few seconds delay on a multi-boot setup
Product: [Fedora] Fedora Reporter: Rahul Sundaram <metherid>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: anaconda-maint-list, awilliam, BobLfoot, jonathan, leigh123linux, mishu, narfman0, robatino, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: anaconda-13.42-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 592080 (view as bug list) Environment:
Last Closed: 2010-05-19 00:07:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 507681    

Description Rahul Sundaram 2010-05-10 12:52:14 UTC
Description of problem:

GRUB by default in configured in Fedora to not show the menu and have zero delay but in a multi-boot environment where Anaconda detects Windows and configures GRUB to boot Windows as a alternative, GRUB was configured by Anaconda to have a few seconds delay and show the menu so that the user can choose between Fedora and Windows. 

Unfortunately this is not the case with Fedora 13 RC2 anymore.  This results in a non-technical user unable to boot into Windows after installing Fedora 13.  I am marking it as a blocker

Comment 1 Adam Williamson 2010-05-10 14:38:40 UTC
Can anyone confirm how this behaved in F12?

Comment 2 Rahul Sundaram 2010-05-10 18:17:15 UTC
Fedora 12 works as expected.  This is a regression.

Comment 3 leigh scott 2010-05-11 09:05:44 UTC
This never worked in F12 for me (I multi-boot several Linux distro's).


The zero delay sucks.

Comment 4 leigh scott 2010-05-11 09:06:14 UTC
(In reply to comment #3)
> This never worked in F12 for me (I multi-boot several Linux distro's).
> https://bugzilla.redhat.com/show_bug.cgi?id=541315
> The zero delay sucks.    

And it still doesn't work in F13.

Comment 5 Peter Jones 2010-05-11 13:45:56 UTC
*** Bug 574994 has been marked as a duplicate of this bug. ***

Comment 6 Jon Robison 2010-05-11 13:49:39 UTC
Worked for me F12 on 2/2 of my machines as Rahul explains. 0 delay does suck..!

Comment 7 John Poelstra 2010-05-12 01:02:14 UTC
Reviewed by a QA, Release Engineering, etc. at 2010-05-11 "Go/No-Go Meeting.  Move to F13Target, will accept into F13 final a well tested fix for this issue considering the potential negative press.

Comment 8 Fedora Update System 2010-05-12 19:20:53 UTC
anaconda-13.42-1.fc13 has been submitted as an update for Fedora 13.

Comment 9 Robert Lightfoot 2010-05-14 03:56:32 UTC
2010-05-13 -- anaconda-13.42-1.fc13. from Fedora13-Final.RC3 tested on Dell Dimension B120 Laptop System.  Hard Drive had Fedora13-Final.RC2 and WindowsXPSP3 partitons before installation.  Advertised delay in grub was present as expected.
When testing F13Final.RC3 as guest in VirtualBox-OSE with no dual OS the delay was 0 as advertised.  Call this bug FIXED for my testing.

Comment 10 Adam Williamson 2010-05-19 00:07:33 UTC
several people have confirmed this is fixed.

Fedora Bugzappers volunteer triage team