This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 590661 - GRUB bootloader should have a few seconds delay on a multi-boot setup
GRUB bootloader should have a few seconds delay on a multi-boot setup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 574994 (view as bug list)
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-05-10 08:52 EDT by Rahul Sundaram
Modified: 2010-05-18 20:07 EDT (History)
9 users (show)

See Also:
Fixed In Version: anaconda-13.42-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 592080 (view as bug list)
Environment:
Last Closed: 2010-05-18 20:07:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2010-05-10 08:52:14 EDT
Description of problem:


GRUB by default in configured in Fedora to not show the menu and have zero delay but in a multi-boot environment where Anaconda detects Windows and configures GRUB to boot Windows as a alternative, GRUB was configured by Anaconda to have a few seconds delay and show the menu so that the user can choose between Fedora and Windows. 

Unfortunately this is not the case with Fedora 13 RC2 anymore.  This results in a non-technical user unable to boot into Windows after installing Fedora 13.  I am marking it as a blocker
Comment 1 Adam Williamson 2010-05-10 10:38:40 EDT
Can anyone confirm how this behaved in F12?
Comment 2 Rahul Sundaram 2010-05-10 14:17:15 EDT
Fedora 12 works as expected.  This is a regression.
Comment 3 leigh scott 2010-05-11 05:05:44 EDT
This never worked in F12 for me (I multi-boot several Linux distro's).


https://bugzilla.redhat.com/show_bug.cgi?id=541315

The zero delay sucks.
Comment 4 leigh scott 2010-05-11 05:06:14 EDT
(In reply to comment #3)
> This never worked in F12 for me (I multi-boot several Linux distro's).
> 
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=541315
> 
> The zero delay sucks.    

And it still doesn't work in F13.
Comment 5 Peter Jones 2010-05-11 09:45:56 EDT
*** Bug 574994 has been marked as a duplicate of this bug. ***
Comment 6 Jon Robison 2010-05-11 09:49:39 EDT
Worked for me F12 on 2/2 of my machines as Rahul explains. 0 delay does suck..!
Comment 7 John Poelstra 2010-05-11 21:02:14 EDT
Reviewed by a QA, Release Engineering, etc. at 2010-05-11 "Go/No-Go Meeting.  Move to F13Target, will accept into F13 final a well tested fix for this issue considering the potential negative press.
Comment 8 Fedora Update System 2010-05-12 15:20:53 EDT
anaconda-13.42-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.42-1.fc13
Comment 9 Robert Lightfoot 2010-05-13 23:56:32 EDT
2010-05-13 -- anaconda-13.42-1.fc13. from Fedora13-Final.RC3 tested on Dell Dimension B120 Laptop System.  Hard Drive had Fedora13-Final.RC2 and WindowsXPSP3 partitons before installation.  Advertised delay in grub was present as expected.
When testing F13Final.RC3 as guest in VirtualBox-OSE with no dual OS the delay was 0 as advertised.  Call this bug FIXED for my testing.
Comment 10 Adam Williamson 2010-05-18 20:07:33 EDT
several people have confirmed this is fixed.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.