Bug 61413

Summary: RFE: Can't replace a directory with a symlink
Product: [Retired] Red Hat Linux Reporter: Bernhard Rosenkraenzer <bero>
Component: rpmAssignee: Paul Nasrat <nobody+pnasrat>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 7.3CC: mitr, than
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-09-29 18:14:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 61131, 73500, 79579, 100644    

Description Bernhard Rosenkraenzer 2002-03-19 10:55:23 UTC
Description of Problem: 
rpm can't replace a directory with a symlink. 
 
Version-Release number of selected component (if applicable): 
4.0.4-7x.5 
 
How Reproducible: 
100% 
 
Steps to Reproduce: 
1. Build an rpm with a directory in it; install it 
2. Update the rpm, replacing the directory with a symlink 
3. Try to upgrade to the new rpm 
 
Actual Results: 
Error messages, failed upgrade 
 
Expected Results: 
New rpm is installed 
 
Additional Information: 
I know it's always been that way; filing a bug report in the hopes of getting it on the 
feature list for one of the next versions. 
 
This issue blocks fixing some other bugs.

Comment 1 Jeff Johnson 2002-07-20 18:55:19 UTC
*** Bug 3979 has been marked as a duplicate of this bug. ***

Comment 2 Paul Nasrat 2005-09-29 18:14:56 UTC
We're not looking at doing this anytime soon.  If you want this persued probably
best forum is rpm-devel list

https://lists.dulug.duke.edu/mailman/listinfo/rpm-devel