This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 642358

Summary: Up arrow tries to run gnome-screenshot
Product: [Fedora] Fedora Reporter: Brian Lane <bcl>
Component: anacondaAssignee: Ales Kozumplik <akozumpl>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: akozumpl, anaconda-maint-list, gmaxwell, jlaska, jonathan, jzeleny, kparal, rhe, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: anaconda-14.21-1.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-10-19 18:24:16 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 641108    

Description Brian Lane 2010-10-12 13:02:03 EDT
Description of problem:
When using the keyboard to select options (eg. in the autopart dialog) up arrow pops up a dialog saying it cannot run gnome-screenshot. left, right and down arrow keys work correctly.

This has been observed both in a KVM virt, and on a Lenovo x200 laptop.

The Beta-DVD does not do this, it is new in 14.18 on the TC1 netinst.iso image.
Comment 1 Chris Lumens 2010-10-13 11:33:58 EDT
*** Bug 642501 has been marked as a duplicate of this bug. ***
Comment 2 Adam Jackson 2010-10-13 14:44:11 EDT
I suspect this may be helped by

commit ecf7d49b1a0217514419b1455b412d6274e3f578
Author: Adam Jackson <ajax@redhat.com>
Date:   Tue Jun 29 08:35:19 2010 -1000

    anaconda: Disable X server regenerations (#609245)

although I don't really have proof of that since I haven't built an updates image to test.
Comment 3 Ales Kozumplik 2010-10-14 04:24:39 EDT
I tested with F14 just now and the Up arrow no longer causes the PrintScrn action! But why is that?

In any case, I'll make sure the patch makes it to f14-branch. Thanks and bravo Ajax!
Comment 4 Ales Kozumplik 2010-10-14 07:08:54 EDT
The other part of the problem is that our custom values for gconf are not being applied. This causes the printscrn to still be caught by metacity with Ajax's patch, but also the window decoration icons appearing.
Comment 5 Ales Kozumplik 2010-10-14 10:03:52 EDT
the two patches are on the mailing list:
https://www.redhat.com/archives/anaconda-devel-list/2010-October/msg00151.html

We definitely get rid of the problem with the UP key with the first patch, the second one should also block the PrintScrn key to cause metacity to try to call gnome-screenshot. If this problem still exists after compose with the new anaconda, please attach the pungi log to this bug.
Comment 6 James Laska 2010-10-14 13:17:22 EDT
Sounds like this should be in ASSIGNED, and pending patch review may move to MODIFIED
Comment 7 Fedora Update System 2010-10-14 19:56:58 EDT
anaconda-14.20-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.20-1.fc14
Comment 8 Fedora Update System 2010-10-15 00:08:42 EDT
anaconda-14.20-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/anaconda-14.20-1.fc14
Comment 9 Fedora Update System 2010-10-18 23:22:40 EDT
anaconda-14.21-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.21-1.fc14
Comment 10 Kamil Páral 2010-10-19 09:38:10 EDT
I tested with F14 TC1 DVD x86_64 with updates.img containing anaconda-14.21-1 code. Problem seems to be gone.
Comment 11 Ales Kozumplik 2010-10-19 13:33:41 EDT
(In reply to comment #10)
> I tested with F14 TC1 DVD x86_64 with updates.img containing anaconda-14.21-1
> code. Problem seems to be gone.

Thanks Kamil.

I think you mean that the 'key up' error is fixed. On a compose built using 14.21 we also need to test whether 'printscrn' doesn't try to call gnome-screenshot and whether all the other metacity settings are sane (e.g. there's no 'maximize' button on dialogs etc.) If that should fail we need to look into the compose logs.

Ales
Comment 12 Fedora Update System 2010-10-19 18:23:33 EDT
anaconda-14.21-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Ales Kozumplik 2010-10-25 05:52:43 EDT
*** Bug 646020 has been marked as a duplicate of this bug. ***