Bug 655322

Summary: NetworkManager[1135]: <error> [1290255985.317100] [nm-manager.c:1368] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name
Product: [Fedora] Fedora Reporter: Nicolas Mailhot <nicolas.mailhot>
Component: NetworkManagerAssignee: Dan Williams <dcbw>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: collura, dcbw, dkovalsk, jklimes, jlaska, kukabu, matthias.guentert, pfpschneider, sudheer.s, udovdh
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: NetworkManager-0.8.3.996-1.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-03-02 01:50:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Nicolas Mailhot 2010-11-20 13:30:18 UTC
Description of problem:

NetworkManager[1135]: <error> [1290255985.317100] [nm-manager.c:1368] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name


Version-Release number of selected component (if applicable):

kernel-2.6.36-5.fc15.x86_64
NetworkManager-0.8.2-1.git20101117.fc15.x86_64
NetworkManager-glib-0.8.2-1.git20101117.fc15.x86_64
NetworkManager-gnome-0.8.2-1.git20101117.fc15.x86_64
selinux-policy-3.9.9-3.fc15.noarch
selinux-policy-targeted-3.9.9-3.fc15.noarch
systemd-13-1.fc15.x86_64
systemd-gtk-13-1.fc15.x86_64
systemd-units-13-1.fc15.x86_64

Comment 1 Peter F. Patel-Schneider 2010-12-01 14:18:36 UTC
I see this message in all my Fedora 14 boxes (two desktops, a Lenovo T60p).  It doesn't appear to be directly causing any problems, but wireless on my T60p isn't working as well as I would like it so, so there may be some malign effects.

Here is a portion of /var/log/messages:


Dec  1 08:38:59 idefix NetworkManager[1348]: <error> [1291210739.762189] [nm-manager.c:1332] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name
Dec  1 08:38:59 idefix NetworkManager[1348]: <error> [1291210739.765079] [nm-manager.c:1332] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name
Dec  1 08:38:59 idefix NetworkManager[1348]: <error> [1291210739.766161] [nm-manager.c:1332] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name
Dec  1 08:38:59 idefix NetworkManager[1348]: <error> [1291210739.767622] [nm-manager.c:1332] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name
Dec  1 08:38:59 idefix NetworkManager[1348]: <error> [1291210739.768339] [nm-manager.c:1332] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name

I am running F14 2.6.35.6-48.fc14.i686 #1 SMP Fri Oct 22 15:34:36 and
NetworkManager version as follows: (yum output)
Arch        : i686
Epoch       : 1
Version     : 0.8.1
Release     : 10.git20100831.fc14

Comment 2 Jirka Klimes 2010-12-03 08:56:08 UTC
It's been fixed upstream:
4b37101ef4e91efb57525ad694169b48b56a0a61 (master)
83e02840b5ce1cf8c122cc70918ddd57396c91db (NM_0_8)

Comment 3 Sudheer Satyanarayana 2010-12-15 11:25:12 UTC
I have the same issue on Fedora 14 x86_64. Because of this blocker bug, I am unable to upgrade to Fedora 14. I hope the fix will be rolled out in the package soon.

Comment 4 Sudheer Satyanarayana 2010-12-15 11:27:41 UTC
snippet for /var/log/messages

Dec 15 16:41:48 localhost NetworkManager[1246]: <error> [1292411508.566412] [nm-manager.c:1332] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name
Dec 15 16:41:48 localhost NetworkManager[1246]: <error> [1292411508.575242] [nm-manager.c:1332] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name
Dec 15 16:41:48 localhost NetworkManager[1246]: <error> [1292411508.576591] [nm-manager.c:1332] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name
Dec 15 16:41:48 localhost NetworkManager[1246]: <error> [1292411508.577508] [nm-manager.c:1332] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name
Dec 15 16:41:48 localhost NetworkManager[1246]: <error> [1292411508.578250] [nm-manager.c:1332] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name

[root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.35.9-64.fc14.x86_64 #1 SMP Fri Dec 3 12:19:41 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux
[root@localhost ~]# 

The Enable Wireless option is greyed out in NetworkManager. Please refer to the Forum thread http://forums.fedoraforum.org/showthread.php?p=1421680

Comment 5 Jirka Klimes 2011-02-02 09:04:54 UTC
*** Bug 666719 has been marked as a duplicate of this bug. ***

Comment 6 Jirka Klimes 2011-02-02 10:48:55 UTC
*** Bug 668229 has been marked as a duplicate of this bug. ***

Comment 7 Jirka Klimes 2011-02-02 13:10:58 UTC
*** Bug 657623 has been marked as a duplicate of this bug. ***

Comment 8 udo 2011-02-02 14:18:33 UTC
So when can we test for Fedora 14?

Comment 9 James Laska 2011-02-09 14:09:46 UTC
(In reply to comment #2)
> It's been fixed upstream:
> 4b37101ef4e91efb57525ad694169b48b56a0a61 (master)
> 83e02840b5ce1cf8c122cc70918ddd57396c91db (NM_0_8)

I believe MODIFIED means that the patch is committed upstream (http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=83e02840b5ce1cf8c122cc70918ddd57396c91db), but not yet packaged for Fedora.  I don't see anything in the changelog of the current rawhide NetworkManager-0.8.2-7.git20101117.fc15 package (http://koji.fedoraproject.org/koji/buildinfo?buildID=217591)?  

I believe we need to wait for a build that contains this fix in rawhide, F15 (once branched) and F14?  Jirka can confirm.

Comment 10 Fedora Update System 2011-02-24 06:05:53 UTC
NetworkManager-0.8.3.995-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.995-1.fc14

Comment 11 Fedora Update System 2011-02-24 06:09:21 UTC
NetworkManager-0.8.3.995-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.995-1.fc13

Comment 12 Fedora Update System 2011-02-24 20:57:05 UTC
NetworkManager-0.8.3.995-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.995-1.fc14

Comment 13 Fedora Update System 2011-02-25 23:42:42 UTC
Package NetworkManager-0.8.3.996-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.3.996-1.fc14'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.996-1.fc14
then log in and leave karma (feedback).

Comment 14 Fedora Update System 2011-02-25 23:45:42 UTC
Package NetworkManager-0.8.3.996-1.fc13:
* should fix your issue,
* was pushed to the Fedora 13 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.3.996-1.fc13'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.996-1.fc13
then log in and leave karma (feedback).

Comment 15 udo 2011-02-26 05:37:24 UTC
Fedora 14 had a small test:
NM was not running so I did the yum update --enablerepo=updates-testing
NetworkManager-0.8.3.996-1.fc14
I then did service NetworkManager start

And voila: stuff worked as it did before the problems.
Connections stayed up, were not reconfigured in weird ways, etc.
Thanks!

Comment 16 udo 2011-02-27 16:37:22 UTC
Hmm.
Excessive logging:

Feb 27 17:15:01 surfplank2 NetworkManager[2873]:    ifcfg-rh:     warning: NM_CONTROLLED was false but HWADDR or SUBCHANNELS was missing; device will be managed
Feb 27 17:20:00 surfplank2 NetworkManager[2873]:    ifcfg-rh:     warning: NM_CONTROLLED was false but HWADDR or SUBCHANNELS was missing; device will be managed
Feb 27 17:20:00 surfplank2 NetworkManager[2873]:    ifcfg-rh:     warning: NM_CONTROLLED was false but HWADDR or SUBCHANNELS was missing; device will be managed
etc etc etc

Comment 17 Fedora Update System 2011-03-02 01:49:02 UTC
NetworkManager-0.8.3.996-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2011-03-03 09:47:08 UTC
Package NetworkManager-0.8.3.997-1.fc13:
* should fix your issue,
* was pushed to the Fedora 13 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.3.997-1.fc13'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.997-1.fc13
then log in and leave karma (feedback).

Comment 19 Fedora Update System 2011-03-25 03:30:03 UTC
NetworkManager-0.8.3.998-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.998-2.fc13

Comment 20 Fedora Update System 2011-04-12 21:27:53 UTC
NetworkManager-0.8.3.998-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.