This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 663294

Summary: RuntimeError: XOpenDisplay failed
Product: [Fedora] Fedora Reporter: Eric Springer <erikina>
Component: anacondaAssignee: Brian Lane <bcl>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 15CC: bcl, cristian.ciupitu, dmaxel, erikina, flokip, foxmulder881, frankly3d, jfrieben, jlaska, johannbg, jonathan, jreiser, justin, meyering, monobello, rbergero, sandro, ultima.ratio.regum69, vanmeeuwen+fedora, v.plessky
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: anaconda_trace_hash:bb3ba0ab6a88ef1fadfba2dbcc0c80fa426826a74e8304634cdf9b9b5043636e AcceptedBlocker
Fixed In Version: anaconda-15.20.1-1.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 679486 728229 (view as bug list) Environment:
Last Closed: 2011-02-24 22:50:32 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 657616, 728229    
Attachments:
Description Flags
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Device Selection
none
liveinst crash
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda. none

Description Eric Springer 2010-12-15 05:23:35 EST
The following was filed automatically by anaconda:
anaconda 15.11 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/account_gui.py", line 91, in setCapsLockLabel
    if _isys.isCapsLockEnabled():
  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/account_gui.py", line 72, in getScreen
    self.setCapsLockLabel()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1285, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1205, in nextClicked
    self.setScreen ()
SystemError: error return without exception set
Comment 1 Eric Springer 2010-12-15 05:23:42 EST
Created attachment 468827 [details]
Attached traceback automatically from anaconda.
Comment 2 Eric Springer 2010-12-15 05:42:11 EST
Created attachment 468833 [details]
Attached traceback automatically from anaconda.
Comment 3 Chris Lumens 2010-12-15 14:10:18 EST
This should be fixed in the next build of anaconda.
Comment 4 Frank Murphy 2010-12-18 09:01:04 EST
Created attachment 469513 [details]
Attached traceback automatically from anaconda.
Comment 5 Frank Murphy 2010-12-18 09:57:26 EST
Created attachment 469517 [details]
Attached traceback automatically from anaconda.
Comment 6 Frank Murphy 2010-12-18 10:05:51 EST
Comment 5(In reply to comment #5)
> Created attachment 469517 [details]
> Attached traceback automatically from anaconda.

This happened with the most recent anaconda, in the livecd:
http://alt.fedoraproject.org/pub/alt/nightly-composes/xfce/
http://alt.fedoraproject.org/pub/alt/nightly-composes/xfce/logs/20101217.16-i386.log

http://koji.fedoraproject.org/koji/buildinfo?buildID=209270
Comment 7 Brian Lane 2010-12-23 16:31:43 EST
Created attachment 470472 [details]
Attached traceback automatically from anaconda.
Comment 8 Brian Lane 2010-12-23 16:45:35 EST
It now throws the new error, but we need to track down why.
Comment 9 Brian Lane 2010-12-23 18:17:48 EST
I don't see this with the nightly build desktop-x86_64-20101222.15.iso

I saw it on my local compose of a rawhide cd which may not be the same.
Comment 10 Brian Lane 2010-12-23 18:34:44 EST
(In reply to comment #9)
> I don't see this with the nightly build desktop-x86_64-20101222.15.iso
> 
> I saw it on my local compose of a rawhide cd which may not be the same.

Cancel that, I've now seen it with the nightly as well. But not consistently.
Comment 11 Frank Murphy 2010-12-24 07:01:37 EST
Created attachment 470618 [details]
Attached traceback automatically from anaconda.
Comment 12 Frank Murphy 2010-12-24 07:37:32 EST
(In reply to comment #11)
> Created attachment 470618 [details]
> Attached traceback automatically from anaconda.

This is trying to install onto a KVM 31gb unallocated guest space. (F14 Host)

So have tried nightlies with both pre-existing partitions, and no partitions.
Same result.

But /usr/bin/liveinst will not start from desktop icon for me.
has to be started from Terminal, and only then after I run "rm -rf /var/log"

# /usr/bin/liveinst
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 535, in <module>
    os.mkdir("/var/log", 0755)
OSError: [Errno 17] File exists: '/var/log'


Have got it installed eventually.
Do above then run install  second time, install goes ahead, but with a new window every time next is clicked. Will attach a screencap. Will not crop, so size can be seen.
Comment 13 Frank Murphy 2010-12-24 07:39:17 EST
Created attachment 470620 [details]
Device Selection

Scrollbars make it awkward.
Comment 14 Frank Murphy 2010-12-25 06:52:14 EST
Created attachment 470668 [details]
liveinst crash

Saved locally and c&p into textfile.
Comment 15 Raphael Groner 2011-01-18 09:44:05 EST
Created attachment 474066 [details]
Attached traceback automatically from anaconda.
Comment 16 Sandro Mathys 2011-01-19 08:17:00 EST
Created attachment 474257 [details]
Attached traceback automatically from anaconda.
Comment 17 Eric Springer 2011-01-22 20:40:10 EST
Created attachment 474771 [details]
Attached traceback automatically from anaconda.
Comment 18 Joachim Frieben 2011-01-23 06:13:33 EST
Created attachment 474808 [details]
Attached traceback automatically from anaconda.
Comment 19 Flóki Pálsson 2011-01-29 07:08:56 EST
Created attachment 475943 [details]
Attached traceback automatically from anaconda.
Comment 20 ultima.ratio.regum69 2011-02-12 09:11:47 EST
Created attachment 478383 [details]
Attached traceback automatically from anaconda.
Comment 21 ultima.ratio.regum69 2011-02-14 02:47:35 EST
Created attachment 478562 [details]
Attached traceback automatically from anaconda.
Comment 22 Jóhann B. Guðmundsson 2011-02-14 11:08:02 EST
Created attachment 478662 [details]
Attached traceback automatically from anaconda.
Comment 23 Flóki Pálsson 2011-02-14 18:49:07 EST
Created attachment 478737 [details]
Attached traceback automatically from anaconda.
Comment 24 James Laska 2011-02-18 10:12:38 EST
Created attachment 479537 [details]
Attached traceback automatically from anaconda.
Comment 25 James Laska 2011-02-18 10:14:52 EST
(In reply to comment #24)
> Created attachment 479537 [details]
> Attached traceback automatically from anaconda.

Discovered after building and testing a live image with the latest F15Alpha kernel
Comment 26 Brian Lane 2011-02-18 10:29:10 EST
Can you reproduce it consistently?
Comment 27 James Laska 2011-02-18 10:39:13 EST
(In reply to comment #26)
> Can you reproduce it consistently?

Seems so (3/3), in my virt guest.  Note, I'm slightly confused since all attached tracebacks since your first one (2010-12-23) are different from the originally reported issue.

anaconda 15.20 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/account_gui.py", line 91, in setCapsLockLabel
    if _isys.isCapsLockEnabled():
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/account_gui.py", line 72, in getScreen
    self.setCapsLockLabel()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1338, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1258, in nextClicked
    self.setScreen ()
RuntimeError: XOpenDisplay failed

Should we continue tracking XOpenDisplay here?
Comment 28 James Laska 2011-02-18 10:49:26 EST
(In reply to comment #27)
> (In reply to comment #26)
> Should we continue tracking XOpenDisplay here?

Nm ... the tracebacks aren't as different as I originally thought.  They appear to be same, with changes in lineno's and the final exception string
Comment 29 James Laska 2011-02-18 11:15:31 EST
Adding to F15Alpha for discussion as an Alpha release blocker per the following criteria [1]:

    "The installer must boot (if appropriate) and run on 
     all primary architectures from default live image, DVD, 
     and boot.iso install media"

https://fedoraproject.org/wiki/Fedora_15_Alpha_Release_Criteria

If this happens only to some, and we have a workaround, that might lower the priority of the issue.  So far, I seem to keep hitting this issue.  Interested in feedback from other testers.  It could be how I built the live image.
Comment 30 Robyn Bergeron 2011-02-18 12:19:52 EST
Per 2011-02-18 Alpha Blocker meeting:

Need more information to determine if this problem is widespread. 

#agreed 663294 - Needs more testing to determine scope of problem.  Leave on proposed blocker list pending more information.

New nightly live .iso's expected later today.
Comment 31 Cristian Ciupitu 2011-02-19 19:00:45 EST
Created attachment 479733 [details]
Attached traceback automatically from anaconda.
Comment 32 Eric Springer 2011-02-19 23:22:54 EST
Created attachment 479738 [details]
Attached traceback automatically from anaconda.
Comment 33 Danny Stieben 2011-02-20 19:39:27 EST
Created attachment 479803 [details]
Attached traceback automatically from anaconda.
Comment 34 Chris Lumens 2011-02-20 21:34:03 EST
*** Bug 678930 has been marked as a duplicate of this bug. ***
Comment 35 Sandro Mathys 2011-02-21 07:41:29 EST
Created attachment 479889 [details]
Attached traceback automatically from anaconda.
Comment 36 Sandro Mathys 2011-02-21 07:49:05 EST
I can still reproduce this with the latest nightly (kde-1g-x86_64-20110221.00.iso).

Reproduced on a Dell Optiplex 755 - which is in the top 10 HW models according to smolt stats, and actually #2 non-VM, non-unnamed model. Not sure what the criteria for 'being widespread' are but I sure think this should be accepted as a blocker.
Comment 37 Jim Meyering 2011-02-21 08:08:52 EST
Created attachment 479912 [details]
Attached traceback automatically from anaconda.
Comment 38 James Laska 2011-02-21 10:21:36 EST
(In reply to comment #30)
> Per 2011-02-18 Alpha Blocker meeting:
> 
> Need more information to determine if this problem is widespread. 
> 
> #agreed 663294 - Needs more testing to determine scope of problem.  Leave on
> proposed blocker list pending more information.

It appears to still be an issue, and we are seeing enough people reproduce this issue.  I'd like to move this from the "ProposedBlocker" list to the "AcceptedBlocker".  This issue appears to be preventing all/most live image installs which is an Alpha criteria blocker.

https://fedoraproject.org/wiki/Fedora_15_Alpha_Release_Criteria
Comment 39 Sandro Mathys 2011-02-21 10:56:28 EST
While #anaconda is already working on resolving this issue let me add what's been found that might influence whether this is to become a blocker.

The bug won't show up:
- if the hostname is not changed (i.e. localhost.localdomain) OR
- if one performs 'xhost +' before launching anaconda

It should be discussed whether either is considered a valid workaround for the alpha release.
Comment 40 Jóhann B. Guðmundsson 2011-02-21 11:04:05 EST
is this bug present if hostname is obtain via dhcp ?
Comment 41 Sandro Mathys 2011-02-21 11:09:53 EST
Yes, if the hostname is automatically obtained, the bug will be hit. Changing it manually to localhost.localdomain will help, though.
Comment 42 Justin Willmert 2011-02-21 11:55:44 EST
Created attachment 479957 [details]
Attached traceback automatically from anaconda.
Comment 43 Brian Lane 2011-02-21 12:44:15 EST
This happens because the hostname was changed. In the live install X is running with auth enabled, so changing the hostname causes the X auth to fail when it tries to check the capslock state. During a normal install X is run with the -ac command line option so this isn't an issue.

The fix is to disable auth in the liveinst script.
Comment 44 Dennis Gilmore 2011-02-21 12:53:32 EST
i was able to reproduce and agree it is a blocker. i tested that the proposed fix on the anaconda list works as well
Comment 45 Dennis Gilmore 2011-02-21 12:54:04 EST
i was able to reproduce and agree it is a blocker. i tested that the proposed fix on the anaconda list works as well
Comment 46 James Laska 2011-02-21 13:01:45 EST
(In reply to comment #45)
> i was able to reproduce and agree it is a blocker. i tested that the proposed
> fix on the anaconda list works as well

Thanks Dennis!  I also have confirmation from clumens on IRC as well that this is a blocker.

> clumens: jlaska: 663294 definitely is

Adding whiteboard: ApprovedBlocker.
Comment 47 James Laska 2011-02-21 13:03:15 EST
(In reply to comment #46)
> Adding whiteboard: ApprovedBlocker.

Apologies, make that 'AcceptedBlocker'
Comment 48 Fedora Update System 2011-02-21 14:35:15 EST
anaconda-15.20.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/anaconda-15.20.1-1.fc15
Comment 49 Fedora Update System 2011-02-21 15:38:37 EST
anaconda-15.20.1-1.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/anaconda-15.20.1-1.fc15
Comment 50 James Laska 2011-02-22 08:44:04 EST
Confirmed fix with anaconda-15.20.1-1.fc15 (RC1)
Comment 51 Sandro Mathys 2011-02-22 09:35:04 EST
Can't confirm fix with Alpha RC1 KDE (anaconda-15.20.1-1.fc15.x86_64).

On a freshly booted system:

$ liveinst
No protocol specified                                                                                                                                                                                                                        
xhost:  unable to open display ":0"                                                                                                                                                                                                          
14:28:44 Starting graphical installation.                                                                                                                                                                                                    
No protocol specified                                                                                                                                                                                                                        
14:28:44 Exception starting GUI installer: could not open display                                                                                                                                                                            
14:28:44 GUI installer startup failed, falling back to text mode.

So the patch actually made things worse :)

No idea why liveinst fails to perform the xhost command though, as I can run it manually:

$ xhost
access control enabled, only authorized clients can connect
SI:localuser:liveuser
$ xhost +
access control disabled, clients can connect from any host

I haven't tried any other Live iso yet.
Comment 52 James Laska 2011-02-22 10:30:56 EST
Confirmed Sandro's behavior on the KDE RC1 live images.  On 2 of 6 boot attempts, running liveinst starts the graphical installer.  The 4 other attempts, running liveinst fails to start the graphical installer, and launches the text-mode installer.  If you are clicking on the desktop icon to start liveinst, you'll never see the text-mode installer.

Running the following before starting liveinst works
# xhost +

In the 4 failure attempts, it seems that the XAUTHORITY ENV variable isn't being passed to the root user.  I think this means the root user won't be able to connect to the liveinst X session.  In the 2 successful attempts, when I `su` to root, I see an XAUTHORITY ENV variable.

So far, I've not managed to reproduce this failure on the GNOME live image.  If this doesn't impact the GNOME image, we may want to track this as a different bug report, and leave this issue in VERIFIED (as the original problem has been addressed).
Comment 53 James Laska 2011-02-22 12:30:54 EST
I'm moving this KDE problem out into a new bugzilla since the issue is different enough from the originally reported problem addressed here.  That bug is bug#679486.
Comment 54 v.plessky 2011-02-23 16:37:03 EST
Created attachment 480583 [details]
Attached traceback automatically from anaconda.
Comment 55 Danny Stieben 2011-02-23 20:13:36 EST
Created attachment 480620 [details]
Attached traceback automatically from anaconda.
Comment 56 v.plessky 2011-02-24 02:14:01 EST
Due to the problem with GNOME LiveCD 
(see comments for GFX Test Day: https://fedoraproject.org/wiki/Test_Day:2011-02-23_Radeon ) it is not possible to do HDD isntall from GNOME Live CD.
GNOME doens't start, crash in mutter.
See also Bug 677842
https://bugzilla.redhat.com/show_bug.cgi?id=677842

So I downloaded and booted from KDE LiveCD.
And tried to isnatll Fedora 15 from it. Got problem - see attachment above.

I had blank screen, when tried to press next - it was saying "you need to define password for root"
There was no form for root password on screen. Very confusing.
Comment 57 v.plessky 2011-02-24 06:37:10 EST
Created attachment 480727 [details]
Attached traceback automatically from anaconda.
Comment 58 Brian Lane 2011-02-24 11:21:22 EST
v.plessky, you are using an older version of anaconda. This bug is fixed in 15.21-1 and you have 15.20-1 on the iso's you are using.
Comment 59 Fedora Update System 2011-02-24 22:50:14 EST
anaconda-15.20.1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 60 Eric Springer 2011-02-25 18:35:28 EST
Created attachment 481102 [details]
Attached traceback automatically from anaconda.
Comment 61 Chris Lumens 2011-04-11 10:32:55 EDT
*** Bug 694961 has been marked as a duplicate of this bug. ***
Comment 62 Chris Lumens 2012-02-09 16:32:45 EST
*** Bug 693806 has been marked as a duplicate of this bug. ***