Bug 666038

Summary: [all languages] yum untranslated words
Product: [Fedora] Fedora Reporter: Skippy <lecotegougdelaforce>
Component: yumAssignee: Seth Vidal <skvidal>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 16CC: aalam, chepioq, ffesti, james.antill, kassabon14, kraymond, maxamillion, noriko, piotrdrag, pmatilai, thomas.canniot, tla, trans
Target Milestone: ---Keywords: Translation, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 666047 (view as bug list) Environment:
Last Closed: 2012-04-03 12:55:57 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 666047    

Description Skippy 2010-12-28 09:48:54 EST
Description of problem:
When asking for package installation or removal with yum, the user using non-English localization will be facing the following sentence :
"---> Package [some package] will be [local translation of "erased" or "installed"]"
in which the English words "Package" and "will be" are not localized.

This sentence is not translated either :
"Adding [locale] to language list"


Version-Release number of selected component (if applicable):
yum.noarch 0:3.2.28-14.fc15 (on F14)
Comment 1 A S Alam 2010-12-28 10:29:45 EST
Bug need to move 'yum' package and 'yum plugins'
Comment 2 A S Alam 2010-12-28 10:32:29 EST
Update version Fedora 14-> Fedora 15 [from package name]
cloning this bug for yum-langpacks' for translation

thanks for report
Comment 3 dominique 2010-12-28 11:32:13 EST
The problem is that yum-plugins (langpacks, presto or other) is not translate, and are not localized yet...
Comment 4 Kevin Raymond 2011-03-09 03:45:58 EST
still there in  F-15 Alpha RC2 up to date.
We have got it translated 100% in french, but I still read 
'<package> will be installé' (with "installé" the only word translated)
Comment 5 Kevin Raymond 2011-03-26 14:27:02 EDT
any work around yum to be able to translate it?
It is still not completely translatable, please update/complete the POT file.

The project is still there, right? http://www.transifex.net/projects/p/yum/resource/3-2-x-po-yum-pot/
Comment 6 dominique 2011-03-27 07:28:20 EDT
(In reply to comment #5)
> any work around yum to be able to translate it?
> It is still not completely translatable, please update/complete the POT file.
> 
> The project is still there, right?
> http://www.transifex.net/projects/p/yum/resource/3-2-x-po-yum-pot/

I agree this comment, yum for F15 (yum-3.2.29-4.fc15) is not all translatable.

But I think it's easy solve it, just do "make update-po" in po directory...

For test I do this, and I have 20 new entries and 27 fuzzy...
Comment 7 Kevin Raymond 2011-03-27 08:27:08 EDT
I've filled a ticket in the upstream trac.
[http://yum.baseurl.org/ticket/680 here it is]
Comment 8 Jens Petersen 2011-06-24 01:12:32 EDT
This appears to be fixed in yum-3.4.2 in F16 rawhide.
Comment 9 Jens Petersen 2012-02-23 21:23:27 EST
(In reply to comment #8)
> This appears to be fixed in yum-3.4.2 in F16 rawhide.

No it doesn't...

I think the problem for Japanese at least is that
translations need to be smarter for:

  "Package [...] will be [updated/installed]"
Comment 10 The Old Man 2012-03-08 10:09:53 EST
https://www.transifex.net/projects/p/yum/resources/  3-2-x-po/yum.pot

translated into Dutch worked very nice on F17 test day once i placed the yum.mo file there. 

Notice: I worked almost flawless (only some presto not translated) on the 3.4.3.18.fc17.noarch package

all former 'mixed language' sentences i had are gone.

grtz
Comment 11 dominique 2012-03-08 11:52:11 EST
(In reply to comment #10)
> https://www.transifex.net/projects/p/yum/resources/  3-2-x-po/yum.pot
> 
> translated into Dutch worked very nice on F17 test day once i placed the yum.mo
> file there. 
> 
> Notice: I worked almost flawless (only some presto not translated) on the
> 3.4.3.18.fc17.noarch package
> 
> all former 'mixed language' sentences i had are gone.
> 
> grtz
The yum-presto plugin is not internationalized yet, but I made a package with the french translation.
I post it here: https://bugzilla.redhat.com/show_bug.cgi?id=799500
You can add dutch translation in source and compile...

and, please, add you to CC list, I have no reply from the maintainer of this package...
Comment 12 Piotr Drąg 2012-04-03 12:55:57 EDT
Upstream yum maintainers seems to be handling translations quite well these days, so I'm closing this bug as fixed.

Translations can be updated here:

https://www.transifex.net/projects/p/yum/