Bug 680213

Summary: RFE: Rebase to 0.3.1 release to obtain SPICE support
Product: Red Hat Enterprise Linux 6 Reporter: Daniel Berrange <berrange>
Component: virt-viewerAssignee: Daniel Berrange <berrange>
Status: CLOSED ERRATA QA Contact: Virtualization Bugs <virt-bugs>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.1CC: dallan, degts, dyuan, mzhan, rwu, zpeng
Target Milestone: rcKeywords: FutureFeature, Rebase
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: virt-viewer-0.4.1-1.el6 Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-12-06 10:07:05 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 694694, 708417, 725454    
Bug Blocks: 693512    

Description Daniel Berrange 2011-02-24 12:10:26 EST
Description of problem:
Upstream virt-viewer now has the ability to connect to a guest's SPICE display, in addition to existing VNC support. This will be useful for people deploying RHEL guests using SPICE. Thus we should rebase to the 0.3.1 release of virt-viewer in RHEL-6.2

Version-Release number of selected component (if applicable):
0.2.3

How reproducible:
Always

Steps to Reproduce:
1. Attempt to use virt-viewer on a guest with spice graphics
2.
3.
  
Actual results:
No display

Expected results:
SPICE displayed

Additional info:
Comment 4 Daniel Berrange 2011-07-25 11:56:40 EDT
Spice support built into virt-viewer-0.4.0-2.el6
Comment 6 zhe peng 2011-07-26 02:39:07 EDT
Verify with:
spice-glib-0.6.2.el6.x86_64
spice-gtk-0.6.2.el6.x86_64
virt-viewer-0.4.0-2.el6.x86_64
spice-server-0.8.1-2.el6.x86_64


 1:install a guest with spice of display

 2:virsh dumpxml demo
.....
 <graphics type='spice' port='5900' tlsPort='-1' autoport='yes' listen='0.0.0.0'/>
.....

 3:virsh start demo

 4:ps -ef | grqemu     26223     1 73 02:36 ?        00:00:16 /usr/libexec/qemu-kvm -S -M rhel6.1.0 -cpu Conroe,+xtpr,+tm2,+est,+vmx,+ds_cpl,+monitor,+pbe,+tm,+ht,+ss,+acpi,+ds,+vme -enable-kvm -m 1024 -smp 1,sockets=1,cores=1,threads=1 -name demo -uuid 64ce24ae-bb33-8884-10bc-4b81c7cac4ca -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/demo.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -drive file=/var/lib/libvirt/images/demo.img,if=none,id=drive-virtio-disk0,format=raw -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -drive file=/dev/sda2,if=none,id=drive-ide0-0-0,format=raw -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=22,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:28:f9:e3,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -usb -spice port=5900,addr=0.0.0.0,disable-ticketing -vga cirrus -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x4
ep kvm

 5:use virt-viewer to client guest
   #virt-viewer demo
  the guest can be logged in by virt-viewer and displayed in graphic console.

Verification is passed.
Comment 13 zhe peng 2011-08-11 02:24:53 EDT
Daniel ,very thanks for your help,below is detail of my verification for multihead

verify SPICE multihead support with :
virt-viewer-0.4.1-1.el6
libvirt-0.9.4-2.el6
qemu-kvm-0.12.1.2-2.177.el6

Step:
  1:Install a new Windows XP guest
  2:Change the guest to use SPICE graphics and have a single QXL video card
  3:Boot the guest, and install the WHQL'd 'QXL' driver in Windows.
  4:Reboot the guest and check QXL is working properly
  5:Shutdown the guest
  6:Add another 'video' element to the guest XML
  #virsh dumpxml winxp
.......
 <graphics type='spice' port='5900' tlsPort='-1' autoport='yes' listen='0.0.0.0'>
      <listen type='address' address='0.0.0.0'/>
    </graphics>
    <video>
      <model type='qxl' vram='65536' heads='1'/>
      <alias name='video0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </video>
    <video>
      <model type='qxl' vram='65536' heads='1'/>
      <alias name='video1'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x0'/>
    </video>
.......
   7: Boot the guest again, and make sure Windows installs the QXL driver for the new graphics card
   8:in Windows XP guest,right click on the desktop,in "settings"->"Display",list two monitor on "Red Hat QXL GPU"
   9: select the second monitor,checked "Extend my Windows desktop onto this monitor" and apply.virt-viewer popup a new window.
  10: in virt-viewer menu,"view"->"Display" ,list two display,and it worked well.
  11:i use spice-client to connect the guest,behavior same with using virt-viewer.
Verification passed. move to verified.
Comment 16 errata-xmlrpc 2011-12-06 10:07:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1614.html