Bug 683872

Summary: [abrt] ekiga-3.3.0-6.fc15: operator[]: Process /usr/bin/ekiga was killed by signal 11 (SIGSEGV)
Product: [Fedora] Fedora Reporter: tuxor <tuxor1337>
Component: ekigaAssignee: Peter Robinson <pbrobinson>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: atigro, bugzilla, dbetz, hgkamath, ivan.mironov, matt, pbrobinson, pingou, rjones
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:aa7d8438d0569e505d0829c87d615ec8c43d1e57
Fixed In Version: ptlib-2.8.3-5.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-05-09 00:00:46 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 657621    
Attachments:
Description Flags
File: backtrace none

Description tuxor 2011-03-10 09:53:47 EST
abrt version: 1.1.17
architecture: x86_64
Attached file: backtrace, 11529 bytes
cmdline: ekiga
comment: fresh install of fedora 15 x86_64 \w gnome via netinst, was using gnome-shell when error occured
component: ekiga
Attached file: coredump, 3141632 bytes
crash_function: operator[]
executable: /usr/bin/ekiga
kernel: 2.6.38-0.rc6.git6.1.fc15.x86_64
package: ekiga-3.3.0-6.fc15
rating: 4
reason: Process /usr/bin/ekiga was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Lovelock)
time: 1299768637
uid: 500

How to reproduce
-----
1. install Ekiga via "yum install ekiga"
2. execute "ekiga" from a terminal 
3. it won't start at all, only the message "memory access error"
Comment 1 tuxor 2011-03-10 09:53:49 EST
Created attachment 483470 [details]
File: backtrace
Comment 2 tuxor 2011-03-14 12:44:06 EDT
Newest update to the boost-library makes install of ekiga impossible.

Package: ekiga-3.3.0-6.fc15.x86_64 (fedora)
            Requires: libboost_signals-mt.so.1.46.0()(64bit)
            Available: boost-signals-1.46.0-0.4.fc15.x86_64 (fedora)
                libboost_signals-mt.so.1.46.0()(64bit)
            Installiert: boost-signals-1.46.1-1.fc15.x86_64 (@updates-testing)
                Not found
Comment 3 Ganapathi Kamath 2011-03-16 12:40:58 EDT
Package: ekiga-3.3.0-6.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1. open a terminal
2. type ekiga, enter
3.
Comment 4 tuxor 2011-03-19 07:21:50 EDT
Maybe somebody could at least fix the broken dependencies? I can't even install ekiga at the moment!
Comment 5 Pierre-YvesChibon 2011-03-19 09:15:03 EDT
Package: ekiga-3.3.0-6.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1.yum update
2.start ekig
3.


Comment
-----
I just tried to start ekiga from a fully updated F15. It crashes with "Segmentation fault (core dumped)" as soon as I start it.
Comment 6 tuxor 2011-03-26 06:04:49 EDT
still dep-problems with package boost-signals.
nobody here to fix this?
Comment 7 Richard W.M. Jones 2011-03-31 09:16:46 EDT
Package: ekiga-3.3.0-6.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1. yum install ekiga
2. Typed 'ekiga' in the terminal
3. Segfault


Comment
-----
Nothing -- the program won't even start up.
Comment 8 Lucian Langa 2011-04-20 15:25:57 EDT
Package: ekiga-3.3.0-6.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Run ekiga from menu or terminal:
Segmentation fault (core dumped)
Comment 9 Robert Swain 2011-04-21 17:39:03 EDT
Package: ekiga-3.3.0-6.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Just trying to start Ekiga for the first time.
Comment 10 Peter Robinson 2011-05-03 12:26:00 EDT
*** Bug 699100 has been marked as a duplicate of this bug. ***
Comment 11 Peter Robinson 2011-05-03 13:13:22 EDT
investigating....
Comment 12 Peter Robinson 2011-05-03 13:32:00 EDT
$ gdb ekiga -d 4
GNU gdb (GDB) Fedora (7.2.90.20110429-36.fc15)
Copyright (C) 2011 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Warning: /home/peter/rpmbuild/SPECS/4: No such file or directory.
Reading symbols from /usr/bin/ekiga...Reading symbols from /usr/lib/debug/usr/bin/ekiga.debug...done.
done.
(gdb) run
Starting program: /usr/bin/ekiga 
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff6798ed1 in operator[] (__pos=0, this=0x0) at /usr/include/c++/4.6.0/ext/bitmap_allocator.h:128
128		{ return this->_M_start[__pos]; }
(gdb) debuginfo-install GConf2-2.32.3-1.fc15.x86_64 ORBit2-2.14.19-2.fc15.x86_64 SDL-1.2.14-11.fc15.x86_64 atk-2.0.0-1.fc15.x86_64 avahi-glib-0.6.30-2.fc15.x86_64 avahi-libs-0.6.30-2.fc15.x86_64 boost-signals-1.46.0-1.fc15.x86_64 cairo-1.10.2-3.fc15.x86_64 cyrus-sasl-lib-2.1.23-16.fc15.x86_64 dbus-glib-0.92-2.fc15.x86_64 dbus-libs-1.4.6-4.fc15.x86_64 expat-2.0.1-11.fc15.x86_64 fontconfig-2.8.0-3.fc15.x86_64 freetype-2.4.4-4.fc15.x86_64 gdk-pixbuf2-2.23.3-1.fc15.x86_64 glib2-2.28.6-2.fc15.x86_64 gtk2-2.24.4-1.fc15.x86_64 keyutils-libs-1.2-7.fc15.x86_64 krb5-libs-1.9-7.fc15.x86_64 libX11-1.4.3-1.fc15.x86_64 libXau-1.0.6-2.fc15.x86_64 libXcomposite-0.4.3-2.fc15.x86_64 libXcursor-1.1.11-3.fc15.x86_64 libXdamage-1.1.3-2.fc15.x86_64 libXext-1.2.0-2.fc15.x86_64 libXfixes-5.0-1.fc15.x86_64 libXi-1.4.2-1.fc15.x86_64 libXinerama-1.1.1-2.fc15.x86_64 libXrandr-1.3.1-2.fc15.x86_64 libXrender-0.9.6-2.fc15.x86_64 libXv-1.0.6-2.fc15.x86_64 libcom_err-1.41.14-2.fc15.x86_64 libgcc-4.6.0-6.fc15.x86_64 libnotify-0.7.2-1.fc15.x86_64 libpng-1.2.44-3.fc15.x86_64 libselinux-2.0.99-4.fc15.x86_64 libstdc++-4.6.0-6.fc15.x86_64 libxcb-1.7-2.fc15.x86_64 libxml2-2.7.8-6.fc15.x86_64 nspr-4.8.7-2.fc15.x86_64 nss-3.12.9-15.fc15.x86_64 nss-softokn-freebl-3.12.9-7.fc15.x86_64 nss-util-3.12.9-2.fc15.x86_64 openldap-2.4.24-2.fc15.x86_64 openssl-1.0.0d-1.fc15.x86_64 pango-1.28.4-1.fc15.x86_64 pixman-0.20.2-2.fc15.x86_64 speex-1.2-0.13.rc1.fc15.x86_64 zlib-1.2.5-3.fc15.x86_64^CQuit
(gdb) thread apply all bt full

Thread 1 (Thread 0x7ffff5514980 (LWP 30725)):
#0  0x00007ffff6798ed1 in operator[] (__pos=0, this=0x0) at /usr/include/c++/4.6.0/ext/bitmap_allocator.h:128
No locals.
#1  __gnu_cxx::__detail::_Bitmap_counter<__gnu_cxx::bitmap_allocator<PContainerReference>::_Alloc_block*>::_M_reset (this=0x7ffff6a99c60, __index=0)
    at /usr/include/c++/4.6.0/ext/bitmap_allocator.h:430
No locals.
#2  0x00007ffff6799758 in __gnu_cxx::bitmap_allocator<PContainerReference>::_M_allocate_single_object (this=0x7ffff6a99c18) at /usr/include/c++/4.6.0/ext/bitmap_allocator.h:883
        __fff = <optimized out>
        __bpi = <optimized out>
        __bit_lock = {_M_device = @0x7ffff6a99c20}
        __nz_bit = <optimized out>
        __ret = <optimized out>
        __puse_count = <optimized out>
#3  0x00007ffff679061b in PContainer::PContainer (this=0x7ffff6a93680, initialSize=1) at ptlib/common/contain.cxx:67
No locals.
#4  0x00007ffff67908f2 in PAbstractArray::PAbstractArray (this=0x7ffff6a93680, elementSizeInBytes=1, initialSize=<optimized out>) at ptlib/common/contain.cxx:165
No locals.
#5  0x00007ffff6793073 in PBaseArray (this=0x7ffff6a93680, initialSize=1) at /usr/src/debug/ptlib-2.8.3/include/ptlib/array.h:284
No locals.
#6  PCharArray (initialSize=1, this=0x7ffff6a93680) at /usr/src/debug/ptlib-2.8.3/include/ptlib/array.h:564
No locals.
#7  PString::PString (this=0x7ffff6a93680) at /usr/src/debug/ptlib-2.8.3/include/ptlib/contain.inl:57
No locals.
#8  0x00007ffff65d86bc in __static_initialization_and_destruction_0 (__priority=65535, __initialize_p=1) at ptclib/psasl.cxx:179
No locals.
#9  _GLOBAL__sub_I_psasl.cxx(void) () at ptclib/psasl.cxx:343
No locals.
#10 0x0000003e1ac0ea36 in call_init (l=<optimized out>, argc=1, argv=0x7fffffffe208, env=0x7fffffffe218) at dl-init.c:83
        j = <optimized out>
        jm = <optimized out>
        addrs = <optimized out>
        init_array = <optimized out>
#11 0x0000003e1ac0eb13 in call_init (env=<optimized out>, argv=<optimized out>, argc=<optimized out>, l=<optimized out>) at dl-init.c:50
No locals.
#12 _dl_init (main_map=0x3e1ae222a8, argc=1, argv=0x7fffffffe208, env=0x7fffffffe218) at dl-init.c:132
        preinit_array = <optimized out>
        preinit_array_size = <optimized out>
        i = <optimized out>
#13 0x0000003e1ac0163a in _dl_start_user () from /lib64/ld-linux-x86-64.so.2
No symbol table info available.
#14 0x0000000000000001 in ?? ()
No symbol table info available.
---Type <return> to continue, or q <return> to quit--- 
#15 0x00007fffffffe4f4 in ?? ()
No symbol table info available.
#16 0x0000000000000000 in ?? ()
No symbol table info available.
(gdb)
Comment 13 Peter Robinson 2011-05-03 13:32:19 EDT
That looks like a problem in ptlib
Comment 14 Peter Robinson 2011-05-03 15:20:17 EDT
*** Bug 701755 has been marked as a duplicate of this bug. ***
Comment 15 cgrim 2011-05-03 15:22:45 EDT
Package: ekiga-3.3.0-6.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Ekiga crashed immediately when starts.
Comment 16 Fedora Update System 2011-05-04 13:55:38 EDT
ptlib-2.8.3-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ptlib-2.8.3-5.fc15
Comment 17 Heiko Adams 2011-05-04 16:12:45 EDT
That update solved the problem for me
Comment 18 Fedora Update System 2011-05-05 00:41:59 EDT
Package ptlib-2.8.3-5.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ptlib-2.8.3-5.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/ptlib-2.8.3-5.fc15
then log in and leave karma (feedback).
Comment 19 Peter Robinson 2011-05-07 10:09:53 EDT
Adding as a NTH blocker for review. This fixes ekiga not starting on F-15.
Comment 20 Peter Robinson 2011-05-07 15:06:07 EDT
*** Bug 699163 has been marked as a duplicate of this bug. ***
Comment 21 Fedora Update System 2011-05-09 00:00:40 EDT
ptlib-2.8.3-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.