Bug 702354

Summary: /usr/include/netdb.h:33:24: fatal error: rpc/netdb.h: No such file or directory
Product: [Fedora] Fedora Reporter: Adam Tkac <atkac>
Component: glibcAssignee: Andreas Schwab <schwab>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: atu, bmillett, dvlasenk, fedora, fweimer, jakub, jjardon, john.ellson, kmaraas, meyering, M.Stoikov, ovasik, rjones, schwab, tgl, trustthesky, tshinnic, wlima
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: glibc-2.14-2 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-06-07 04:25:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Adam Tkac 2011-05-05 12:34:37 UTC
Description of problem:
Compilation of the bind package fails with "/usr/include/netdb.h:33:24: fatal error: rpc/netdb.h: No such file or directory" error. In my opinion rpc/netdb.h should be present of netdb.h shouldn't include it.

Version-Release number of selected component (if applicable):
glibc-2.13.90-10

How reproducible:
always

Steps to Reproduce:
1. fedpkg clone bind
2. cd bind
3. fedpkg build bind
  
Actual results:
Build fails

Expected results:
Successful compilation

Additional information:
glibc-2.13.90-9 is fine.

Comment 1 Andreas Schwab 2011-05-05 13:34:51 UTC
*** Bug 702366 has been marked as a duplicate of this bug. ***

Comment 2 Brian Millett 2011-05-05 14:03:43 UTC
The glibc-headers-2.13.90-10 changelog includes:

- Update from master
  - Obsolete RPC implementation in libc


I guess not!

Comment 3 Andreas Schwab 2011-05-05 14:04:45 UTC
*** Bug 702368 has been marked as a duplicate of this bug. ***

Comment 4 Tom Lane 2011-05-05 17:46:13 UTC
Same thing observed here:

$ cat test.c
#include <netdb.h>

int main() { return 0; }

$ gcc test.c
In file included from test.c:1:0:
/usr/include/netdb.h:33:24: fatal error: rpc/netdb.h: No such file or directory
compilation terminated.

This breaks my packages as well.

Comment 5 Thomas L. Shinnick 2011-05-05 23:55:17 UTC
Note apparent duplicate 
  https://bugzilla.redhat.com/show_bug.cgi?id=702510

"Me too"  building node.js : 

  deps/c-ares/ares_parse_txt_reply.c:27:0:
/usr/include/netdb.h:33:24: fatal error: rpc/netdb.h: No such file or directory
compilation terminated.

Worked in F14 ...

Comment 7 William Lima 2011-05-06 02:44:50 UTC
*** Bug 702510 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2011-05-06 11:44:03 UTC
glibc-2.13.90-11 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/glibc-2.13.90-11

Comment 9 John Ellson 2011-05-06 13:17:49 UTC
Thanks. The koji build of glibc-2.13.90-11 fixes the problems I was having building graphviz on fc15 i686 and x86_64 (reported in dup bug #702510)

Comment 10 Michael Stoykov 2011-05-06 13:33:56 UTC
works for me too for compiling https://github.com/media-explorer/media-explorer
10x and hope it will be pushed in testing soon :)

Comment 11 William Lima 2011-05-06 16:29:39 UTC
For those who tested glibc-2.13.90-11, please give it positive karma (current -6).

Comment 12 Fedora Update System 2011-05-07 15:05:37 UTC
Package glibc-2.13.90-11:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glibc-2.13.90-11'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/glibc-2.13.90-11
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2011-05-17 05:36:27 UTC
Package glibc-2.13.90-12:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glibc-2.13.90-12'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/glibc-2.13.90-12
then log in and leave karma (feedback).

Comment 14 Fedora Update System 2011-05-18 18:42:42 UTC
Package glibc-2.13.90-13:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glibc-2.13.90-13'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/glibc-2.13.90-13
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2011-05-27 20:24:40 UTC
Package glibc-2.13.90-14:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glibc-2.13.90-14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/glibc-2.13.90-14
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2011-06-02 19:08:41 UTC
Package glibc-2.14-1:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glibc-2.14-1'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/glibc-2.14-1
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2011-06-04 02:55:34 UTC
Package glibc-2.14-2:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glibc-2.14-2'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/glibc-2.14-2
then log in and leave karma (feedback).

Comment 18 Fedora Update System 2011-06-07 04:24:55 UTC
glibc-2.14-2 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.