Bug 707074

Summary: abrt dupe detection needs to ignore some parts of kernel traces.
Product: [Fedora] Fedora Reporter: Dave Jones <davej>
Component: abrtAssignee: Nikola Pajkovsky <npajkovs>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: anton, dhoward, dvlasenk, iprikryl, jmoskovc, kklic, mtoman, npajkovs, pfrields
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: abrt-2.0.3-1.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-06-24 03:24:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Dave Jones 2011-05-23 22:05:39 UTC
Compare bug 706780 with bug 704651
Both filed with abrt, but not marked as duplicates.
Possibly because one was tainted, the other wasn't ?
(if so, ignoring that part of the report would be fine).

Comment 1 Nikola Pajkovsky 2011-05-24 11:30:44 UTC
I'm going to write some improvements.

Comment 2 Nikola Pajkovsky 2011-05-31 08:39:34 UTC
commit 82c53df6074a4db8f2c5cb4e6b665c2e0881eb28
Merge: a2c4ca9 8f35082
Author: Nikola Pajkovsky <npajkovs@redhat.com>
Date:   Tue May 31 10:35:51 2011 +0200

    Merge branch 'oops/btparser'
    
    * oops/btparser:
      rhzb#707074 abrt dupe detection needs to ignore some parts of kernel traces

The basic idea is strip out only function from bactrace and take the first 6 function to calculate hash.

Comment 3 Dave Jones 2011-06-07 20:28:29 UTC
btw, a further improvement to the backtrace hashing would be to ignore the functions that are prefixed with a ?
I don't know if you do that already..

Comment 4 Nikola Pajkovsky 2011-06-08 09:06:14 UTC
I don't ignore those functions. Algorithm just skip that '?' mark. Nevertheless skip unreliable function name from backtrace is not bad idea.

Comment 5 Fedora Update System 2011-06-21 13:44:33 UTC
abrt-2.0.3-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.3-1.fc15

Comment 6 Fedora Update System 2011-06-21 23:55:29 UTC
Package abrt-2.0.3-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.3-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/abrt-2.0.3-1.fc15
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-06-24 03:22:28 UTC
abrt-2.0.3-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.