Bug 711573

Summary: Fedora 15 liveinst fails with a python error before opening
Product: [Fedora] Fedora Reporter: Scott Dowdle <dowdle>
Component: pypartedAssignee: David Cantrell <dcantrell>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 15CC: anaconda-maint-list, bcl, dcantrell, jbwillia, jonathan, msdeleonpeque, pbrobinson, sagarun, satellitgo, upgradeservices, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: pyparted-3.5-3.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-06-15 05:30:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Scott Dowdle 2011-06-07 19:23:46 UTC
Description of problem: If liveinst is run graphically it just fails with no error.  When run from the command line, the following error:

[liveuser@localhost ~]$ /usr/bin/liveinst
Traceback (most recent call last):
  File "/usr/bin/anaconda-cleanup", line 41, in <module>
    from pyanaconda.cmdline import InstallInterface
  File "/usr/lib/python2.7/site-packages/pyanaconda/cmdline.py", line 25, in
    import parted
  File "/usr/lib/python2.7/site-packages/parted/__init__.py", line 53, in
    from partition import Partition
  File "/usr/lib/python2.7/site-packages/parted/partition.py", line 249, in
    partitionFlag[__flag] = _ped.partition_flag_get_name(__flag)
ValueError: Invalid flag provided.
localuser:root being added to access control list
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 507, in <module>
    from pyanaconda import kickstart
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 21, in
    from storage.deviceaction import *
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line
31, in <module>
    import parted
  File "/usr/lib/python2.7/site-packages/parted/__init__.py", line 53, in
    from partition import Partition
  File "/usr/lib/python2.7/site-packages/parted/partition.py", line 249, in
    partitionFlag[__flag] = _ped.partition_flag_get_name(__flag)
ValueError: Invalid flag provided.

This is on a Fedora REMIX with the latest packages installed as of June 7, 2011.  The bug was first brought to my attention on the Fedora Remix mailing list:


I was able to verify that the bug still existed even with the updates of the day applied.

Version-Release number of selected component (if applicable):

anaconda has not been updated yet since the initial Fedora 15 release but a number of other components have... including the kernel.

I'm not sure what additional info would be helpful.  Ask and I will supply.

This was on a KVM virtual machine reusing an existing .img disk file that worked with tons of previous install testing.

Comment 1 Brian Lane 2011-06-07 20:00:10 UTC
This is because I updated parted w/o updating pyparted. It needs a patch from master cherry-picked to add the GPT legacy_boot flag support.

Comment 2 Brian Lane 2011-06-07 20:02:34 UTC
*** Bug 711557 has been marked as a duplicate of this bug. ***

Comment 3 Scott Dowdle 2011-06-07 20:53:42 UTC
Brian C. Lane,

Sounds like you know how to fix it so please do so when you have a chance.  The only additional thing I have to offer is a diff of two package lists... comparing the package lists of my last working build to my first broken build... and sure enough, parted is only the list.

< apr-1.4.2-3.fc15.i686
< apr-util-1.3.10-7.fc15.i686
> apr-1.4.5-1.fc15.i686
> apr-util-1.3.12-1.fc15.i686
< bind-libs-9.8.0-3.P1.fc15.i686
< bind-libs-lite-9.8.0-3.P1.fc15.i686
< bind-license-9.8.0-3.P1.fc15.noarch
< bind-utils-9.8.0-3.P1.fc15.i686
> bind-libs-9.8.0-5.P2.fc15.i686
> bind-libs-lite-9.8.0-5.P2.fc15.i686
> bind-license-9.8.0-5.P2.fc15.noarch
> bind-utils-9.8.0-5.P2.fc15.i686
< evolution-3.0.1-1.fc15.i686
< evolution-data-server-3.0.1-1.fc15.i686
> evolution-3.0.2-1.fc15.i686
> evolution-data-server-3.0.2-1.fc15.i686
< flash-plugin-
> flash-plugin-
< gnome-dvb-daemon-0.2.0-1.fc15.i686
> gnome-dvb-daemon-0.2.1-1.fc15.i686
< gnome-settings-daemon-3.0.1-4.fc15.i686
> gnome-settings-daemon-3.0.1-6.fc15.i686
< libcgroup-0.37.1-2.fc15.i686
> libcgroup-0.37.1-3.fc15.i686
< libtorrent-0.12.7-1.fc15.i686
> libtorrent-0.12.8-1.fc15.i686
< logrotate-3.7.9-8.fc15.i686
> logrotate-3.7.9-11.fc15.i686
< NetworkManager-0.8.999-3.git20110526.fc15.i686
< NetworkManager-glib-0.8.999-3.git20110526.fc15.i686
< NetworkManager-gnome-0.8.999-3.git20110526.fc15.i686
> NetworkManager-0.8.9997-1.git20110531.fc15.i686
> NetworkManager-glib-0.8.9997-1.git20110531.fc15.i686
> NetworkManager-gnome-0.8.9997-1.git20110531.fc15.i686
< parted-2.3-8.fc15.i686
> parted-2.3-9.fc15.i686
< rdesktop-1.6.0-11.fc15.i686
> rdesktop-1.6.0-12.fc15.i686
< rtorrent-0.8.7-6.fc15.i686
> rtorrent-0.8.8-1.fc15.i686
< selinux-policy-3.9.16-24.fc15.noarch
< selinux-policy-targeted-3.9.16-24.fc15.noarch
> selinux-policy-3.9.16-26.fc15.noarch
> selinux-policy-targeted-3.9.16-26.fc15.noarch
< setroubleshoot-3.0.31-1.fc15.i686
> setroubleshoot-3.0.35-1.fc15.i686
< setroubleshoot-server-3.0.31-1.fc15.i686
> setroubleshoot-server-3.0.35-1.fc15.i686
< shotwell-0.9.2-1.fc15.i686
> shotwell-0.9.3-1.fc15.i686
< sip-4.12.1-3.fc15.i686
> sip-4.12.1-5.fc15.i686
< Thunar-1.2.1-5.fc15.i686
> Thunar-1.2.2-1.fc15.i686
< xfce4-settings-4.8.1-4.fc15.i686
> xfce4-settings-4.8.2-1.fc15.i686
< xorg-x11-server-common-1.10.1-14.fc15.i686
> xorg-x11-server-common-1.10.2-1.fc15.i686
< xorg-x11-server-Xephyr-1.10.1-14.fc15.i686
< xorg-x11-server-Xorg-1.10.1-14.fc15.i686
> xorg-x11-server-Xephyr-1.10.2-1.fc15.i686
> xorg-x11-server-Xorg-1.10.2-1.fc15.i686

Comment 4 Ben Williams 2011-06-08 17:03:39 UTC
Scott if you please push the update, I produce updated livecd for the community having an updated livecds are saving alot of new users problems

Comment 5 Brian Lane 2011-06-08 17:21:10 UTC
You can work around this by not installing the latest f15 parted.

Comment 6 Scott Dowdle 2011-06-08 18:53:10 UTC
(In reply to comment #5)
> You can work around this by not installing the latest f15 parted.

Some of us remixers setup our own local mirrors but primarily just rsync from the stock Fedora repos.  Others of us use the stock Fedora repos remotely.  In both cases, once something is in the official repos, it is a bit of engineering to not use a current package and use an older one instead... but I'm sure I'm not telling you anything you don't already know.  Point taken.

Comment 7 Fedora Update System 2011-06-08 19:27:58 UTC
pyparted-3.5-3.fc15 has been submitted as an update for Fedora 15.

Comment 8 Fedora Update System 2011-06-10 13:28:36 UTC
Package pyparted-3.5-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pyparted-3.5-3.fc15'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).

Comment 9 satellitgo 2011-06-10 15:00:32 UTC
burned to CD and boots
Problems booting=
Boot line: (delete quiet)  selinux=0 and setenforce=0 safe mode boot: sed: can't read /etc/rc.d/init.d/halt: No such file or directory after started Network Manager  sees em1 NIC Link but NM does not see it-long pause-[211.798771] ---[ end trace..........]  cat5  unplug / replug sees it as up -no farther progress towards boot then starting sandbox and get boot  (5+ minutes) get gdm login 

liveinst f5 root:
installs  properly to 8 Gb USB "custom ext4 as /" no swap 
 "Congratulations your Generic installation is complete"
USB boots fine to firstboot  (no smolt profile shown (empty screen)
Generic release 16 (Generic) gdm login  Sugar starts and jabber works

Looks like  pyparted was updated in build

Comment 10 Arun S A G 2011-06-10 18:11:56 UTC
I tried to build a  livecd after updating to the latest version of pyparted (pyparted-3.5-3). 

I encountered the following bug:


Here is my kickstart file: 


Is it problem with my kickstart package selection or anaconda?

liveinst -C isn't working either.

Comment 11 Brian Lane 2011-06-13 17:16:27 UTC
*** Bug 712840 has been marked as a duplicate of this bug. ***

Comment 12 Peque 2011-06-14 01:37:58 UTC
Works with pyparted-3.5-3.fc15.

Thanks! :-D

Comment 13 Fedora Update System 2011-06-15 05:30:43 UTC
pyparted-3.5-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.