This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 752220

Summary: [abrt] libreoffice-core-3.4.3.2-15.fc16: crash on exit EventGuardAcquire
Product: [Fedora] Fedora Reporter: Matthew Casperson <mcaspers>
Component: libreofficeAssignee: Caolan McNamara <caolanm>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: andrey.arapov, caolanm, cbredesen, dtardon, erack, ibelkov, ltinkl, mstahl, redhat_bugzilla, sbergman
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Unspecified   
Whiteboard: abrt_hash:2fcba8e503de002b5e9849f568127f340e29eaaf
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-11-09 11:03:38 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: dso_list
none
File: maps
none
File: backtrace none

Description Matthew Casperson 2011-11-08 16:03:49 EST
libreport version: 2.0.6
abrt_version:   2.0.4.981
backtrace_rating: 4
cmdline:        /usr/lib/libreoffice/program/soffice.bin --writer --splash-pipe=7
comment:        Closed LibreOffice Writer after editing a reasonably large document
executable:     /usr/lib/libreoffice/program/soffice.bin
kernel:         3.1.0-5.fc16.i686.PAE
reason:         Process /usr/lib/libreoffice/program/soffice.bin was killed by signal 6 (SIGABRT)
time:           Tue Nov  8 08:46:27 2011
uid:            1000
username:       matthew
var_log_messages: Nov  8 08:46:29 localhost abrt[28264]: saved core dump of pid 27891 (/usr/lib/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2011-11-08-08:46:27-27891 (123977728 bytes)
xsession_errors: 

backtrace:      Text file, 70761 bytes
dso_list:       Text file, 24607 bytes
maps:           Text file, 57586 bytes

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=localhost.localdomain
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=27878
:GPG_AGENT_INFO=/tmp/keyring-DFhoEq/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=gnome-shell-1808-localhost.localdomain-libreoffice-26_TIME500660050
:HISTSIZE=1000
:XDG_SESSION_COOKIE=ff8224ae456744676a8ac38700000018-1320201321.460570-1857125753
:GJS_DEBUG_OUTPUT=stderr
:OLDPWD=/usr/lib/libreoffice/program
:GNOME_KEYRING_CONTROL=/tmp/keyring-DFhoEq
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:USER=matthew
:SSH_AUTH_SOCK=/tmp/keyring-DFhoEq/ssh
:USERNAME=matthew
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1608,unix/unix:/tmp/.ICE-unix/1608
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-writer.desktop
:MAIL=/var/spool/mail/matthew
:PATH=/usr/NX/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/matthew/.local/bin:/home/matthew/bin
:DESKTOP_SESSION=gnome
:NXDIR=/usr/NX
:QT_IM_MODULE=xim
:PWD=/home/matthew
:XMODIFIERS=@im=none
:KDE_IS_PRELINKED=1
:GNOME_KEYRING_PID=1604
:LANG=en_US.UTF-8
:KDEDIRS=/usr
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/matthew
:XDG_SEAT=seat0
:SHLVL=1
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=matthew
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-ihcPdbQPpC,guid=2fcfd862fa8f07477c015d9e00000036
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/matthew
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-matthew-6NH0qD/database
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib/i386/client:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib/i386/server:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib/i386/native_threads:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib/i386

smolt_data:
:
:
:General
:=================================
:UUID: 5ae180d1-36c9-40b2-8b88-86ace5a13ef7
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: i686
:BogoMIPS: 5985.42
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Pentium(R) D CPU 3.00GHz
:CPU Stepping: 4
:CPU Family: 15
:CPU Model Num: 6
:Number of CPUs: 2
:CPU Speed: 3000
:System Memory: 3531
:System Swap: 5567
:Vendor: Dell Inc.
:System: Dell DXP051 
:Form factor: Tower
:Kernel: 3.1.0-5.fc16.i686.PAE
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10186:4136:465) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #3
:(32902:4250:4136:465) pci, e1000e, ETHERNET, 82573L Gigabit Ethernet Controller
:(32902:10202:4136:465) pci, i801_smbus, SERIAL, N10/ICH 7 Family SMBus Controller
:(32902:10177:4136:465) pci, ahci, STORAGE, N10/ICH7 Family SATA AHCI Controller
:(32902:10192:0:0) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 1
:(32902:10160:0:0) pci, None, PCI/ISA, 82801GH (ICH7DH) LPC Interface Bridge
:(5361:12064:5361:8207) pci, None, SIMPLE, Dimension 3000
:(32902:10208:0:0) pci, pcieport, PCI/PCI, 82801GR/GH/GHM (ICH7 Family) PCI Express Port 5
:(32902:10210:0:0) pci, pcieport, PCI/PCI, 82801GR/GH/GHM (ICH7 Family) PCI Express Port 6
:(32902:10207:4136:465) pci, ata_piix, STORAGE, 82801G (ICH7 Family) IDE Controller
:(4098:43656:5963:43656) pci, snd_hda_intel, MULTIMEDIA, Barts HDMI Audio [Radeon HD 6800 Series]
:(32902:9294:0:0) pci, None, PCI/PCI, 82801 PCI Bridge
:(4098:26424:5963:5963) pci, radeon, VIDEO, Barts XT [ATI Radeon HD 6800 Series]
:(32902:10185:4136:465) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #2
:(32902:10184:4136:465) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #1
:(32902:10096:4136:465) pci, None, HOST/PCI, 82945G/GZ/P/PL Memory Controller Hub
:(32902:10200:4136:465) pci, snd_hda_intel, MULTIMEDIA, N10/ICH 7 Family High Definition Audio Controller
:(32902:10187:4136:465) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #4
:(32902:10188:4136:465) pci, ehci_hcd, USB, N10/ICH 7 Family USB2 EHCI Controller
:(32902:10097:32902:0) pci, pcieport, PCI/PCI, 82945G/GZ/P/PL PCI Express Root Port
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/VolGroup-lv_root / ext4 4096 4096 12901535 11134454 10479094 3276800 3027362 3027362
:/dev/sda2 /boot ext4 1024 1024 495844 417659 392059 128016 127791 127791
:/dev/mapper/VolGroup-lv_home /home ext4 4096 4096 45639215 38349445 36031109 11591680 11426107 11426107
:
Comment 1 Matthew Casperson 2011-11-08 16:03:58 EST
Created attachment 532382 [details]
File: dso_list
Comment 2 Matthew Casperson 2011-11-08 16:04:01 EST
Created attachment 532383 [details]
File: maps
Comment 3 Matthew Casperson 2011-11-08 16:04:04 EST
Created attachment 532384 [details]
File: backtrace
Comment 4 David Tardon 2011-11-09 07:19:04 EST
Well, we do

void X11SalData::DeleteDisplay()
{
    delete m_pSalDisplay;
    m_pSalDisplay       = NULL;
    delete pXLib_;
    pXLib_              = NULL;
}  

, so when GtkXLib::~GtkXLib() tries to consume all remaining events (by calling Yield(true, true)) the display has already been destroyed :( Luckily this is only a problem if there are any events.

This should be fixed in 3.5 by refactoring the gtk plugin.
Comment 5 Caolan McNamara 2011-11-09 11:03:38 EST
Hopefully sufficiently rare we can live with this, without bodging in a backport.
Comment 6 Caolan McNamara 2011-12-19 16:49:23 EST
*** Bug 769081 has been marked as a duplicate of this bug. ***
Comment 7 David Tardon 2012-01-09 06:37:48 EST
*** Bug 759086 has been marked as a duplicate of this bug. ***
Comment 8 David Tardon 2012-01-09 06:39:44 EST
will be fixed in 3.4.5
Comment 9 Stephan Bergmann 2012-01-11 07:31:08 EST
*** Bug 758045 has been marked as a duplicate of this bug. ***