Bug 804435

Summary: RFE: please put the vegas plugin into a separate subpackage to avoid conflicts with the original Adobe flashplayer
Product: [Fedora] Fedora Reporter: Michal Ambroz <rebus>
Component: totemAssignee: Bastien Nocera <bnocera>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: aaltemara, adel.gadllah, awilliam, bnocera, bruno, corcodel.marian, hdegoede, idirectscm, jik, jjardon, joshua, kalevlember, kparal, mishu, stijn, tflink
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedNTH
Fixed In Version: totem-3.4.1-3.fc17 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-05-15 23:16:08 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 752653    
Attachments:
Description Flags
Split off vegas none

Description Michal Ambroz 2012-03-18 15:15:11 EDT
Description of problem:
The library /usr/lib64/mozilla/plugins/libtotem-vegas-plugin.so from totem-mozplugin registers with the same name and version as the original flash plugin. 
Not only that it doesn't work for example for playing youtube video, but it also knocks-out the original Adobe Flash plugin if it is installed.

I believe that there should be some clear way how to recognize this "Shockwave Flash" is actually not a "Shockwave", but Totem Vegas.

Also only way how to disable is to uninstall the totem-mozplugin, which removes other useful plugins as well.


Version-Release number of selected component (if applicable):
totem-mozplugin.x86_64 1:3.3.90-2.fc17  

How reproducible:
100%

Steps to Reproduce:
1. Install firefox
2. Install totem-mozplugin
3. Install original adobe flash from http://get.adobe.com/flashplayer/
  
Actual results:
Flash objects will not work. For example youtube videos.

Expected results:
Flash objects should be using original flash plugin from adobe if it is installed


Additional info:
workaround to make Flash plugin working in Fedora 17 Alpha is to remove the totem-mozplugin
rpm -e totem-mozplugin
Comment 1 Hans de Goede 2012-04-03 03:55:16 EDT
I've been hitting this problem too, and the answer to me seems easy, since the totem vegas plugin conflicts with the original flash plugin and some people want to use the original flash plugin, while using the other totem plugins for for example mms streams, the vegas plugin should be in its own package. I've updated $summary to reflect this.

For other people reading along bug 806605 has an interesting workaround, mkdir /etc/totem and place the file from attachment 574375 [details] there.
Comment 2 Hans de Goede 2012-04-03 03:55:32 EDT
*** Bug 806605 has been marked as a duplicate of this bug. ***
Comment 3 Stijn Hoop 2012-04-09 16:42:13 EDT
FWIW this was one of the first things that I hit on F17 Beta RC3. I don't think breaking flash by default is a good thing to do, even though I understand that it is not supported. Please split off the vegas plugin until it is a ready replacement.
Comment 4 Anthony Altemara 2012-04-11 21:39:33 EDT
As a workaround, I have gone into google chrome, about:plugins and disabled:

Name:	Shockwave Flash
Version:	11.1 r102
Location:	/usr/lib64/mozilla/plugins/libtotem-vegas-plugin.so


and gone into Firefox and disabled one of the Shockwave Flash plugins. Strangely, firefox is reporting both plugins at the same version, so I had to use trial-and-error to ensure I disabled the correct Shockwave plugin.

After I disabled them, flash works.
Comment 5 Adel Gadllah 2012-05-06 05:04:50 EDT
Created attachment 582406 [details]
Split off vegas

Here is a patch to split it off.

Want/need an ACK from Bastien before pushing it.
Comment 6 Michael Schwendt 2012-05-07 09:23:22 EDT
*** Bug 819176 has been marked as a duplicate of this bug. ***
Comment 7 Michael Schwendt 2012-05-07 09:23:33 EDT
*** Bug 812203 has been marked as a duplicate of this bug. ***
Comment 8 Jonathan Kamens 2012-05-07 10:37:52 EDT
This is a serious issue. Can we bump the priority please? The totem flash plugin CANNOT DISPLAY EVERYTHING THAT THE ADOBE FLASH PLUGIN CAN. I encountered a flash game, for example, that simply wouldn't work in the totem plugin. Shipping a plugin that is going to override another plugin that works properly, and that is unable to do everything that other plugin can actually do, seems like a pretty darn good way to anger and frustrate users and damage the Fedora user experience.
Comment 9 Fedora Update System 2012-05-08 09:11:11 EDT
totem-3.4.1-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/totem-3.4.1-3.fc17
Comment 10 Fedora Update System 2012-05-09 12:09:43 EDT
Package totem-3.4.1-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing totem-3.4.1-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7503/totem-3.4.1-3.fc17
then log in and leave karma (feedback).
Comment 11 joshua 2012-05-11 16:48:02 EDT
Doesn't fix this issue for me
Comment 12 Hans de Goede 2012-05-12 04:04:57 EDT
(In reply to comment #11)
> Doesn't fix this issue for me

That is weird:

[hans@localhost ~]$ rpm -ql totem-mozplugin
totem-mozplugin-3.4.1-3.fc17.x86_64
/usr/lib64/mozilla/plugins/libtotem-cone-plugin.so
/usr/lib64/mozilla/plugins/libtotem-gmp-plugin.so
/usr/lib64/mozilla/plugins/libtotem-mully-plugin.so
/usr/lib64/mozilla/plugins/libtotem-narrowspace-plugin.so
/usr/libexec/totem-plugin-viewer
/usr/share/totem/mozilla-viewer.css
/usr/share/totem/mozilla-viewer.ui

No more vegas plugin, and:
http://koji.fedoraproject.org/koji/buildinfo?buildID=317958

Shows a separate totem-mozplugin-vegas package. Did you perhaps accidentally install the new -vegas package?
Comment 13 Bruno Wolff III 2012-05-13 09:24:25 EDT
-1 NTH as this can be fixed with an update and there is only a small effect on live images.
Comment 14 Kalev Lember 2012-05-13 14:07:50 EDT
+1 NTH, I'd rather have this included in the base repo to avoid changing user experience (removing flash video support) with a 0-day update.
Comment 15 Kamil Páral 2012-05-14 12:40:00 EDT
Actually LiveCDs benefit from the old totem, because you can play YouTube from them. But I still think +1 NTH is proper due to the reasons stated in comment 14. Flash plugin will be installed by lots of Fedora users, maybe even sooner then doing a system update. There might be a lot of confusion and unneeded bug reports when Flash doesn't work at all. Other users might be thrilled YouTube works without flash, until they update their system and it's gone. This update seems pretty safe and should not break anything.
Comment 16 joshua 2012-05-14 13:28:13 EDT
(In reply to comment #12)

You're right, I was using totem-mozplugin-3.4.1-2.fc17.x86_64, not totem-mozplugin-3.4.1-3.fc17.x86_64.

Fixed now.
Comment 17 Tim Flink 2012-05-14 14:22:18 EDT
+1 NTH to keep behaviour consistent between initial install and post-update.
Comment 18 Adel Gadllah 2012-05-14 15:46:16 EDT
(In reply to comment #15)
> Actually LiveCDs benefit from the old totem, because you can play YouTube from
> them. 

Not without installing gstreamer codecs .. OTOH with the new totem youtube will fallback to HTML5+webm for most (newer) videos so the new totem will get you youtube while the old will not ;)
Comment 19 Adam Williamson 2012-05-14 22:34:53 EDT
+1 NTH, change is pretty isolated and safe and has a good result. That makes it accepted.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 20 Fedora Update System 2012-05-15 23:16:08 EDT
totem-3.4.1-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.