Bug 80507

Summary: gnome-sound-recorder hangs
Product: [Retired] Red Hat Linux Reporter: Marius Andreiana <marius.andreiana>
Component: gnome-mediaAssignee: Colin Walters <walters>
Status: CLOSED DUPLICATE QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: adamallen, adam, dparsavand, elwoo, srevivo, wtogami
Target Milestone: ---Keywords: MoveUpstream, Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 13:50:37 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 79579, 100644    

Description Marius Andreiana 2002-12-27 09:43:26 EST
Press Record on toolbar.
Now Play is enabled and Stop is disabled ( should be the other way ).

After trying another action the application frozens.
Comment 1 Warren Togami 2002-12-27 19:49:05 EST
What sound card is this?  What kernel module?

Does recording work in any other application?
Comment 2 Marius Andreiana 2002-12-29 07:54:11 EST
soundcard: Creative 128 PCI.

I haven't tried other applications, but 
cat /dev/dsp > test.raw 
and
cat test.raw > /dev/dsp
works.

I couldn't record with gnome-sound-recorder in gnome 2.0 too, but I hoped
gstreamer will fix the problem.
Comment 3 Havoc Pennington 2003-01-12 21:47:09 EST
Upstream as http://bugzilla.gnome.org/show_bug.cgi?id=103279
Comment 4 Havoc Pennington 2003-01-19 10:54:39 EST
*** Bug 82036 has been marked as a duplicate of this bug. ***
Comment 5 Havoc Pennington 2003-01-19 11:15:50 EST
Reopening for tracking.
Comment 6 Elton Woo 2003-02-08 19:04:29 EST
Sound card: Creative Labs Ensoniq 64 (ES1371), [Audio PCI-97, Rev. 08] PCI card.
I know the card is woking. If I connect my portable SW/AM/FM radio from its earphone
plug to either 'line-in" or "mic-in", I get sound through my speakers. However,
starting
"record" the slider *DOESN'T* move, though the application says: " recording"....

File Information reports a file size, but when I select "save as" the sound
recorder hangs
with the mouse hourglass pointer ...OR  I get an "untitled.wav file of 0 bytes.
 I've also
tried recording with two different stereo microphones (one from an old recordable 
Sony Walkman, and the other from a recordable Aiwa portable cassette 'walkman').
Perhaps I need a self-powered microphone?

Given that I can hear sounds through my speakers when the recording source is my
radio, shouldn't that create  / save a sound file?
Comment 7 Colin Walters 2004-07-26 13:34:14 EDT
I can reproduce this too.  I'm going to go ahead and consolidate this
with bug 100774, the general "gnome-sound-recorder is still busted" bug.

This bug was originally opened against RH9 - could people try against
the FC2 version, and followup to 100774?

*** This bug has been marked as a duplicate of 100774 ***
Comment 8 Red Hat Bugzilla 2006-02-21 13:50:37 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.