This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 100774 - gnome-sound-recorder doesn't work
gnome-sound-recorder doesn't work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Colin Walters
: Triaged
: 80507 103191 115105 120710 120752 121937 130617 132555 (view as bug list)
Depends On:
Blocks: CambridgeTarget 106104
  Show dependency treegraph
 
Reported: 2003-07-25 03:41 EDT by petrosyan
Modified: 2007-11-30 17:10 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-15 22:47:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome-sound-recorder crash strace (188.25 KB, text/plain)
2004-04-04 21:21 EDT, petrosyan
no flags Details

  None (edit)
Description petrosyan 2003-07-25 03:41:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
gnome-sound-recorder does not work.
when I press the record button nothing happens.


Version-Release number of selected component (if applicable):
gnome-media-2.2.1.1-5

How reproducible:
Always

Steps to Reproduce:
1. start gnome-sound-recorder
2. press the record button
Comment 1 Bill Nottingham 2003-07-28 16:47:58 EDT
What sort of sound card do you have?
Comment 2 petrosyan 2003-07-28 17:08:18 EDT
it is a standard IBM Thinkpad T20 . here is a message from dmesg.

Crystal 4280/46xx + AC97 Audio, version 1.28.32, 06:10:42 Jul 11 2003
cs46xx: Card found at 0xe8122000 and 0xe8000000, IRQ 11
cs46xx: Thinkpad 600X/A20/T20 (1014:0153) at 0xe8122000/0xe8000000, IRQ 11
ac97_codec: AC97 Audio codec, id: CRY20 (Cirrus Logic CS4297A rev B)
Comment 3 petrosyan 2003-07-28 17:11:13 EDT
it used to work in previos Red Hat releases
Comment 4 Steve Seremeth 2003-11-14 08:30:00 EST
Doesn't work for me either.  It acts like it's recording, but I get
nothing.  And it also crashes occasionally while I'm testing - like
when trying to re-record nothing.  :)

I have audio on the motherboard - the chipset is VIA 8235 which is AC
97 compatable.  Listening is fine - recording does not work. 
Gnomemeeting tells me that my driver doesn't support full duplex.

I tried uninstalling a whole bunch of the default Fedora audio
software in hopes of getting alsa working, but I'm finding the
dependencies to be far and wide.

Hopefully this will get resolved soon.

Thanks.

P.S.  Microphone works fine - I've used it under windows xp without
incident.  Feel free to contact me if you need me to test something.
Comment 5 Steve Seremeth 2003-11-15 14:25:31 EST
I take it back.  After I was able to install the alsa driver it
started working.

Cool.

Steve
Comment 6 Tim Wunder 2003-11-29 09:11:19 EST
I cannot save wavs recorded by gnome-sound-recorder without getting a
segfault. Occasionally, the wavs are usable, but not if they're of any
size (more than 20 or 30 seconds). If the wav file would've been of
any size (say 2 minutes worth), opening the resulting wav causes a
segfault in gnome-sound-recorder. I also get the occasional segfault
during recording.

This is a backtrace that resulted from the crash after trying to open
a file saved by gnome-sound-recorder that should've been 2 minutes (or
o) of audio (g-s-r crashed during the save process):
(no debugging symbols found)...0x00409c32 in _dl_sysinfo_int80 ()
   from /lib/ld-linux.so.2
#0  0x00409c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00ae9a03 in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#2  0x00a3a7f4 in libgnomeui_module_info_get () from
/usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x0067d51a in ?? () from /usr/lib/gstreamer-0.6/libgstflxdec.so
#5  0x09cf2e80 in ?? ()
#6  0x09c857f8 in ?? ()
#7  0x00000001 in ?? ()
#8  0x00640b10 in ?? () from /usr/lib/libgstreamer-0.6.so.0
#9  0x09cb36f0 in ?? ()
#10 0x00640b10 in ?? () from /usr/lib/libgstreamer-0.6.so.0
#11 0xbffbff14 in ?? ()
#12 0x0061b6a0 in gst_xml_registry_new () from
/usr/lib/libgstreamer-0.6.so.0

$ rpm -qf /lib/ld-linux.so.2
glibc-2.3.2-101.1

$ rpm -qf /usr/lib/libgstreamer-0.6.so.0
gstreamer-0.6.3-1

Additionally, I cannot play any .wav files more than once (regardless
of their source). Running the app from the command line shows the
following:
GStreamer-WARNING **: abnormal clock request diff: ABS(283862456802) >
2000000000
Similar messages are repeated many times

Sound card is a Sound Blaster Live using emu10k1. g-s-r worked fine
using RHL 8.0.

Here's a bt from a segfault during recording:
(gdb) bt
#0  0x001d2c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x0066138e in pthread_cond_wait@@GLIBC_2.3.2 () from
/lib/tls/libpthread.so.0
#2  0x00cfbf4a in gst_thread_new () from /usr/lib/libgstreamer-0.6.so.0
#3  0x00cdfc51 in gst_element_set_state () from
/usr/lib/libgstreamer-0.6.so.0
#4  0x006c1998 in bonobo_socket_add_id () from /usr/lib/libbonoboui-2.so.0
#5  0x00e6acb0 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#6  0x001abb64 in bonobo_closure_invoke_va_list () from
/usr/lib/libbonobo-2.so.0
#7  0x001abdd7 in bonobo_closure_invoke () from /usr/lib/libbonobo-2.so.0
#8  0xbff195d0 in ?? ()
#9  0xbff1962c in ?? ()
Comment 7 petrosyan 2004-04-04 21:21:30 EDT
Created attachment 99104 [details]
gnome-sound-recorder crash strace

the latest gnome-sound-recorder crash strace log file
Comment 8 Jones Lee 2004-04-12 08:44:35 EDT
I got SB Live! 5.1 and it crashed with me as well. I think there must
be some conflict b/w OSS and ALSA.
Comment 9 Jerone Young 2004-04-14 20:20:20 EDT
I looks like this is very related to the "gsteamer-properties"
problem. If you try to run the test and the Input is ALSA the app will
crash. But if I change it to OSS..when I do the test I just hear
static...also after switching this to OSS I launch 
gnome-sound-recorder and it doesn't crash...but it doesn't record
anything either.
Comment 10 Ron Jenkins 2004-05-20 12:29:08 EDT
My Dell C600 laptop with a clean install has the issue where you hit
record and it just stares at you.
Comment 11 petrosyan 2004-05-20 13:42:05 EDT
it stopped crashing for me, too.
now it just does nothing when you click on the record button.
Comment 12 Will Backman 2004-06-01 09:46:08 EDT
gnome-media-2.6.0-1
I get a seg fault when I hit the record button, default settings.

alias snd-card-0 snd-ens1371
Comment 13 Gerry Tool 2004-06-08 20:25:26 EDT
I open Gnome Sound Recorder and click on the Record button.  I hear a
system sound indicating the button was clicked, but the button stays
red and nothing else happens.  This works on my system in an FC1
install, but did not work in FC2T3 nor does it work in final FC2 from
a fresh install. My sound card is onboard C-Media CM8738.  It plays
gnome system sounds fine, plays .ogg files fine and plays the test
sound in the Soundcard Detection applet.  Sounds work fine playing
DVDs in Totem.
Comment 14 Teppo Turtiainen 2004-06-10 14:31:56 EDT
Same thing here too. Pressing Record does nothing. Sound card is
onboard Realtek ALC650.
Comment 15 Michael Katzmann 2004-07-04 15:27:26 EDT
I get the same behaviour with ALSA on FC 2.
I have a Intel onboard sound system and also a USB (webcam) mic. The mic
works fine on gnome meeting.
Comment 16 Dick Mobbis 2004-07-22 09:16:39 EDT
Doesn't work for me either. 

I have SBLive!5.1.  Listening is fine - recording does not work. 

I tried gnome-alsamixer, all sliders are up, but nothing happens -
gnome-soundrecorder crashes, apps record silence.

I'm new to Linux - please help me. I can't use VoIP in Linux!

Thanks.

P.S.  Microphone works fine - I've used it under Windows XP.  Feel
free to contact me if you need me to test something.

dickmobbis @nospam@ bigmir.net
Comment 17 Colin Walters 2004-07-23 16:55:01 EDT
For the people experiencing crashes - can you please get a backtrace?
See: http://bugzilla.gnome.org/getting-traces.cgi

For the people just getting silence: Can you try going to Sound and
Video->Volume Control, and turning the volume on "Mic" and "Capture"
all the way up?
Comment 18 Colin Walters 2004-07-26 13:25:54 EDT
*** Bug 120710 has been marked as a duplicate of this bug. ***
Comment 19 Colin Walters 2004-07-26 13:34:19 EDT
*** Bug 80507 has been marked as a duplicate of this bug. ***
Comment 20 Colin Walters 2004-07-26 13:42:08 EDT
*** Bug 103191 has been marked as a duplicate of this bug. ***
Comment 21 Colin Walters 2004-07-26 13:43:46 EDT
*** Bug 115105 has been marked as a duplicate of this bug. ***
Comment 22 Colin Walters 2004-07-27 11:32:45 EDT
*** Bug 121937 has been marked as a duplicate of this bug. ***
Comment 23 Colin Walters 2004-07-27 17:21:37 EDT
*** Bug 120752 has been marked as a duplicate of this bug. ***
Comment 24 Rodrigo Vieira Couto 2004-08-03 22:47:20 EDT
I got the same problem on a snd-trident.

Here is the backtrace (guess gnome-sound-recorder wasn't compiled with
-g):

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 17718192 (LWP 3763)]
0x002e8f74 in _int_malloc () from /lib/tls/libc.so.6
(gdb) backtrace
#0  0x002e8f74 in _int_malloc () from /lib/tls/libc.so.6
#1  0x002e809d in malloc () from /lib/tls/libc.so.6
#2  0x00606527 in g_malloc () from /usr/lib/libglib-2.0.so.0
#3  0x025373ec in gst_buffer_new_and_alloc () from
/usr/lib/libgstreamer-0.8.so.1
#4  0x00200e1a in gst_audio_convert_get_type () from
/usr/lib/gstreamer-0.8/libgstaudioconvert.so
#5  0x002018e1 in gst_audio_convert_get_type () from
/usr/lib/gstreamer-0.8/libgstaudioconvert.so
#6  0x001ffcc8 in gst_audio_convert_get_type () from
/usr/lib/gstreamer-0.8/libgstaudioconvert.so
#7  0x0017c370 in ?? () from /usr/lib/gstreamer-0.8/libgstoptscheduler.so
#8  0x08386a08 in ?? ()
#9  0x0837734c in ?? ()
#10 0x00000001 in ?? ()
#11 0x02628088 in ?? () from /usr/lib/libgstreamer-0.8.so.1
#12 0x084b1aa8 in ?? ()
#13 0x02628088 in ?? () from /usr/lib/libgstreamer-0.8.so.1
#14 0x010e53f8 in ?? ()
#15 0x02556b08 in gst_pad_push () from /usr/lib/libgstreamer-0.8.so.1
Previous frame identical to this frame (corrupt stack?)
Comment 25 Phil Barnes 2004-08-10 18:05:39 EDT
Running Fedora Core 2.
gnome-media-2.6.0-1
I can record and playback. When I save the file, either using 'save'
or 'save as', no file is created and the title remains as
Untitled.flac/ogg/wav.
Comment 26 petrosyan 2004-08-11 17:30:31 EDT
Here is a backtrace on an IBM Thinkpad X40:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -150941568 (LWP 3017)]
gst_opt_scheduler_get_wrapper (srcpad=0x99701a8) at
gstoptimalscheduler.c:1372
1372      osched = group->chain->sched;
(gdb) thread apply all bt
Thread 2 (Thread 18455472 (LWP 3020)):
#0  0x004af402 in ?? ()
#1  0x00618790 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/libpthread.so.0
#2  0x07eefafe in gst_thread_main_loop (arg=0xfffffffc) at gstthread.c:599
#3  0x0056dc4d in g_static_private_free () from /usr/lib/libglib-2.0.so.0
#4  0x0061598c in start_thread () from /lib/tls/libpthread.so.0
#5  0x003b516a in clone () from /lib/tls/libc.so.6
 
Thread 1 (Thread -150941568 (LWP 3017)):
#0  gst_opt_scheduler_get_wrapper (srcpad=0x99701a8)
    at gstoptimalscheduler.c:1372
#1  0x07eda613 in gst_pad_pull (pad=0x97d0700) at gstpad.c:3224
#2  0x00f95220 in gst_spider_identity_dumb_loop (ident=0x97d0350)
    at gstspideridentity.c:435
#3  0x004c0ec6 in loop_group_schedule_function (argc=0, argv=0x97d0bc8)
    at gstoptimalscheduler.c:1278
#4  0x004c0892 in schedule_group (group=0x97d0bc8)
    at gstoptimalscheduler.c:1114
#5  0x004c0956 in gst_opt_scheduler_schedule_run_queue (osched=0x9883bf0)
    at gstoptimalscheduler.c:1157
#6  0x004c1491 in gst_opt_scheduler_get_wrapper (srcpad=0x97d09c0)
    at gstoptimalscheduler.c:1390
#7  0x07eda613 in gst_pad_pull (pad=0x9891130) at gstpad.c:3224
#8  0x004f5ca4 in gst_alsa_sink_get_type ()
   from /usr/lib/gstreamer-0.8/libgstalsa.so
#9  0x004c0ec6 in loop_group_schedule_function (argc=0, argv=0x9892790)
    at gstoptimalscheduler.c:1278
#10 0x004c0892 in schedule_group (group=0x97d1120)
    at gstoptimalscheduler.c:1114
#11 0x004c0956 in gst_opt_scheduler_schedule_run_queue (osched=0x9883bf0)
    at gstoptimalscheduler.c:1157
#12 0x004c0baa in schedule_chain (chain=0x97d1498)
    at gstoptimalscheduler.c:1205
#13 0x004c3f19 in gst_opt_scheduler_iterate (sched=0x9883bf0)
    at gstoptimalscheduler.c:2384
#14 0x07ee5d89 in gst_scheduler_iterate (sched=0x9883bf0) at
gstscheduler.c:695
#15 0x07eb81f8 in gst_bin_iterate_func (bin=0x98831f0) at gstbin.c:1121
#16 0x07efc709 in gst_marshal_BOOLEAN__VOID (closure=0x97bd6e8,
    return_value=0xfeea1580, n_param_values=1, param_values=0x99659e8,
    invocation_hint=0xfeea15a8, marshal_data=0x7eb8170) at
gstmarshal.c:433
#17 0x005b74f7 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#18 0x005b7160 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#19 0x005cabc5 in g_signal_emit_by_name () from
/usr/lib/libgobject-2.0.so.0
#20 0x005c9f2e in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#21 0x005ca454 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#22 0x07eb83eb in gst_bin_iterate (bin=0x98831f0) at gstbin.c:1174
#23 0x0804e3f3 in play_iterate (window=0x9846dd8) at gsr-window.c:1196
#24 0x005561f3 in g_child_watch_add () from /usr/lib/libglib-2.0.so.0
#25 0x00552e4a in g_main_depth () from /usr/lib/libglib-2.0.so.0
#26 0x00553f28 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#27 0x00554260 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#28 0x005548a3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#29 0x00911403 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#30 0x0804ba4d in main (argc=5000272, argv=0x4c4c50) at
gnome-recorder.c:205

using Fedora Core 2 with all the updates and debuginfo packages.
gstreamer-0.8.3-2
gstreamer-plugins-0.8.2-2.1
Comment 27 A. Ben Hmeda 2004-08-14 12:50:47 EDT
Cannot record sound although it plays fine. Has not been an issue with
2.4 series kernels, only after upgrading from RH9 to FC2 The soundcard
is SB128 ALSA installed, using Audacity/Gnome-Sound recorder and
gnusound, no crashes, modprobe.conf below

alias snd-card-0 snd-ens1370
install snd-ens1370 /sbin/modprobe --ignore-install snd-ens1370 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-ens1370 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-ens1370
Comment 28 Eric Smith 2004-08-22 16:41:31 EDT
I have the same problem described by Phil Barnes above.  The actual
recording process is fine, and the recorded file can be seen in /tmp
(e.g., /tmp/gsr-record-Untitled-12893.5EQjWV), but "Save" and "Save
As" don't work.  However, this is almost certainly not related to the
main bug reported here, so I've opened a new bug #130617.

Please do not close #130617 as a duplicate of #100774 unless it can be
determined to be the same problem, which is unlikely.  Bug #100774 is
described as nothing happening when record is pressed, which is NOT
what happens in #130617.
Comment 29 petrosyan 2004-08-23 00:27:49 EDT
after upgrading to gstreamer-0.8.5-1 from rawhide, this bug seems to
have gotten fixed. 

if people can confirm this I will close this bug.
Comment 30 Gerry Tool 2004-08-25 21:21:43 EDT
I upgraded my FC2 to gstreamer-0.8.5-1 from rawhide, and the behaviour
is different.  Pressing record now "appears to record".  If I try to
save the file, it acts as though it is saving it, but it does not
create the file.
Comment 31 petrosyan 2004-08-30 20:27:01 EDT
it creates the file for me.
Comment 32 Colin Walters 2004-09-16 13:55:24 EDT
*** Bug 132555 has been marked as a duplicate of this bug. ***
Comment 33 Colin Walters 2004-09-16 13:55:56 EDT
*** Bug 130617 has been marked as a duplicate of this bug. ***
Comment 34 John Bradshaw 2004-09-26 11:59:08 EDT
Seeing "Save" and "Save as" problem as described in bug 130617 (which
has been marked as a duplicate of this bug) so I'm registering my
interest in the problem against this report.  Sound recorder worked
fine in RH 9 and FC1.  System is a Dell Inspiron 7000 laptop.
Comment 35 Colin Walters 2004-09-29 23:17:39 EDT
Ok so I'd like to make a decision soon whether to keep the sound
recorder or remove it.  Has anyone here tried FC3 test2 or rawhide? 
Did the sound recorder work for you?
Comment 36 Marius Andreiana 2004-09-30 00:30:37 EDT
Works for me in FC3t2, didn't work before.
Comment 38 Michael Schwendt 2004-11-06 22:05:48 EST
With FC2 I see the same as described in comment 34 plus a fully
reproducible crash. To reproduce:

1. start gnome-sound-recorder
2. click "Record", record 1-2 seconds
3. click "Stop"
4. click "New", the a second window
5. in 2nd window, click "Record", see Error "ALSA device "default" is
already in use by another program."
6. click "Close", get Segmentation fault
Comment 39 Michael Schwendt 2004-11-06 22:26:32 EST
With FC3 RC5, results are not much different. But since this is in KDE
and I used "yum install gnome-media" so I could try
gnome-sound-recorder, probably I don't quality as tester. Some symptoms:

* When I click "Record", I see no activity whatsoever except
"Recording..." in the status line. In File Information everything is
listed as "Unknown". File Size is ~1 KiB only. After clicking "Stop",
Length is 0 seconds.

* When I "Open" a WAV file and play it once, the next time I want to
play it I get an error dialog "Internal GStreamer error: pad problem.
 File a bug".

* I seem unable to "Save As" an opened existing WAV file.

* Playback stutters near the end of a WAV file and file sounds
corrupted. Small pieces of the end of a file loop two times or so.
Comment 40 Ron Jenkins 2004-11-06 22:44:18 EST
Geez, over a year and it still doesn't work!!!
Comment 41 petrosyan 2004-11-15 22:47:29 EST
gnome-sound-recorder seems to be working fine for me on a newly
installed Fedora Core 3
Comment 42 GO 2004-12-23 22:05:47 EST
Record works fine within the tool under FC3.

However the saving of the file doesn't work.

1. A file in /tmp is created upon startup.

[go2002@primary tmp]$ ls -al gsr*
-rw-------  1 go2002 go2002 0 Dec 23 21:52 gsr-record-Untitled-6051.caCQfH

from the strace log
[go2002@primary tmp]$ grep gsr- ~/log
open("/tmp/gsr-record-Untitled-6051.caCQfH",
O_RDWR|O_CREAT|O_EXCL|O_LARGEFILE, 0600) = 16

2. If I then click on record I see a second open in the strace log.
open("/tmp/gsr-record-Untitled-6051.caCQfH",
O_RDWR|O_CREAT|O_EXCL|O_LARGEFILE,0600) = 16
open("/tmp/gsr-record-Untitled-6051.caCQfH",
O_WRONLY|O_CREAT|O_TRUNC|O_LARGEFILE, 0666) = 16

3. When I stop I see the file got written with some info:
[go2002@primary tmp]$ ls -al gsr*
-rw-------  1 go2002 go2002 285265 Dec 23 21:53
gsr-record-Untitled-6051.caCQfH

4. Now when I go to save it to disk I see the following in the strace log:
[go2002@primary tmp]$ grep gsr- ~/log
open("/tmp/gsr-record-Untitled-6051.caCQfH",
O_RDWR|O_CREAT|O_EXCL|O_LARGEFILE, 0600) = 16
open("/tmp/gsr-record-Untitled-6051.caCQfH",
O_WRONLY|O_CREAT|O_TRUNC|O_LARGEFILE, 0666) = 16
rename("/tmp/gsr-record-Untitled-6051.caCQfH",
"/home/go2002/savefile.flac") = -1 EXDEV (Invalid cross-device link)

5. However if I don't close the tool I can copy the same file to my
home disk and rename it and load that in and play it back fine.

So your workaround is to just find the 'gsr-...' file in /tmp and copy
that before you exit.  Must be an easy fix.  No idea why the rename
above is failing.
Comment 43 petrosyan 2005-01-02 23:14:38 EST
saving to a file works fine for me.
Comment 44 Helio Marques 2006-03-25 17:03:20 EST
The "save as" option is incorrectly implemented using the function rename to  
move the temporarily created file on /tmp to the destination directory. The 
rename function can not be used to move files to different file systems !  
  

Note You need to log in before you can comment on or make changes to this bug.